Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: 1 ... 7 8 [9] 10 11 ... 14   Go Down

Author Topic: bs_fantasy_ext (Version 1.4.1 Released - Critical update!)  (Read 220337 times)

0 Members and 1 Guest are viewing this topic.

SNU

  • Anope User
  • Offline Offline
  • Posts: 158
    • http://www.firstclassirc.com
Re: bs_fantasy_ext (Version 1.1.16)
« Reply #200 on: October 12, 2008, 09:21:09 PM »

As of your question I suggest you to wait for the official release of the updated module where - I think - Viper is working on.

If you're not able to patch a file and recompile its not worth to do. Just be patient.
Logged

Djk

  • Anope User
  • Offline Offline
  • Posts: 3
Re: bs_fantasy_ext (Version 1.1.16)
« Reply #201 on: October 13, 2008, 05:39:25 PM »

Hi.

Out of interest I would still like to know, whether or not the above patch works.

Kyle.
Logged

Mike

  • Anope User
  • Offline Offline
  • Posts: 2
Re: bs_fantasy_ext (Version 1.1.16)
« Reply #202 on: October 17, 2008, 02:31:43 PM »

in the bs_fantasy_ext directory use the command "patch -p1 < patch.txt"

just be careful if you are FTPing the patch file to a remote server to do it in binary mode, someone i sent the patch to couldn't get it to work and i believe that was their problem
Logged

Keiro

  • Anope User
  • Offline Offline
  • Posts: 35
Re: bs_fantasy_ext (Version 1.1.16)
« Reply #203 on: October 27, 2008, 05:32:52 PM »

What happened to the patch that Mike posted?

I saw it before, but now it's missing.

I was hoping to use it.

Obviously, compiling this module with Anope-1.7.22 fails since it's incompatible.

I'd love to have this module working as soon as possible! :)

Edit: Whoa. Ok, apparently logging in lets you see the patch. That blows, having to be logged in to even see it!

Patch time!

... Ok, I think the patch failed... not sure, but this is interesting.

ignore.h: At top level:
ignore.h:30: error: conflicting types for 'delete_ignore'
../../../include/extern.h:1014: error: previous declaration of 'delete_ignore' w                                                                                                 as here
ignore.h:30: error: conflicting types for 'delete_ignore'
../../../include/extern.h:1014: error: previous declaration of 'delete_ignore' w                                                                                                 as here
In file included from main.c:61:
ignore.c: In function `do_ignorelist':
ignore.c:97: error: incompatible types in assignment
ignore.c:102: error: structure has no member named `who'
ignore.c: In function `delete_ignore':
ignore.c:119: warning: assignment from incompatible pointer type
ignore.c:122: error: structure has no member named `who'
ignore.c: In function `do_clearignore':
ignore.c:141: error: incompatible types in assignment
ignore.c:145: error: incompatible types in assignment
*** Error code 1

Stop in /usr/home/keiro/anope-1.7.22/src/protocol/bs_fantasy_ext.
*** Error code 1

Stop in /usr/home/keiro/anope-1.7.22/src/protocol.
*** Error code 1

Stop in /usr/home/keiro/anope-1.7.22.
keiro@centaur:/home/keiro/anope-1.7.22>

This is on a shell host. >_>

Edit 2: I tried the patch again in binary mode. It succeeded, but I got the same errors as above.  :-\

Here's the patch output.

keiro@centaur:/home/keiro/anope-1.7.22/src/bs_fantasy_ext>patch -p1 < patch.txt
Hmm...  Looks like a unified diff to me...
The text leading up to this was:
--------------------------
|diff -Naur original/ban.c fixed/ban.c
|--- original/ban.c     2008-03-04 21:09:53.000000000 +0100
|+++ fixed/ban.c        2008-10-09 04:52:36.000000000 +0200
--------------------------
Patching file ban.c using Plan A...
Hunk #1 succeeded at 173.
Hunk #2 succeeded at 208.
Hunk #3 succeeded at 218.
Hunk #4 succeeded at 319.
Hmm...  The next patch looks like a unified diff to me...
The text leading up to this was:
--------------------------
|diff -Naur original/clear.c fixed/clear.c
|--- original/clear.c   2007-06-17 16:30:46.000000000 +0200
|+++ fixed/clear.c      2008-10-09 05:26:25.000000000 +0200
--------------------------
Patching file clear.c using Plan A...
Hunk #1 succeeded at 83.
Hunk #2 succeeded at 123.
Hunk #3 succeeded at 164.
Hunk #4 succeeded at 427.
Hmm...  The next patch looks like a unified diff to me...
The text leading up to this was:
--------------------------
|diff -Naur original/ignore.c fixed/ignore.c
|--- original/ignore.c  2007-06-17 16:38:52.000000000 +0200
|+++ fixed/ignore.c     2008-10-09 04:52:36.000000000 +0200
--------------------------
Patching file ignore.c using Plan A...
Hunk #1 succeeded at 73.
Hunk #2 succeeded at 94.
Hunk #3 succeeded at 108.
Hunk #4 succeeded at 124.
Hunk #5 succeeded at 134.
Hmm...  The next patch looks like a unified diff to me...
The text leading up to this was:
--------------------------
|diff -Naur original/ignore.h fixed/ignore.h
|--- original/ignore.h  2007-06-17 16:38:55.000000000 +0200
|+++ fixed/ignore.h     2008-10-09 04:52:36.000000000 +0200
--------------------------
Patching file ignore.h using Plan A...
Hunk #1 succeeded at 27.
done
keiro@centaur:/home/keiro/anope-1.7.22/src/bs_fantasy_ext>

Then... I tried recompiling anope after succeeding with the patch.

make all in bs_fantasy_ext...
gcc -pipe -g -O2 -I/usr/local/include/mysql -fno-strict-aliasing -pipe -export-dynamic -rdynamic -Wall -fPIC -DPIC -shared -I../ -I../../../include -c main.c
In file included from main.c:33:
ban.c: In function `do_unban':
ban.c:196: error: structure has no member named `bancount'
ban.c:213: error: incompatible type for argument 2 of `my_match_wild_nocase'
ban.c:214: error: incompatible type for argument 1 of `myStrGetToken'
ban.c:216: error: incompatible type for argument 2 of `my_match_wild_nocase'
ban.c:217: error: incompatible type for argument 1 of `myStrGetToken'
ban.c:225: error: incompatible types in assignment
ban.c:236: error: incompatible type for argument 2 of `delBan'
ban.c:244: error: incompatible type for argument 2 of `delBan'
ban.c:272: error: incompatible type for argument 2 of `delBan'
ban.c:311: error: structure has no member named `bancount'
ban.c:312: error: incompatible type for argument 2 of `my_match_wild_nocase'
ban.c:313: error: incompatible type for argument 2 of `my_match_wild_nocase'
ban.c:314: error: incompatible type for argument 2 of `delBan'
ban.c:325: error: incompatible type for argument 2 of `my_match_wild_nocase'
ban.c:326: error: incompatible type for argument 2 of `my_match_wild_nocase'
ban.c:327: error: incompatible type for argument 2 of `delBan'
ban.c:329: error: incompatible type for argument 2 of `my_match_wild_nocase'
ban.c:330: error: incompatible type for argument 2 of `my_match_wild_nocase'
ban.c:331: error: incompatible type for argument 2 of `delBan'
In file included from main.c:34:
shun.c: In function `do_shun':
shun.c:88: warning: long int format, time_t arg (arg 6)
shun.c:133: warning: long int format, time_t arg (arg 7)
In file included from main.c:37:
clear.c: In function `do_clear':
clear.c:88: error: structure has no member named `bancount'
clear.c:96: error: incompatible type for argument 1 of `sstrdup'
clear.c:124: error: structure has no member named `exceptcount'
clear.c:131: error: incompatible type for argument 1 of `sstrdup'
clear.c:161: error: structure has no member named `invitecount'
clear.c:168: error: structure has no member named `invite'
In file included from ignore.c:28,
                 from main.c:61:
ignore.h: At top level:
ignore.h:30: error: conflicting types for 'delete_ignore'
../../../include/extern.h:1014: error: previous declaration of 'delete_ignore' was here
ignore.h:30: error: conflicting types for 'delete_ignore'
../../../include/extern.h:1014: error: previous declaration of 'delete_ignore' was here
In file included from main.c:61:
ignore.c: In function `do_ignorelist':
ignore.c:97: error: incompatible types in assignment
ignore.c:102: error: structure has no member named `who'
ignore.c: In function `delete_ignore':
ignore.c:119: warning: assignment from incompatible pointer type
ignore.c:122: error: structure has no member named `who'
ignore.c: In function `do_clearignore':
ignore.c:141: error: incompatible types in assignment
ignore.c:145: error: incompatible types in assignment
*** Error code 1

Stop in /usr/home/keiro/anope-1.7.22/src/protocol/bs_fantasy_ext.
*** Error code 1

Stop in /usr/home/keiro/anope-1.7.22/src/protocol.
*** Error code 1

Stop in /usr/home/keiro/anope-1.7.22.
keiro@centaur:/home/keiro/anope-1.7.22>

Any ideas, guys?
« Last Edit: October 27, 2008, 06:02:25 PM by Keiro »
Logged

SNU

  • Anope User
  • Offline Offline
  • Posts: 158
    • http://www.firstclassirc.com
Re: bs_fantasy_ext (Version 1.1.16)
« Reply #204 on: October 27, 2008, 06:49:24 PM »

Try the same using the most recent Version of Anope ( 1.8 RC1 ).
If the output is exactly the same, tell it. Otherwise tell it, too. But I think there will be no Support vor 1.7-Versions anymore :D

And I also think if Viper has done his part finishing the Core he will go on fixing his nice modules. :D
Logged

Keiro

  • Anope User
  • Offline Offline
  • Posts: 35
Re: bs_fantasy_ext (Version 1.1.16)
« Reply #205 on: October 28, 2008, 09:12:35 PM »

Will do!

I'll report back after I've set up a test network for this purpose as I'd rather not try to set it up on my network at the moment.

Be back in a while with the info.
Logged

Raffaele Nntifrega

  • Anope User
  • Offline Offline
  • Posts: 7
with 1.8
« Reply #206 on: November 02, 2008, 06:31:30 PM »

i tried the latest patch from mike... but it didn't work:
Code: [Select]
hi@test:~/anope-1.8.0-rc1/src/modules/bs_fantasy_ext$ patch -p1 < bs_patch.diff
patching file ban.c
Hunk #1 FAILED at 173.
Hunk #2 FAILED at 208.
Hunk #3 FAILED at 218.
Hunk #4 FAILED at 319.
4 out of 4 hunks FAILED -- saving rejects to file ban.c.rej
patching file clear.c
Hunk #1 FAILED at 83.
Hunk #2 FAILED at 123.
Hunk #3 FAILED at 164.
Hunk #4 FAILED at 427.
4 out of 4 hunks FAILED -- saving rejects to file clear.c.rej
patching file ignore.c
Hunk #1 FAILED at 73.
Hunk #2 FAILED at 94.
Hunk #3 FAILED at 108.
Hunk #4 FAILED at 124.
Hunk #5 FAILED at 134.
5 out of 5 hunks FAILED -- saving rejects to file ignore.c.rej
patching file ignore.h
patch unexpectedly ends in middle of line
Hunk #1 FAILED at 27.
1 out of 1 hunk FAILED -- saving rejects to file ignore.h.rej
Logged

tehsu

  • Anope User
  • Offline Offline
  • Posts: 1
Re: bs_fantasy_ext (Version 1.1.16)
« Reply #207 on: November 03, 2008, 07:02:50 AM »

Yeah, wish this could get updated asap for 1.8, greatly appreciate it.
Logged

F1r3f0x

  • Anope User
  • Offline Offline
  • Posts: 1
Re: with 1.8
« Reply #208 on: November 03, 2008, 07:57:16 PM »

i tried the latest patch from mike... but it didn't work:
Code: [Select]
hi@test:~/anope-1.8.0-rc1/src/modules/bs_fantasy_ext$ patch -p1 < bs_patch.diff
patching file ban.c
Hunk #1 FAILED at 173.
Hunk #2 FAILED at 208.
Hunk #3 FAILED at 218.
Hunk #4 FAILED at 319.
4 out of 4 hunks FAILED -- saving rejects to file ban.c.rej
patching file clear.c
Hunk #1 FAILED at 83.
Hunk #2 FAILED at 123.
Hunk #3 FAILED at 164.
Hunk #4 FAILED at 427.
4 out of 4 hunks FAILED -- saving rejects to file clear.c.rej
patching file ignore.c
Hunk #1 FAILED at 73.
Hunk #2 FAILED at 94.
Hunk #3 FAILED at 108.
Hunk #4 FAILED at 124.
Hunk #5 FAILED at 134.
5 out of 5 hunks FAILED -- saving rejects to file ignore.c.rej
patching file ignore.h
patch unexpectedly ends in middle of line
Hunk #1 FAILED at 27.
1 out of 1 hunk FAILED -- saving rejects to file ignore.h.rej


hi,
i manuelly applied the patch to the files, because i got the same errors.
now (after uploading and re-compiling) the module can be loaded, but its the same error as before....

User1 typed this in #channel:

Code: [Select]
* User1 sets mode: +b *!*@123.456.789.000
(User1) !unban User2

Then this happens:

Code: [Select]
*** Global -- from services.server.com: PANIC! buffer = :User1 ! #channel :!unban User2
and all Services quit.

pls help mee!!

PS: Sry for my bad english :(
Logged

SNU

  • Anope User
  • Offline Offline
  • Posts: 158
    • http://www.firstclassirc.com
Re: bs_fantasy_ext (Version 1.1.16)
« Reply #209 on: November 04, 2008, 03:59:04 PM »

Hi.
Don't expect support for your issue. If you get it then you can qiet be happy.
I tell you this because:
- the author of the module already told he won't support this patch.
- As currently told, the patch is made to work on 1.7.22 not on further versions.

I suggest anybody to be patient and maybe to be "motivizing" the devs (by donating or joking around with them) but not to harass them. I think making anope 1.8 final is the primary goal. After that, there will possibly be updates for the modules.

[edit] Currently I see viper has got a little time to patch his modules, maybe being really patient will give us an updated module ;)

greets.
« Last Edit: November 04, 2008, 04:16:22 PM by SNU »
Logged

casper1256

  • Anope User
  • Offline Offline
  • Posts: 39
    • http://www.chatspecial.nl
Re: bs_fantasy_ext (Version 1.1.16)
« Reply #210 on: November 04, 2008, 05:22:16 PM »

Hi.
Don't expect support for your issue. If you get it then you can qiet be happy.
I tell you this because:
- the author of the module already told he won't support this patch.
- As currently told, the patch is made to work on 1.7.22 not on further versions.

I suggest anybody to be patient and maybe to be "motivizing" the devs (by donating or joking around with them) but not to harass them. I think making anope 1.8 final is the primary goal. After that, there will possibly be updates for the modules.

[edit] Currently I see viper has got a little time to patch his modules, maybe being really patient will give us an updated module ;)

greets.

I guess I'll have to wait with the updating then....
Logged
Network Administrator
ChatSpecial.nl

SNU

  • Anope User
  • Offline Offline
  • Posts: 158
    • http://www.firstclassirc.com
Re: bs_fantasy_ext (Version 1.1.16)
« Reply #211 on: November 04, 2008, 05:37:26 PM »

Thats what I meant :D
Logged

faceman

  • Anope User
  • Offline Offline
  • Posts: 2
Re: bs_fantasy_ext (Version 1.1.16)
« Reply #212 on: November 23, 2008, 02:41:45 PM »

*trying* to wait patiently for a 1.8.0-rc1 release*
Logged

ayie

  • Anope User
  • Offline Offline
  • Posts: 4
Re: bs_fantasy_ext (Version 1.1.16)
« Reply #213 on: December 19, 2008, 03:16:17 AM »

I use anope 1.8.0rc1

i do make modules and make install without problem, but i dont see any bs_fantasy_ext file in services modules folder.
when i try /os modload bs_fantasy_ext, it said Unable to load module bs_fantasy_ext

Logged

TwinShadow

  • Anope User
  • Offline Offline
  • Posts: 64
    • ShadowHime
Re: bs_fantasy_ext (Version 1.1.16)
« Reply #214 on: December 19, 2008, 04:18:33 AM »

Because the last version that this module officially supports is 1.7.21. Other than that, a new update will come eventually, but not until after 1.8 is released.
Logged

Jan Milants

  • Team
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1372
Re: bs_fantasy_ext (Version 1.1.16)
« Reply #215 on: December 26, 2008, 09:07:20 PM »

I do not know if anyone was still using the French language file, but it s gotten hopelessly outdated.. if anyone s willing to update it, contact me. If no1 volunteers it will be left out of the next release.. I use a new language backend, so it either gets updated or is left out.

And yeah.. just a bit more patience.. i have an early beta running on my 1.8 testnet atm  ;)
Not so much added/changed on the user-side, but did some changes to how the back-end looks like.

edit: btw, i ll need a few ppl with a test to test the fist closed betas.. and no you can't try it on a live net cuz they are still wayy too prone to crashes.. trust me on that one  ::)
« Last Edit: December 27, 2008, 12:59:03 AM by Viper »
Logged
If you like me donate coins to 1FBmZVT4J8WAUMHKqpWhgNVj3XXnRN1cCk :)

TwinShadow

  • Anope User
  • Offline Offline
  • Posts: 64
    • ShadowHime
Re: bs_fantasy_ext (Version 1.1.16)
« Reply #216 on: December 27, 2008, 09:37:09 PM »

I suppose I can do a bit of beta testing on my laptop, as it does run Linux anyway. I do some local testing on here for my IRCd, but.. I have learned that some stuff work fine on here, than on my live net for some reason.. oh well.

But yeah, I can help with beta stuff for now.
Logged

Jan Milants

  • Team
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1372
bs_fantasy_ext 1.2.0 RC1
« Reply #217 on: December 28, 2008, 12:19:28 PM »

Since there were no real issues with the beta I decided to give it away to a broader audience as a public RC..

http://vips.hopto.org/~viper/bs_fantasy_ext-1.2.0-RC1.tar.gz

The changelog isn't that big:
Code: [Select]
  A  Introduced new language system to replace the cores lang system for modules.
  A  Added configuration directive which when set ignores users with +B. (Unreal & PTlink)
  C  Clients on ulined servers no longer show up in !staff. This eliminates the need to add an exemption for every network service.
  U  Synchronized module code with Anope 1.8.0.
  U  Updated flags.
  F  Fixed crashbug in !set nobot.
  F  Fixed several issues found in the core.
  F  Fixed markup codes no longer being loaded properly.
  F  Now unloads languages upon unload and reloads when the config is reloaded.

I also need some feedback on this item in my todolist..
Quote
- Update help system to no longer show commands if users do not have access to them.
   --> not sure whether this is worth the trouble.. it would cause the help to be
      different, depending on which channel the command is given. Might cause too much confusion.
      Any input on this is appreciated, though atm, i tend more to not implementing it.
as said, i m leaning towards scratching the idea as it will likely just cause more confusion.. and it s a lot of work to implement as i d have to tear up the help entries in the lang files... so unless some1 has any gd points this won't be implemented..
« Last Edit: December 28, 2008, 12:22:34 PM by Viper »
Logged
If you like me donate coins to 1FBmZVT4J8WAUMHKqpWhgNVj3XXnRN1cCk :)

TwinShadow

  • Anope User
  • Offline Offline
  • Posts: 64
    • ShadowHime
Re: bs_fantasy_ext (Version 1.1.16)
« Reply #218 on: December 28, 2008, 11:17:03 PM »

Hm, it seems the module fails to compile on my system.

Code: [Select]
make[2]: Entering directory `/home/[removed]/irc/anope-1.8.0-rc1/src/modules/bs_fantasy_ext'
Makefile:18: warning: overriding commands for target `clean'
../Makefile.sub:25: warning: ignoring old commands for target `clean'
(cd lang ; make 'CFLAGS=-pipe -g -O2 -I/usr/include/mysql  -DBIG_JOINS=1 -fPIC -export-dynamic' 'CC=gcc' 'ANOPELIBS=-lnsl -lresolv  -ldl' 'LDFLAGS=-Wl,-Bsymbolic-functions -rdynamic -L/usr/lib/mysql -lmysqlclient' 'BINDEST=/home/[removed]/irc/services' 'INSTALL=/usr/bin/install' 'INCLUDEDIR=../include' 'RM=/bin/rm' 'CP=/bin/cp' 'TOUCH=/usr/bin/touch' 'SHELL=/bin/sh' 'DATDEST=/home/[removed]/irc/services' 'RUNGROUP=' 'MODULE_PATH=/home/[removed]/irc/services/modules/' 'PROFILE=' 'SHARED=-shared' 'MODULEFLAGS=-fPIC -DPIC -shared' spotless all index.h ; )
make[3]: Entering directory `/home/[removed]/irc/anope-1.8.0-rc1/src/modules/bs_fantasy_ext/lang'
rm -f en_us langcomp index.h
rm -f index
gcc -pipe -g -O2 -I/usr/include/mysql  -DBIG_JOINS=1 -fPIC -export-dynamic langcomp.c -o langcomp
grep '^[A-Z]' en_us.l >index
./langcomp en_us.l
Generating index.h... 195 strings
cp index.h ../
make[3]: Leaving directory `/home/[removed]/irc/anope-1.8.0-rc1/src/modules/bs_fantasy_ext/lang'
gcc -pipe -g -O2 -I/usr/include/mysql  -DBIG_JOINS=1 -fPIC -export-dynamic -rdynamic -Wall -fPIC -DPIC -shared -I../ -I../../../include -c main.c
In file included from main.h:23,
                 from main.c:24:
config.h:79: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘AppendToTopicDel’
In file included from main.c:29:
misc.c: In function ‘get_flags’:
misc.c:639: error: ‘MaxUnbanIP’ undeclared (first use in this function)
misc.c:639: error: (Each undeclared identifier is reported only once
misc.c:639: error: for each function it appears in.)
In file included from main.c:30:
misc_cmds.c: In function ‘append_to_topic’:
misc_cmds.c:83: error: ‘AppendToTopicDel’ undeclared (first use in this function)
In file included from main.c:33:
ban.c: In function ‘do_unban’:
ban.c:263: error: ‘MaxUnbanIP’ undeclared (first use in this function)
In file included from main.c:52:
akick.c: In function ‘akick_view’:
akick.c:538: warning: format not a string literal and no format arguments
akick.c:538: warning: format not a string literal and no format arguments
make[2]: *** [main.o] Error 1
make[2]: Leaving directory `/home/[removed]/irc/anope-1.8.0-rc1/src/modules/bs_fantasy_ext'

I'm not too entirely sure why it's doing that right now. I'm using Linux Mint 6 "Felicia", based off of Ubuntu 8.10 Intrepid Ibex. I just find it a bit odd right now.
Logged

Jan Milants

  • Team
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1372
Re: bs_fantasy_ext (Version 1.1.16)
« Reply #219 on: December 29, 2008, 02:15:18 PM »

Quote
config.h:79: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘AppendToTopicDel’
i m guessing you edited config.h and messed up somewhere..  :-\
Logged
If you like me donate coins to 1FBmZVT4J8WAUMHKqpWhgNVj3XXnRN1cCk :)

TwinShadow

  • Anope User
  • Offline Offline
  • Posts: 64
    • ShadowHime
Re: bs_fantasy_ext (Version 1.1.16)
« Reply #220 on: December 29, 2008, 04:20:42 PM »

Guess I did, I'll have a look later today. Somewhat busy for the afternoon for me. (for my timezone anyway)

We all love edits. XP
I did some testing with the module, and nothing serious came up. I've done some testing of the commands, and so far, the ones I did try have worked just fine. Will probably look more later on.
« Last Edit: December 29, 2008, 10:09:04 PM by TwinShadow »
Logged

Jan Milants

  • Team
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1372
bs_fantasy_ext 1.2.0 RC2
« Reply #221 on: January 11, 2009, 04:31:29 PM »

ok apparently RC1 had a serious crashbug in !unban, however all previous versions of bs_fantasy_ext are also vulnerable to an exploit in !unban allowing attackers to guess the IP of users whose IP did not resolve AND who have no vhost set. So while rare, it s a serious issue. There is more though.. while IPs were being protected in the previous versions, with the exception of earlier mentioned exploit, masks were not. though harder to guess, attackers could reconstruct a users' mask and then resolve it the the IP.. same result, though a much harder approach.
Also be aware that the anope !unban command is vulnerable to all of these, which is why it was removed as a core feature in 1.7.22...

All of this should be fixed in 1.2.0 RC2 so I encourage people to do some serious testing with the !unban command and report your findings back to me..
Because of the exploit (for which code is already publicly available) as well as the crashbug in 1.1.16 I recommend people move away from these older versions of the module asap. If you cannot for some reason, I recommend you disable both !unban and !set immediately (cf config.h).

I should also note that 1.2.0 RC2 does not yet compile on windows and since my laptop s been send back to the oem for rma I do not know whether I will have it back in time for windows support to be added to 1.2.0. Since there is no release of this module which supports any of the latest anope releases I am not willing to wait and will release without windows support if needed..

I really need some feedback on this RC... if noone bothers testing it and everyone just waits for 1.2.0 final the final won't be any better then the release candidates..  ::)

Download: http://vips.hopto.org/~viper/bs_fantasy_ext-1.2.0-RC2.tar.gz
Logged
If you like me donate coins to 1FBmZVT4J8WAUMHKqpWhgNVj3XXnRN1cCk :)

Joeyexa

  • Anope User
  • Offline Offline
  • Posts: 1
Re: bs_fantasy_ext (Version 1.2.0 :: RC2 Released)
« Reply #222 on: January 11, 2009, 04:48:07 PM »

!admins bug in 1.2 rc2:

[11:45:30] -OperServ- The following Administrators are online:
[11:45:30] -OperServ- -----------------------------------------------------------------------
[11:45:30] <&Global> bs_fantasy_ext: INVALID language string call, language:
  • , String [24]
  • [11:45:30] -OperServ- Joey             - 
    [11:45:30] <&Global> bs_fantasy_ext: INVALID language string call, language:
  • , String [24]
  • [11:45:30] -OperServ- MJay             - 
    [11:45:30] <&Global> bs_fantasy_ext: INVALID language string call, language:
  • , String [24]
  • [11:45:30] -OperServ- Scotty           - 
    [11:45:30] -OperServ- -----------------------------------------------------------------------
    [11:45:30] -OperServ- Total Avalable Admins: 3
Logged

Jan Milants

  • Team
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1372
Re: bs_fantasy_ext (Version 1.2.0 :: RC2 Released)
« Reply #223 on: January 11, 2009, 05:08:27 PM »

was also in RC1... makes me wonder how many ppl actually bother testing..  ::)
nice catch though Joey...

Download RC2 again from the same link... only needed a quick update
Logged
If you like me donate coins to 1FBmZVT4J8WAUMHKqpWhgNVj3XXnRN1cCk :)

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
Re: bs_fantasy_ext (Version 1.2.0 :: RC2 Released)
« Reply #224 on: January 11, 2009, 08:20:38 PM »

Slight typo in "Available" there too.
Logged
Pages: 1 ... 7 8 [9] 10 11 ... 14   Go Up