Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: unrealircd and anope  (Read 4529 times)

0 Members and 1 Guest are viewing this topic.

mrlily

  • Anope User
  • Offline Offline
  • Posts: 2
unrealircd and anope
« on: November 21, 2009, 03:44:14 PM »

hi, i'm having problems linking anope and unrealircd, error is: Read error from server: No such file or directory (error num: 2), files below, can you please help?




log file;

[Nov 21 23:16:51 2009] Module hs_request compiled against current version of Anope 2558
[Nov 21 23:16:51 2009] TS6 not supported on this ircd
[Nov 21 23:16:51 2009] serv_uplink is (nil) and status is 0
[Nov 21 23:16:51 2009] TS6 not supported on this ircd
[Nov 21 23:16:51 2009] serv_uplink is (nil) and status is 0
[Nov 21 23:16:51 2009] TS6 not supported on this ircd
[Nov 21 23:16:51 2009] serv_uplink is (nil) and status is 0
[Nov 21 23:16:51 2009] TS6 not supported on this ircd
[Nov 21 23:16:51 2009] serv_uplink is (nil) and status is 0
[Nov 21 23:16:51 2009] TS6 not supported on this ircd
[Nov 21 23:16:51 2009] serv_uplink is (nil) and status is 0
[Nov 21 23:16:51 2009] TS6 not supported on this ircd
[Nov 21 23:16:51 2009] serv_uplink is (nil) and status is 0
[Nov 21 23:16:51 2009] TS6 not supported on this ircd
[Nov 21 23:16:51 2009] serv_uplink is (nil) and status is 0
[Nov 21 23:16:51 2009] Databases loaded
[Nov 21 23:16:51 2009] Info: Reflecting database records.
[Nov 21 23:16:51 2009] Connected to Server 1 (127.0.0.1:7070)
[Nov 21 23:16:52 2009] Read error from server: No such file or directory (error num: 2)




unrealircd.conf file;

link    services.localhost.net
{
   username   *;
   hostname    127.0.0.1;
   bind-ip    *;
   port       7070;
   hub             *;
   password-connect "password";
   password-receive "password";
   class           servers;
      options {
         /* Note: You should not use autoconnect when linking services */
         
      //autoconnect;
         ssl;
         zip;
      };
};



services.conf file;

/*
 * [REQUIRED] IRCd Config
 *
 * This section is used to set up Anope to connect to your IRC network.
 * This section can be included multiple times, and Anope will attempt to
 * connect to each server until it finally connects.
 */
uplink
{
   /*
    * The IP or hostname of the IRC server you wish to connect Services to.
    * Usually, you will want to connect Services over 127.0.0.1 (aka localhost).
    *
    * NOTE: On some shell providers, this will not be an option.
    */

   host = "127.0.0.1"

   /*
    * The port to connect to.
    * The IRCd *MUST* be configured to listen on this port, and to accept
    * server connections.
    *
    * Refer to your IRCd documentation for how this is to be done.
    */
   port = 7070

   /*
    * The password to send to the IRC server for authentication.
    * This must match the link block on your IRCd.
    *
    * Refer to your IRCd documentation for more information on link blocks.
    */
   password = "password"

}

/*
 * [REQUIRED] Server Information
 *
 * This section contains information about the Services server.
 */
serverinfo
{
   /*
    * The hostname that Services will be seen as, it must have no conflicts with any
    * other server names on the rest of your IRC network. Note that it does not have
    * to be an existing hostname, just one that isn't on your network already. This
    * can be overridden with the -name command-line option when starting Services.
    */
   name = "services.localhost.net"

   /*
    * The text which should appear as the server's information in /whois and similar
    * queries. This can be overridden by the -desc command-line option when starting
    * Services.
    */
   description = "Services for IRC Networks"

   /*
    * The local address that Services will bind to before connecting to the remote
    * server. This may be useful for multihomed hosts. If neither of these are given,
    * Services will let the Operating System choose the local address. If only a
    * hostname is specified, Services will bind to that address but let the Operating
    * System choose the local port. These directives are optional, and may be overridden
    * with the -local command-line option when starting Services.
    *
    * If you don't know what this means or don't need to use it, just leave these
    * directives commented out.
    */
   //#localhost = "nowhere."
   //#localport = 0

   /*
    * This directive instructs Anope which IRCd Protocol to speak when connecting.
    * You MUST modify this to match the IRCd you run.
    *
    * Supported:
    *  - inspircd11
    *  - inspircd12
    *  - ratbox
    *  - bahamut
    *  - unreal32
    */
   type = "inspircd11"

   /*
    * What Server ID to use for this connection?
    * Note: This should *ONLY* be used for TS6/P10 IRCds. Refer to your IRCd documentation
    * to see if this is needed.
    */
   #id = "00A"

   /*
    * These identify the ident@hostname which will be used by the Services pesudoclients.
    * They can be overridden by the -user and -host command-line options when starting
    * Services.
    */
   ident = "services"
   hostname = "localhost.net"

   /*
    * The filename containing the Services process ID. The path is relative to the
    * services executable. If not given, defaults to "services.pid".
    */
   pid = "services.pid"

   /*
    * The filename containing the Message of the Day. The path is relative to the
    * services executable. If not given, defaults to "services.motd".
    */
   motd = "services.motd"
}

/*




Logged

LEthaLity

  • Team
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 307
    • LEthaLity
Re: unrealircd and anope
« Reply #1 on: November 21, 2009, 04:18:04 PM »

you need to decide which ircd it is, if it is unreal then you dont want to be using the inspircd protocol module.

/*
    * This directive instructs Anope which IRCd Protocol to speak when connecting.
    * You MUST modify this to match the IRCd you run.
    *
    * Supported:
    *  - inspircd11
    *  - inspircd12
    *  - ratbox
    *  - bahamut
    *  - unreal32
    */
   type = "inspircd11"    needs to be unreal32.
If it's unreal you also dont want UseTs6 to be uncommented, i cant see if you do or not, or whether the inspircd module is giving that error.
Logged

mrlily

  • Anope User
  • Offline Offline
  • Posts: 2
Re: unrealircd and anope
« Reply #2 on: November 22, 2009, 04:43:05 AM »

LEthaLity, ok, that worked. thanks.

next step is to learn how to use the service.
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
Re: unrealircd and anope
« Reply #3 on: November 22, 2009, 10:18:17 AM »

Answer is read the documentation / this forum.
Logged
Pages: [1]   Go Up