Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: FreeBSD 1.9.0-p1 Problem?  (Read 6769 times)

0 Members and 1 Guest are viewing this topic.

Izv143

  • Anope User
  • Offline Offline
  • Posts: 36
    • www.krajinalive.com
FreeBSD 1.9.0-p1 Problem?
« on: October 11, 2009, 08:26:34 AM »

I had problem installing anope-1.9.0-p1 on FreeBSD, it says finished and installed but when I open folder services thare arejust 2 folders bin and data, nothing else. Any help ??
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
Re: FreeBSD 1.9.0-p1 Problem?
« Reply #1 on: October 11, 2009, 12:31:26 PM »

Hi,

I split your post into its own thread because it had absolutely NOTHING to do with the thread you posted in. Please do not do that again.

What you are seeing is correct, look inside those directories and you will see the relevant files.

A little bit of investigation on your own part would have easily solved this.
Logged

Izv143

  • Anope User
  • Offline Offline
  • Posts: 36
    • www.krajinalive.com
Re: FreeBSD 1.9.0-p1 Problem?
« Reply #2 on: October 12, 2009, 11:16:34 AM »

Sorry for that Charles
But still I can't solve my problem, if is problem gcc I can't do anything koz my irc server and services are on shell which I have bought from shell provider. Can you give some directions how to solve this pls.
Thank You
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
Re: FreeBSD 1.9.0-p1 Problem?
« Reply #3 on: October 12, 2009, 11:21:54 AM »

cd bin
services -version

Post the output.
Logged

Naram Qashat

  • Team
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 192
    • CBX's Sprite Animations
Re: FreeBSD 1.9.0-p1 Problem?
« Reply #4 on: October 12, 2009, 04:56:32 PM »

I would find it impossible for Anope to not work under FreeBSD unless it's FreeBSD 4.x, since all versions of FreeBSD since 5.x come with at least gcc 3.x.  Plus, I personally develop Anope while under FreeBSD, so if it wasn't working, I'd know immediately.
Logged

Izv143

  • Anope User
  • Offline Offline
  • Posts: 36
    • www.krajinalive.com
Re: FreeBSD 1.9.0-p1 Problem?
« Reply #5 on: October 13, 2009, 01:47:16 PM »

cd bin
services -version

Post the output.

- (~/services/bin) - ./services -version
Anope-1.9.0-p1 (2277)   -- build #1, compiled Oct 13 2009 14:04:27
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
Re: FreeBSD 1.9.0-p1 Problem?
« Reply #6 on: October 13, 2009, 04:34:03 PM »

It's fine then.

I suggest you look in data and read the documentation.
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
Re: FreeBSD 1.9.0-p1 Problem?
« Reply #7 on: October 14, 2009, 09:51:40 AM »

huh?
Logged

Izv143

  • Anope User
  • Offline Offline
  • Posts: 36
    • www.krajinalive.com
Re: FreeBSD 1.9.0-p1 Problem?
« Reply #8 on: October 14, 2009, 12:34:53 PM »

huh?

What do u mean ?
By the way i solved the problem works now just i do not have ChanServ on my channels like I use to have :(
Logged

Naram Qashat

  • Team
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 192
    • CBX's Sprite Animations
Re: FreeBSD 1.9.0-p1 Problem?
« Reply #9 on: October 14, 2009, 06:44:38 PM »

You probably had a module to do that, it's not a default thing for Anope.  However, you can manually assign ChanServ as a BotServ bot to your channels, it's just not automatic.
Logged
Pages: [1]   Go Up