Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: Can't use shortcut commands  (Read 5085 times)

0 Members and 1 Guest are viewing this topic.

Pkerown

  • Anope User
  • Offline Offline
  • Posts: 6
Can't use shortcut commands
« on: September 05, 2009, 09:09:27 PM »

I can't use the shortcut commands for *serv (/os help, /ns help, /hs help etc.)

I'm using Linux with FreeBSD. Using anope 1.8.2

Nor can I use !kb, !mute, etc.

Any fix to this?
Logged

TwinShadow

  • Anope User
  • Offline Offline
  • Posts: 64
    • ShadowHime
Re: Can't use shortcut commands
« Reply #1 on: September 05, 2009, 09:11:34 PM »

This isn't an Anope issue, rather an IRCd one. You need to configure the IRCd for aliases, and I believe Unreal and InspIRCd both come with pre-configured aliases configurations for Anope, so all you have to do is enable them.
Logged

Pkerown

  • Anope User
  • Offline Offline
  • Posts: 6
Re: Can't use shortcut commands
« Reply #2 on: September 05, 2009, 09:20:15 PM »

How do I enable them?
Logged

Jan Milants

  • Team
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1372
Re: Can't use shortcut commands
« Reply #3 on: September 05, 2009, 10:41:24 PM »

hard to say if you don't even mention the ircd you use :)
Logged
If you like me donate coins to 1FBmZVT4J8WAUMHKqpWhgNVj3XXnRN1cCk :)

Pkerown

  • Anope User
  • Offline Offline
  • Posts: 6
Re: Can't use shortcut commands
« Reply #4 on: September 06, 2009, 08:33:14 AM »

anope + UnrealIRCd

EDIT: got it working, just had to restart services.
« Last Edit: September 06, 2009, 09:21:02 AM by Pkerown »
Logged

Pkerown

  • Anope User
  • Offline Offline
  • Posts: 6
Re: Can't use shortcut commands
« Reply #5 on: September 06, 2009, 09:52:31 PM »

Can't use !access add name level for some reason, how do I fix?
Logged

TwinShadow

  • Anope User
  • Offline Offline
  • Posts: 64
    • ShadowHime
Re: Can't use shortcut commands
« Reply #6 on: September 07, 2009, 02:18:30 AM »

I believe to use those commands, you need to have fantasy enabled, have the right access in the list, and have a botserv bot in the channel.

To enable fantasy commands: /bs set #channel fantasy on
Logged

Pkerown

  • Anope User
  • Offline Offline
  • Posts: 6
Re: Can't use shortcut commands
« Reply #7 on: September 07, 2009, 08:35:03 AM »

Got a bot in channel (by BotServ), turned Fantasy on, and I'm founder of the channel with superadmin privileges.

Still didn't work.
Logged

Jobe

  • Contributor
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1023
    • Anope IRC Services
Re: Can't use shortcut commands
« Reply #8 on: September 07, 2009, 11:05:54 AM »

Fantasy commands such as !access and !aop require the use of the module bs_fantasy_ext
Logged
Your IP: ()
My IRC Status:

Come along and visit http://www.anopequotes.org/

Pkerown

  • Anope User
  • Offline Offline
  • Posts: 6
Re: Can't use shortcut commands
« Reply #9 on: September 21, 2009, 08:24:08 PM »

How would I install it bs_fantasy_ext on FreeBSD? I have SSH access, do I need to be root?
Logged

Jan Milants

  • Team
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1372
Re: Can't use shortcut commands
« Reply #10 on: September 21, 2009, 10:13:06 PM »

last I checked I provided a file called INSTALL in the bs_fantasy_ext package...
Logged
If you like me donate coins to 1FBmZVT4J8WAUMHKqpWhgNVj3XXnRN1cCk :)
Pages: [1]   Go Up