Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: Inspircd 1.2 Issue  (Read 3082 times)

0 Members and 1 Guest are viewing this topic.

Allen

  • Anope User
  • Offline Offline
  • Posts: 2
Inspircd 1.2 Issue
« on: September 03, 2009, 12:24:08 AM »

hello all,
Everytime I attempt to link anope with inspircd I get this message

[ 5:01 PM]   ===   *** LINK: Verified incoming server connection from Services.Blizzard[127.0.0.1] (Expermimental Services for Blizzard)
[ 5:01 PM]   ===   *** LINK: Bursting to Services.Blizzard (Authentication: plaintext password).
[ 5:01 PM]   ===   *** LINK: Finished bursting to Services.Blizzard.
[ 5:01 PM]   ===   *** REMOTECONNECT: Client connecting at Services.Blizzard: BotServ!services@blizzard.serveirc.com [0.0.0.0] [Bot Service]
[ 5:01 PM]   ===   *** REMOTECONNECT: Client connecting at Services.Blizzard: ChanServ!services@blizzard.serveirc.com [0.0.0.0] [Channel Registration Service]
[ 5:01 PM]   ===   *** REMOTECONNECT: Client connecting at Services.Blizzard: Global!services@blizzard.serveirc.com [0.0.0.0] [Global Noticer]
[ 5:01 PM]   ===   *** REMOTECONNECT: Client connecting at Services.Blizzard: HelpServ!services@blizzard.serveirc.com [0.0.0.0] [Help Service]
[ 5:01 PM]   ===   *** REMOTECONNECT: Client connecting at Services.Blizzard: HostServ!services@blizzard.serveirc.com [0.0.0.0] [vHost Service]
[ 5:01 PM]   ===   *** REMOTECONNECT: Client connecting at Services.Blizzard: MemoServ!services@blizzard.serveirc.com [0.0.0.0] [Memo Service]
[ 5:01 PM]   ===   *** REMOTECONNECT: Client connecting at Services.Blizzard: NickServ!services@blizzard.serveirc.com [0.0.0.0] [Nickname Registration Service]
[ 5:01 PM]   ===   *** REMOTECONNECT: Client connecting at Services.Blizzard: OperServ!services@blizzard.serveirc.com [0.0.0.0] [Operator Service]
[ 5:01 PM]   ===   *** LINK: Sent ERROR to Services.Blizzard: Unrecognised or malformed command '12I ENDBURST' -- possibly loaded mismatched modules
[ 5:01 PM]   ===   *** LINK: Server Services.Blizzard split: Remote host closed the connection
[ 5:01 PM]   ===   *** LINK: Netsplit complete, lost 8 users on 1 servers.
[ 5:01 PM]   ===   *** LINK: Connection to 'Services.Blizzard' failed.
[ 5:01 PM]   ===   *** REMOTEQUIT: Client exiting on server Services.Blizzard: MemoServ!services@blizzard.serveirc.com [blizzard.serveirc.com Services.Blizzard]
[ 5:01 PM]   ===   *** REMOTEQUIT: Client exiting on server Services.Blizzard: OperServ!services@blizzard.serveirc.com [blizzard.serveirc.com Services.Blizzard]
[ 5:01 PM]   ===   *** REMOTEQUIT: Client exiting on server Services.Blizzard: HelpServ!services@blizzard.serveirc.com [blizzard.serveirc.com Services.Blizzard]
[ 5:01 PM]   ===   *** REMOTEQUIT: Client exiting on server Services.Blizzard: NickServ!services@blizzard.serveirc.com [blizzard.serveirc.com Services.Blizzard]
[ 5:01 PM]   ===   *** REMOTEQUIT: Client exiting on server Services.Blizzard: Global!services@blizzard.serveirc.com [blizzard.serveirc.com Services.Blizzard]
[ 5:01 PM]   ===   *** REMOTEQUIT: Client exiting on server Services.Blizzard: BotServ!services@blizzard.serveirc.com [blizzard.serveirc.com Services.Blizzard]
[ 5:01 PM]   ===   *** REMOTEQUIT: Client exiting on server Services.Blizzard: ChanServ!services@blizzard.serveirc.com [blizzard.serveirc.com Services.Blizzard]
[ 5:01 PM]   ===   *** REMOTEQUIT: Client exiting on server Services.Blizzard: HostServ!services@blizzard.serveirc.com [blizzard.serveirc.com Services.Blizzard]

Im guessing its a module that I forgot to load on inspircd. I dont really know. im new to 1.2 and anope running Windows using 1.9.0-p1. Please Help.
Thanks!
« Last Edit: September 03, 2009, 01:04:01 AM by Allen »
Logged

LEthaLity

  • Team
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 303
    • LEthaLity
Re: Inspircd 1.2 Issue
« Reply #1 on: September 03, 2009, 01:22:48 AM »

http://forum.anope.org/index.php?topic=2841.0

I'm guessing you need this (fixed protocol module)
http://anope.svn.sourceforge.net/viewvc/anope/tags/1.9.0p1/src/protocol/inspircd12.cpp
place it in the src/protocol directory of your anope source and recompile
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
Re: Inspircd 1.2 Issue
« Reply #2 on: September 03, 2009, 07:41:10 AM »

Hi,

We recently packaged the updated inspircd.cpp into a 1.9.0-p1 package you can get from:

http://www.anope.org/downloads/anope-1.9.0p1-inspircd12.tar.gz

http://www.anope.org/downloads/anope-1.9.0p1-inspircd12.md5sum.txt
Logged
Pages: [1]   Go Up