Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: A few bugs I noticed  (Read 5501 times)

0 Members and 1 Guest are viewing this topic.

Sm0ke0ut

  • Anope User
  • Offline Offline
  • Posts: 9
A few bugs I noticed
« on: July 17, 2009, 05:32:54 PM »

Dear user/moderator/developer,

I'm testing the new anope 1.9 services, and I noticed some errors. But before i'll make an official bug-report I want to know if some other people are experience the same problems and if (there is) someone can give me any solutions to the problems I've noticed:

Code: [Select]
Travian IRC test network (inspird 1.2 SVN 11442. + Anope 1.9 SVN 2382.)

#1 BOTSERV > ASSIGN (able to assign default service nicknames)
[Jul 17 18:14:29.605051 2009] debug: Creating channel #test
[Jul 17 18:14:29.605108 2009] debug: Sm0ke0ut joins #test
[Jul 17 18:14:29.605145 2009] debug: Changing modes for #test to +o Sm0ke0ut
[Jul 17 18:14:29.605191 2009] debug: Setting +o on #test for Sm0ke0ut
[Jul 17 18:14:29.605240 2009] debug: Changing modes for #test to +nt o,500AAAAA8
[Jul 17 18:14:36.330308 2009] debug: Received: :500AAAAA8 PRIVMSG 00AAAAAAD :register #test blaat test
[Jul 17 18:14:36.330693 2009] debug: chan_has_user_status wanted 1 the user is 1
[Jul 17 18:14:36.330810 2009] ChanServ: Channel '#test' registered by Sm0ke0ut!unknown@82.148.195.218
[Jul 17 18:14:36.330975 2009] debug: Sent: :00AAAAAAD NOTICE Sm0ke0ut :Channel #test registered under your nickname: Sm0ke0ut
[Jul 17 18:14:36.331072 2009] debug: Sent: :00AAAAAAD NOTICE Sm0ke0ut :Your channel password is blaat - remember it for later use.
[Jul 17 18:14:36.331142 2009] debug: Sent: :00AAAAAAD FMODE #test 1247847269 +r
[Jul 17 18:14:36.331194 2009] debug: Sent: :00AAAAAAD FMODE #test 1247847269 +q Sm0ke0ut
[Jul 17 18:14:42.568912 2009] debug: Received: :500AAAAA8 PRIVMSG 00AAAAAAC :assign #test NickServ
[Jul 17 18:14:42.569346 2009] debug: Sent: FJOIN #test 1247847269 + :,00AAAAAAM
[Jul 17 18:14:42.569506 2009] debug: Sent: :00AAAAAAM FMODE #test 1247847269 +ao NickServ NickServ
[Jul 17 18:14:42.569612 2009] debug: Sent: :00AAAAAAC NOTICE Sm0ke0ut :Bot NickServ has been assigned to #test.

[Jul 17 18:35:04.781223 2009] debug: Received: :500AAAAA8 PRIVMSG 00AAAAAAC :botlist
[Jul 17 18:35:04.781606 2009] debug: Sent: :00AAAAAAC NOTICE Sm0ke0ut :Bot list:
[Jul 17 18:35:04.781774 2009] debug: Sent: :00AAAAAAC NOTICE Sm0ke0ut :   Agent            (irc@travian.org)
[Jul 17 18:35:04.781851 2009] debug: Sent: :00AAAAAAC NOTICE Sm0ke0ut :   BotServ          (services@travian.org)
[Jul 17 18:35:04.781901 2009] debug: Sent: :00AAAAAAC NOTICE Sm0ke0ut :   ChanServ         (services@travian.org)
[Jul 17 18:35:04.781946 2009] debug: Sent: :00AAAAAAC NOTICE Sm0ke0ut :   Druid            (irc@Travian.org)
[Jul 17 18:35:04.781991 2009] debug: Sent: :00AAAAAAC NOTICE Sm0ke0ut :   Gaul             (irc@travian.org)
[Jul 17 18:35:04.782034 2009] debug: Sent: :00AAAAAAC NOTICE Sm0ke0ut :   Global           (services@travian.org)
[Jul 17 18:35:04.782077 2009] debug: Sent: :00AAAAAAC NOTICE Sm0ke0ut :   H                (irc@travian.org)
[Jul 17 18:35:04.782161 2009] debug: Sent: :00AAAAAAC NOTICE Sm0ke0ut :   HostServ         (services@travian.org)
[Jul 17 18:35:04.782214 2009] debug: Sent: :00AAAAAAC NOTICE Sm0ke0ut :   MemoServ         (services@travian.org)
[Jul 17 18:35:04.782258 2009] debug: Sent: :00AAAAAAC NOTICE Sm0ke0ut :   Natar            (irc@travian.org)
[Jul 17 18:35:04.782300 2009] debug: Sent: :00AAAAAAC NOTICE Sm0ke0ut :   NickServ         (services@travian.org)
[Jul 17 18:35:04.782342 2009] debug: Sent: :00AAAAAAC NOTICE Sm0ke0ut :   OperServ         (services@travian.org)
[Jul 17 18:35:04.782384 2009] debug: Sent: :00AAAAAAC NOTICE Sm0ke0ut :   Peacebot         (irc@Travian.org)
[Jul 17 18:35:04.782426 2009] debug: Sent: :00AAAAAAC NOTICE Sm0ke0ut :   Roman            (irc@travian.org)
[Jul 17 18:35:04.782469 2009] debug: Sent: :00AAAAAAC NOTICE Sm0ke0ut :   Terraner         (irc@imperion.org)
[Jul 17 18:35:04.782617 2009] debug: Sent: :00AAAAAAC NOTICE Sm0ke0ut :   Teuton           (irc@travian.org)
[Jul 17 18:35:04.782669 2009] debug: Sent: :00AAAAAAC NOTICE Sm0ke0ut :   Titanen          (irc@imperion.org)
[Jul 17 18:35:04.782713 2009] debug: Sent: :00AAAAAAC NOTICE Sm0ke0ut :   Travian          (irc@travian.org)
[Jul 17 18:35:04.782756 2009] debug: Sent: :00AAAAAAC NOTICE Sm0ke0ut :   TT               (irc@travian.org)
[Jul 17 18:35:04.782800 2009] debug: Sent: :00AAAAAAC NOTICE Sm0ke0ut :   Xen              (irc@imperion.org)
[Jul 17 18:35:04.782867 2009] debug: Sent: :00AAAAAAC NOTICE Sm0ke0ut :Bots reserved to IRC operators:
[Jul 17 18:35:04.782918 2009] debug: Sent: :00AAAAAAC NOTICE Sm0ke0ut :   I                (irc@travian.org)
[Jul 17 18:35:04.782961 2009] debug: Sent: :00AAAAAAC NOTICE Sm0ke0ut :   T                (irc@travian.org)
[Jul 17 18:35:04.783005 2009] debug: Sent: :00AAAAAAC NOTICE Sm0ke0ut :   Zeus             (zeus@speed.travian.nl)
[Jul 17 18:35:04.783050 2009] debug: Sent: :00AAAAAAC NOTICE Sm0ke0ut :23 bots available.


#2 !SEEN <nickname>, it seems that !commands in channels will evaluate as chanserv commands, seen doesn't work at all.
[Jul 17 18:18:40.417974 2009] debug: Received: :500AAAAA8 PRIVMSG #travian.nl :!seen Sm0ke0ut
[Jul 17 18:18:40.418521 2009] debug: Sent: :00AAAAAAD NOTICE Sm0ke0ut :Unknown command seen.  "/msg ChanServ HELP" for help.

#3 NICKSERV > UMODE r - seems to be weird, that my umode r will be removed after the `automatically identified`
[Jul 17 18:26:10.679966 2009] debug: Received: :500AAAAA8 NICK test 1247847971
[Jul 17 18:26:10.680105 2009] debug: 500AAAAA8 changes nick to test
[Jul 17 18:26:10.680159 2009] debug: Sm0ke0ut changed nick to test
[Jul 17 18:26:16.342926 2009] debug: Received: :500AAAAA8 PRIVMSG 00AAAAAAM :logout
[Jul 17 18:26:16.343306 2009] debug: Sent: :00AAAAAAM NOTICE test :Your nick isn't registered.
[Jul 17 18:26:19.340995 2009] debug: Received: :500AAAABJ NICK ungoliant 1247847979
[Jul 17 18:26:19.341135 2009] debug: 500AAAABJ changes nick to ungoliant
[Jul 17 18:26:19.341209 2009] debug: Travian38444 changed nick to ungoliant
[Jul 17 18:26:19.341448 2009] debug: Sent: :00AAAAAAM NOTICE ungoliant :This nickname is registered and protected.  If it is your
[Jul 17 18:26:19.341586 2009] debug: Sent: :00AAAAAAM NOTICE ungoliant :nick, type /msg NickServ IDENTIFY password.  Otherwise,
[Jul 17 18:26:19.341659 2009] debug: Sent: :00AAAAAAM NOTICE ungoliant :please choose a different nick.
[Jul 17 18:26:19.341714 2009] debug: Sent: :00AAAAAAM NOTICE ungoliant :If you do not change within one minute, I will change your nick.
[Jul 17 18:26:23.061862 2009] debug: Received: :500AAAAA8 NICK Sm0ke0ut 1247847983
[Jul 17 18:26:23.062006 2009] debug: 500AAAAA8 changes nick to Sm0ke0ut
[Jul 17 18:26:23.062059 2009] debug: test changed nick to Sm0ke0ut
[Jul 17 18:26:23.062253 2009] debug: Sent: :00AAAAAAM MODE 500AAAAA8 -r
[Jul 17 18:26:23.062311 2009] debug: Changing mode for Sm0ke0ut to -r
[Jul 17 18:26:23.062363 2009] NickServ: Sm0ke0ut!unknown@82.148.195.218 automatically identified for nick Sm0ke0ut

[Jul 17 18:28:40.075698 2009] debug: Received: :500AAAAA8 PRIVMSG 00AAAAAAM :IDENTIFY PASSWORD
[Jul 17 18:28:40.076087 2009] debug: Sent: :00AAAAAAM NOTICE Sm0ke0ut :You are already identified.
[Jul 17 18:28:43.290686 2009] debug: Received: :500AAAAA8 PRIVMSG 00AAAAAAM :logout
[Jul 17 18:28:43.291038 2009] debug: Sent: :00AAAAAAM MODE 500AAAAA8 -r 1
[Jul 17 18:28:43.291112 2009] debug: Changing mode for Sm0ke0ut to -r
[Jul 17 18:28:43.291147 2009] NickServ: Sm0ke0ut!unknown@82.148.195.218 logged out nickname Sm0ke0ut
[Jul 17 18:28:43.291272 2009] debug: Sent: :00AAAAAAM NOTICE Sm0ke0ut :Your nick has been logged out.
[Jul 17 18:28:43.291341 2009] debug: Sent: :00A METADATA 500AAAAA8 accountname :
[Jul 17 18:28:44.514582 2009] debug: Received: :500AAAAA8 PRIVMSG 00AAAAAAM :IDENTIFY PASSWORD
[Jul 17 18:28:44.514967 2009] debug: Sent: :00AAAAAAM MODE 500AAAAA8 +r
[Jul 17 18:28:44.515037 2009] debug: Changing mode for Sm0ke0ut to +r
[Jul 17 18:28:44.515093 2009] debug: Sent: :00A METADATA 500AAAAA8 accountname :Sm0ke0ut
[Jul 17 18:28:44.515128 2009] NickServ: Sm0ke0ut!unknown@82.148.195.218 identified for nick Sm0ke0ut
[Jul 17 18:28:44.515200 2009] debug: Sent: :00AAAAAAM NOTICE Sm0ke0ut :Password accepted - you are now recognized.
« Last Edit: July 17, 2009, 05:35:28 PM by Sm0ke0ut »
Logged

Naram Qashat

  • Team
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 192
    • CBX's Sprite Animations
Re: A few bugs I noticed
« Reply #1 on: July 17, 2009, 06:06:09 PM »

#1 has been allowed since 1.9.0, it's expected that way.  The core pseudo-clients are seen as bots in 1.9.x.

#2 is known, we are going to be fixing that (you ARE using the SVN version, so it's expected there may still be some issues)

#3 is also known and we are going to be fixing that as well.
Logged

Sm0ke0ut

  • Anope User
  • Offline Offline
  • Posts: 9
Re: A few bugs I noticed
« Reply #2 on: July 17, 2009, 07:11:41 PM »

I'm aware of the SVN usage, but I still felt like to report some issues i've noticed.

For the following errors:

#1 I see, but there's another error. It's not possible (yet) to set them on private. (it's forcing channel, no bots)
[Jul 17 20:08:34.556380 2009] debug: Received: :500AAAAA8 PRIVMSG 00AAAAAAC :set Teuton private on
[Jul 17 20:08:34.556752 2009] debug: Sent: :00AAAAAAC NOTICE Sm0ke0ut :Channel Teuton is not a valid channel.

#2 + #3 I'll be patience until a patch/fix has been released.

If I notice more bugs/problems I'll report them here!

Thanks in advance.
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
Re: A few bugs I noticed
« Reply #3 on: July 17, 2009, 08:00:37 PM »

Hey Sm0ke0ut,

Thanks for posting about these; good to get some discussion on the go even if they are in trunk.

I'll work on improving the registration function to make it a bit clearer next time someone wants to reg on here :)

Logged

Adam

  • Team
  • *
  • Offline Offline
  • Posts: 463
Re: A few bugs I noticed
« Reply #4 on: July 17, 2009, 09:26:17 PM »

Thanks Sm0ke0ut, The botserv set private bug is now fixed in SVN :)
Logged

Sm0ke0ut

  • Anope User
  • Offline Offline
  • Posts: 9
Re: A few bugs I noticed
« Reply #5 on: July 27, 2009, 10:15:32 AM »

I've found another bug/problem - perhaps already known, if not.. there you go ;) (using latest SVN):

[11:12:28] * Notice from ChanServ: Sm0ke0ut not found on #gothic-nederland SOP list.
[11:12:32] * Notice from ChanServ: Access list for #gothic-nederland:
[11:12:32] * Notice from ChanServ: Num Lev Nick
[11:12:32] * Notice from ChanServ: 1 SOP Sm0ke0ut
[11:12:32] * Notice from ChanServ: 2 AOP Fayntic
[11:12:32] * Notice from ChanServ: End of access list.
[11:12:33] * Notice from ChanServ: Sm0ke0ut not found on #gothic-nederland SOP list.

I didn't check the other xOP possibilities, but they will probably give the same error.

Temporary fix:
[11:12:58] * Notice from ChanServ: xOP lists system for #gothic-nederland is now OFF.
[11:13:01] * Notice from ChanServ: Sm0ke0ut deleted from #gothic-nederland access list.
Logged
Pages: [1]   Go Up