Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: anope crash  (Read 6017 times)

0 Members and 1 Guest are viewing this topic.

GyniO

  • Anope User
  • Offline Offline
  • Posts: 3
anope crash
« on: May 26, 2009, 06:44:27 PM »

Hi everyone.

I have one small problem with anope when I crete bot with command:
Quote
/msg BotServ BOT ADD Q Q xxx.pl xxx.pl
And:
Quote
/msg Q #channel 
they was bug..
And anope was crashed..

When i need to restart anope message on irc(unrealircd):

Quote
-xxx- *** Notice -- Possible negative TS split at link xxx (1243358645 - 1243358648 = -3)
-
-xxx- *** Notice -- Link xxx -> xxx is now synced [secs: -3 recv: 2.112 sent: 3.202]
-
-xxx- *** Notice -- Max SendQ limit exceeded for xxx[9x.1xx.1xx.1xx]: 1000038 > 1000000
-
-xxx- *** Global -- Closing link: Max SendQ exceeded - xxx[9x.1xx.1xx.1xx]


when i start anope with command:
Code: [Select]
./services -debug -nofork
then i see:
Quote
[May 26 19:41:21.064536 2009] debug: Received: :xxx MODE #opers &-o Q 1243357308
[May 26 19:41:21.064552 2009] debug: Changing modes for #opers to &-o Q 1243357308
[May 26 19:41:21.064570 2009] debug: Sent: :Q MODE #opers +o Q
[May 26 19:41:21.064602 2009] debug: Received: :xxx MODE #opers -oh Q Q 0
[May 26 19:41:21.064619 2009] debug: Changing modes for #opers to -oh Q Q 0
[May 26 19:41:21.064636 2009] debug: Sent: :Q MODE #opers +o Q
[May 26 19:41:21.064672 2009] debug: Received: :xxx MODE #opers &-o Q 1243357308
[May 26 19:41:21.064688 2009] debug: Changing modes for #opers to &-o Q 1243357308
[May 26 19:41:21.064705 2009] debug: Sent: :Q MODE #opers +o Q
[May 26 19:41:21.064958 2009] debug: Received: :xxx MODE #opers -oh Q Q 0
[May 26 19:41:21.065000 2009] debug: Changing modes for #opers to -oh Q Q 0
[May 26 19:41:21.065071 2009] debug: Sent: :Q MODE #opers +o Q
[May 26 19:41:21.065136 2009] debug: Received: :xxx MODE #opers &-o Q 1243357308
[May 26 19:41:21.065176 2009] debug: Changing modes for #opers to &-o Q 124335

Can who help me?

Change Max SendQ this nothing help... (I test it)
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
Re: anope crash
« Reply #1 on: May 26, 2009, 06:49:55 PM »

Ulines are wrong.
Logged

GyniO

  • Anope User
  • Offline Offline
  • Posts: 3
Re: anope crash
« Reply #2 on: May 26, 2009, 06:52:47 PM »

?

Can you tell me where I can repair it?
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
Re: anope crash
« Reply #3 on: May 26, 2009, 06:56:47 PM »

In your ircd configuration file you should have a section about ulines.

Your services hostname which you kindly commented out (sigh) needs to be listed there so it can exceed sendq etc.

Logged

GyniO

  • Anope User
  • Offline Offline
  • Posts: 3
Re: anope crash
« Reply #4 on: May 26, 2009, 07:05:34 PM »

Code: [Select]
ulines {
        localhost;
        xxx;
        127.0.0.1;
        9x.1xx.1xx.1xx;
};
This?
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
Re: anope crash
« Reply #5 on: May 26, 2009, 07:58:37 PM »

Remove everything in there and ONLY put whatever ServerName in services.conf is set to.

Then rehash your ircd and try again.
Logged
Pages: [1]   Go Up