Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: [solved]problem with nickserv changing names  (Read 3559 times)

0 Members and 1 Guest are viewing this topic.

Guido

  • Anope User
  • Offline Offline
  • Posts: 6
[solved]problem with nickserv changing names
« on: March 25, 2009, 01:41:20 AM »

Hello,   I've got a new ircd install, unreal 3.2.8 works fin, add anope 1.8.0 that work almost fine except that I,ve got a problem with nickserv. With a registered nick, when a different nick try to take that registered one, nickserv ask to identify otherwise he will change the nick. but after 1min nothing happen, it don't change (secure is on kill is on).  so I looked in debug mode and seen that I've got a problem with ns_seedpass and cs_sendpass  (the whole email section is desactivated) the modules seems not to load, even if I did a fresh install of anope, here's the first log juste after the new install:

Code: [Select]
[Mar 24 21:03:03 2009] Loading IRCD Protocol Module: [unreal32]
[Mar 24 21:03:03 2009] status: [0][Module, Okay - No Error]
[Mar 24 21:03:03 2009] Loading Encryption Module: [enc_md5]
[Mar 24 21:03:03 2009] status: [0][Module, Okay - No Error]
[Mar 24 21:03:03 2009] Anope 1.8.0 (1899) (ircd protocol: UnrealIRCd 3.2+) starting up
[Mar 24 21:03:04 2009] ns_sendpass requested unload...
[Mar 24 21:03:04 2009] debug: trying to load core module [ns_sendpass]
[Mar 24 21:03:04 2009] debug: status: [6][Module Error, Error during load time or module returned MOD_STOP]
[Mar 24 21:03:04 2009] cs_sendpass requested unload...
[Mar 24 21:03:04 2009] debug: trying to load core module [cs_sendpass]
[Mar 24 21:03:04 2009] debug: status: [6][Module Error, Error during load time or module returned MOD_STOP]
[Mar 24 21:03:04 2009] Databases loaded
[Mar 24 21:03:04 2009] Info: Reflecting database records.
[Mar 24 21:03:04 2009] Connected to Server 1 (67.43.236.30:23333)
[Mar 24 21:03:04 2009] trying to load [cs_appendtopic]
[Mar 24 21:03:04 2009] [cs_appendtopic] Loaded successfully
[Mar 24 21:03:04 2009] status: [0][Module, Okay - No Error]
[Mar 24 21:03:04 2009] trying to load [cs_enforce]
[Mar 24 21:03:04 2009] status: [0][Module, Okay - No Error]
[Mar 24 21:03:04 2009] trying to load [ns_maxemail]
[Mar 24 21:03:04 2009] status: [0][Module, Okay - No Error]
[Mar 24 21:03:04 2009] trying to load [os_info]
[Mar 24 21:03:04 2009] os_info: Loading configuration directives...
[Mar 24 21:03:04 2009] os_info: Directive OSInfoDBName loaded (os_info.db)...
[Mar 24 21:03:04 2009] os_info: WARNING: can not open the database file! (it might not exist, this is not fatal)
[Mar 24 21:03:04 2009] status: [0][Module, Okay - No Error]
[Mar 24 21:03:04 2009] trying to load [hs_request]
[Mar 24 21:03:04 2009] [hs_request] Unable to open database ('hs_request.db') for reading
[Mar 24 21:03:04 2009] hs_request loaded
[Mar 24 21:03:04 2009] status: [0][Module, Okay - No Error]
[Mar 24 21:03:04 2009] status: [0][Module, Okay - No Error]
[Mar 24 21:03:04 2009] user: New maximum user count: 1
[Mar 24 21:03:04 2009] user: New maximum user count: 2
[Mar 24 21:03:04 2009] user: New maximum user count: 3
[Mar 24 21:03:04 2009] user: New maximum user count: 4
[Mar 24 21:03:04 2009] user: New maximum user count: 5
[Mar 24 21:03:04 2009] Server irc.mydomain.com is done syncing

So, is it cause I just did'nt set the email section that I,ve got this problem of cause of a config in services.conf?

I use encryption, so except for password recovery I dont really need emails

Does this ns_sendpass is related with that bug?

Thanks for taking time to help me :)
« Last Edit: March 25, 2009, 05:56:26 PM by Guido »
Logged

Adam

  • Team
  • *
  • Offline Offline
  • Posts: 463
Re: problem with nickserv changing names
« Reply #1 on: March 25, 2009, 01:50:03 AM »

It sounds like your ULines are not set properly. Set it in your IRCd configuration to your services server name, then restart services.
Logged

Guido

  • Anope User
  • Offline Offline
  • Posts: 6
Re: problem with nickserv changing names
« Reply #2 on: March 25, 2009, 02:11:04 AM »

in services.conf: ServerName  "services.mydomain.com"
in unrealircd.conf:
ulines {
   "services.mydomain.com";

};

triple checked....  :/
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
Re: problem with nickserv changing names
« Reply #3 on: March 25, 2009, 04:01:05 PM »

Hi,

The sendpass' will unload because you're using encryption, no bones about that and email won't help either.

Regardless, it will be ulines to explain why the renicking isn't occuring or whether you have a host in the access list.

Either pastebin your configs, or pop onto irc.anope.org and someone will connect to your network to test that.
Logged

Guido

  • Anope User
  • Offline Offline
  • Posts: 6
Re: problem with nickserv changing names
« Reply #4 on: March 25, 2009, 05:56:13 PM »

ok tested and retested after another install and now everything seems to work fine

I don't know what was the problem but happy that being solved

Thanks for the help :)
Logged
Pages: [1]   Go Up