Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: Upgrade from anope-1.7.21 to 1.9.0 DB too old  (Read 5285 times)

0 Members and 1 Guest are viewing this topic.

Mephisteus

  • Anope User
  • Offline Offline
  • Posts: 2
Upgrade from anope-1.7.21 to 1.9.0 DB too old
« on: February 13, 2009, 10:56:17 PM »

I'm trying to get this done on a test network but I've run into this error
"FATAL: DB nick.db is too old"

Anyone know how I can fix this?
Logged

Jan Milants

  • Team
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1372
Re: Upgrade from anope-1.7.21 to 1.9.0 DB too old
« Reply #1 on: February 13, 2009, 11:57:48 PM »

Save the DB with 1.8 first... 1.9 will have a new DB backend soon enough and has already been stripped of all legacy DB code and the only code that s still in it is that for the 1.8 DB.  So it will only support upgrades from the 1.8 branch.
Logged
If you like me donate coins to 1FBmZVT4J8WAUMHKqpWhgNVj3XXnRN1cCk :)

Mephisteus

  • Anope User
  • Offline Offline
  • Posts: 2
Re: Upgrade from anope-1.7.21 to 1.9.0 DB too old
« Reply #2 on: February 14, 2009, 12:23:59 AM »

Any way to do this without having to connect Anope to a server? We're trying inspircd 1.2 and would ultimately prefer not having to setup a seperate ircd for this :p
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
Re: Upgrade from anope-1.7.21 to 1.9.0 DB too old
« Reply #3 on: February 14, 2009, 10:28:24 AM »

No, you can send your db's to me if you want and i'll do it on my testnet but it would probably be easier for you to just do it and then it's done.
Logged

Izv143

  • Anope User
  • Offline Offline
  • Posts: 36
    • www.krajinalive.com
Re: Upgrade from anope-1.7.21 to 1.9.0 DB too old
« Reply #4 on: October 14, 2009, 12:08:45 PM »

I'm trying to get this done on a test network but I've run into this error
"FATAL: DB nick.db is too old"

Anyone know how I can fix this?

What I did is install 1.8.0 and copy all db from 1.7.21 into 1.8.0. Then start that services (1.8.0 ), install 1.9.1 set up everything and copy db from 1.8.0 to 1.9.1 and then start them. All passwords for channels and nicknames and all other stuff like bots, hosts etc were on 1.9.1 .When I say db I mean chan.db, nickdb, oper.db, host.db etc
Logged
Pages: [1]   Go Up