Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: Not working with Unreal3.2.7  (Read 6612 times)

0 Members and 1 Guest are viewing this topic.

woodsier

  • Anope User
  • Offline Offline
  • Posts: 24
Not working with Unreal3.2.7
« on: February 07, 2009, 01:05:21 AM »

Hi guys.

Not sure if I should ask here or at unrealIRCD forums, so I'll ask at both!

I am getting the following error:

[Feb 07 00:52:33 2009] Loading IRCD Protocol Module: [unreal32]
[Feb 07 00:52:33 2009] status: [4][Module Error, File does not exist]

When running ./services -debug -nofork.

I am running Ubuntu 8.10 with Unreal3.2.7 and Anope 1.8.0.

In services.conf my module setting is: "IRCDModule "unreal32".

I am not sure if there should be something there, but inside the modules folder there is only a runtime folder, which itself is empty.

I DID get some errors upon making with anope.

Lots of spam like this: "chanserv.c:482: warning: ignoring return value of âfreadâ, declared with attribute warn_unused_result"

And this:


    /bin/sh: ./configure: Permission denied
    make[2]: Entering directory `/home/ihdl/irc/Unreal3.2.7/anope-1.8.0/src/core'
    Makefile:1: Makefile.inc: No such file or directory
    make[2]: *** No rule to make target `Makefile.inc'. Stop.
    make[2]: Leaving directory `/home/ihdl/irc/Unreal3.2.7/anope-1.8.0/src/core'
    make[1]: *** [core] Error 2
    make[1]: Leaving directory `/home/ihdl/irc/Unreal3.2.7/anope-1.8.0/src'
    make: *** [core] Error 2



When i typed make install I got this:

    make[2]: Entering directory `/home/ihdl/irc/Unreal3.2.7/anope-1.8.0/src/modules'
    Makefile:1: Makefile.inc: No such file or directory
    make[2]: *** No rule to make target `Makefile.inc'. Stop.
    make[2]: Leaving directory `/home/ihdl/irc/Unreal3.2.7/anope-1.8.0/src/modules'
    make[2]: Entering directory `/home/ihdl/irc/Unreal3.2.7/anope-1.8.0/src/protocol'
    Makefile:1: Makefile.inc: No such file or directory
    make[2]: *** No rule to make target `Makefile.inc'. Stop.
    make[2]: Leaving directory `/home/ihdl/irc/Unreal3.2.7/anope-1.8.0/src/protocol'
    make[2]: Entering directory `/home/ihdl/irc/Unreal3.2.7/anope-1.8.0/src/core'
    Makefile:1: Makefile.inc: No such file or directory
    make[2]: *** No rule to make target `Makefile.inc'. Stop.
    make[2]: Leaving directory `/home/ihdl/irc/Unreal3.2.7/anope-1.8.0/src/core'
    make[1]: *** [install] Error 2
    make[1]: Leaving directory `/home/ihdl/irc/Unreal3.2.7/anope-1.8.0/src'
    make: *** [install] Error 2



Could you help me guys?

My folder structure is
/home/ihdl/irc/Unreal3.2.7
/home/ihdl/irc/Unreal3.2.7/services <- where I ./Config everything to be held including data
/home/ihdl/irc/Unreal3.2.7/anope-1.8.0 <- where I copied the original anope files before I config, made, made install etc.

Thanks.
Logged

LEthaLity

  • Team
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 303
    • LEthaLity
Re: Not working with Unreal3.2.7
« Reply #1 on: February 07, 2009, 01:17:43 AM »

permission denied is your main problem, i get this also on my old irc shell, try chmodding configure, and makefile so you can run them
Logged

katsklaw

  • Guest
Re: Not working with Unreal3.2.7
« Reply #2 on: February 07, 2009, 01:44:29 AM »

run ./Config not ./configure and from the anope-1.8.0 directory.
Logged

woodsier

  • Anope User
  • Offline Offline
  • Posts: 24
Re: Not working with Unreal3.2.7
« Reply #3 on: February 07, 2009, 03:15:51 AM »

Thanks for the reply, I changed permissions for everything in the directory to be executable and it worked a charm.

Now I have a new problem! Haha. I have read the documentation and such, and have set my nick to be servicesroot, yet I cannot seem to access OperServ (Access Denied).

ServicesRoot   "woodsier"

# SuperAdmin  [OPTIONAL]
#    When enabled, Services admins will be able to use SuperAdmin [ON|OFF]
#    which will temporarily grant them extra privileges, such as being a
#    founder of _all_ channels, ability to adjust another users modes etc..

SuperAdmin

# LogMaxUsers  [OPTIONAL]
#    Causes Services to write a message to the log every time a new user
#    maximum is set.

I have tried it with SuperAdmin uncommented.

I have tried it also with both OSOpersOnly on and off. When it's off I can message operserv for the commands and such but I still cannot change anything.

I have registered my name with nickserv, restarted the server, restarted anope. Everything.

I have googled for guides and such but I get nothing.

Could someone point me in the right direction? I would like to set myself up as an IRCOP etc.
Logged

woodsier

  • Anope User
  • Offline Offline
  • Posts: 24
Re: Not working with Unreal3.2.7
« Reply #4 on: February 07, 2009, 03:17:16 AM »

run ./Config not ./configure and from the anope-1.8.0 directory.

Ah, nah that wasn't it. I was running ./Config but that in itself calls the scripts ./configure which did not have executable privileges in all of the directories in which it resided.
Logged

woodsier

  • Anope User
  • Offline Offline
  • Posts: 24
Re: Not working with Unreal3.2.7
« Reply #5 on: February 07, 2009, 03:24:59 AM »

Nevermind, I have got it. Thankyou for your patience.
Logged

katsklaw

  • Guest
Re: Not working with Unreal3.2.7
« Reply #6 on: February 07, 2009, 02:32:43 PM »

Ah, nah that wasn't it. I was running ./Config but that in itself calls the scripts ./configure which did not have executable privileges in all of the directories in which it resided.

Yeah I noticed that after you had replied. Sorry about the misinformation ;P It just proves everyone is wrong from time to time. lol

Anyway, there shouldn't be a reason you would need to change permissions unless you are doing something weird, like trying to irun as a user after you installed as root (which won't work since anope automaticly sets permissions back to the installed user) or something like untarring on Windows and you FTPed the directory to Linux.
Logged

LEthaLity

  • Team
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 303
    • LEthaLity
Re: Not working with Unreal3.2.7
« Reply #7 on: February 07, 2009, 04:31:03 PM »

lol i always used to do the latter which is why i'd encountered it before,  the bad old days when my linux commands were limited to cd and dir :P
Logged
Pages: [1]   Go Up