Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: compiling svn build  (Read 2951 times)

0 Members and 1 Guest are viewing this topic.

hardwarewizard

  • Anope User
  • Offline Offline
  • Posts: 22
compiling svn build
« on: January 31, 2009, 10:09:12 PM »

ok i d/l the svn trunk and executed the config. it seemed to compile but i didn't get what i wanted.

i want to get it compiled to allow connecting to inspircd 1.2 i see the source fot the protocol but as i am not very experienced. it didn't seem to install or compile.

could someone guide me in whats the correct way to compile the svn

thanks.
Logged

Naram Qashat

  • Team
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 192
    • CBX's Sprite Animations
Re: compiling svn build
« Reply #1 on: February 01, 2009, 12:47:25 AM »

Firstly, how did you try to compile it in the first place?  If you can provide those steps, I can see what I can do.
Logged

hardwarewizard

  • Anope User
  • Offline Offline
  • Posts: 22
Re: compiling svn build
« Reply #2 on: February 01, 2009, 01:26:01 AM »

these are the steps i did

./Config

used all defaults

and followed the directions the compile gave me


also i'm doing this using debian etch

after some playing around and moving files i get this

i have not created my serices conf yet at this point(looks like a step backwards with the single conf file)
and no log file was created


update:

thecastle:~/services2$ ./anoperc start
Starting Anope
chdir(/home/test/services2/../data): No such file or directory
Unfortunately it seems Anope did not start successfully
This error has been logged in your Anope Log file
Located in /home/test/services2/data/logs/
This may help you diagnose the problem
Further help may be available from http://www.anope.org/
« Last Edit: February 01, 2009, 03:18:31 AM by hardwarewizard »
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
Re: compiling svn build
« Reply #3 on: February 01, 2009, 03:10:18 PM »

Hi there,

There's an issue with anoperc since the services binary was moved to the bin dir.

I'll look into this now and update SVN shortly with a solution.
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
Re: compiling svn build
« Reply #4 on: February 01, 2009, 03:19:06 PM »

Hi there,

Please update your svn version to release 1942 where I have changed anoperc to identify correctly where the services binary lives.

Please retry again and if it still fails paste the following:

1) output of pwd
2) output of the logfile anoperc points to

You may wish to ensure you have correctly configured anope and your ircd to link by running ./services before using anoperc.

Hope this helps.
Logged
Pages: [1]   Go Up