Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: anope 1.9.x and unreal3.2.9-rc2 cant connect - No link block named  (Read 4507 times)

0 Members and 1 Guest are viewing this topic.

Johnny

  • Anope User
  • Offline Offline
  • Posts: 3

ok ive read docs ive looked at pages both in the anope and the unreal forums.

i have had servers before, heck i helped write one (new config is new to me, im used to ircd.cong files)

i am having the same problem as here
http://forum.anope.org/index.php?topic=3435.0
and i read this here
http://forum.anope.org/index.php?topic=1267.0

and i still have yet to fix this problem i cant connect
heres my connection info problem

Code: [Select]
« irc.xxxxx.com : *** LocOps -- Link denied for services.xxxxx.com(unknown@127.0.0.1) (No link block named 'services.xxxxx.com') [@127.0.0.1.57923]
ive tried my internet network ip 192.168.0.x and my ip address too, it still give that line

heres my configs (mind you i have xxxxx'ed out my real info
unreal3ircd.conf
Code: [Select]
listen         *:4400;
link            services.xxxx.com
{
username *;
hostname *;
bind-ip *;
port 4400;
hub             *;
password-connect "xxxx";
password-receive "xxxx";
class           servers;
options {
};
};
services-server "services.xxxx.com";

services.conf
Code: [Select]
uplink
{
/*
* The IP or hostname of the IRC server you wish to connect Services to.
* Usually, you will want to connect Services over 127.0.0.1 (aka localhost).
*
* NOTE: On some shell providers, this will not be an option.
*/
host = "127.0.0.1"

/*
* Enable if Services should connect using IPv6.
*/
ipv6 = no

/*
* Enable if Services should connect using SSL.
* You must have m_ssl loaded for this to work.
*/
ssl = yes

/*
* The port to connect to.
* The IRCd *MUST* be configured to listen on this port, and to accept
* server connections.
*
* Refer to your IRCd documentation for how this is to be done.
*/
port = 4400

/*
* The password to send to the IRC server for authentication.
* This must match the link block on your IRCd.
*
* Refer to your IRCd documentation for more information on link blocks.
*/
password = "xxxxx"
}

/*
 * [REQUIRED] Server Information
 *
 * This section contains information about the Services server.
 */
serverinfo
{
/*
* The hostname that Services will be seen as, it must have no conflicts with any
* other server names on the rest of your IRC network. Note that it does not have
* to be an existing hostname, just one that isn't on your network already.
*/
name = "services.xxxxx.com"

/*
* The text which should appear as the server's information in /whois and similar
* queries.
*/
description = "Services for IRC Networks"

/*
* The local address that Services will bind to before connecting to the remote
* server. This may be useful for multihomed hosts. If ommited, Services will let
* the Operating System choose the local address. This directive is optional.
*
* If you don't know what this means or don't need to use it, just leave this
* directives commented out.
*/
#localhost = "nowhere."

/*
* This directive instructs Anope which IRCd Protocol to speak when connecting.
* You MUST modify this to match the IRCd you run.
*
* Supported:
*  - inspircd11
*  - inspircd12
*  - inspircd20
*  - ratbox
*  - bahamut
*  - unreal32
*  - plexus
*/
type = "unreal32"

/*
* What Server ID to use for this connection?
* Note: This should *ONLY* be used for TS6/P10 IRCds. Refer to your IRCd documentation
* to see if this is needed.
*/
#id = "00A"

/*
* These identify the ident@hostname which will be used by the Services pesudoclients.
*/
ident = "services"
hostname = "services.xxxx.com"

/*
* The filename containing the Services process ID. The path is relative to the
* services executable. If not given, defaults to "services.pid".
*/
pid = "services.pid"

/*
* The filename containing the Message of the Day. The path is relative to the
* services executable. If not given, defaults to "services.motd".
*/
motd = "services.motd"
}


there are no ircd.log entries besides the user connects.

services.log for anope has info of:
Code: [Select]
[Aug 04 19:54:39 2011] Loading IRCD Protocol Module: [unreal32]
[Aug 04 19:54:39 2011] SERVER: services.xxxx.com (Services for IRC Networks) uplinked to no uplink connected to the network
[Aug 04 19:54:39 2011] Launching Anope into the background
[Aug 04 19:54:39 2011] Anope 1.9.4 (1) (ircd protocol: UnrealIRCd 3.2.x) starting up
[Aug 04 19:54:40 2011] Error while loading ns_cert: Your IRCd does not support ssl client certificates
[Aug 04 19:54:42 2011] Error while loading ms_rsend: Don't like memo reciepts, or something.
[Aug 04 19:54:43 2011] Error while loading os_defcon: Invalid configuration settings
[Aug 04 19:54:44 2011] Loading databases...
[Aug 04 19:54:44 2011] Databases loaded
[Aug 04 19:54:44 2011] Connected to server 1 (127.0.0.1:4400)
[Aug 04 19:54:44 2011] Disconnected from the server, retrying in 60 seconds
[Aug 04 19:55:44 2011] Connected to server 1 (127.0.0.1:4400)
[Aug 04 19:55:45 2011] Disconnected from the server, retrying in 60 seconds
[Aug 04 19:56:45 2011] Connected to server 1 (127.0.0.1:4400)


now im not sure what this line means
[Aug 04 19:54:39 2011] SERVER: services.xxxx.com (Services for IRC Networks) uplinked to no uplink connected to the network
but would that be part of the problem??

ill deal with theses later after i get it to connect at all
[Aug 04 19:54:40 2011] Error while loading ns_cert: Your IRCd does not support ssl client certificates
[Aug 04 19:54:42 2011] Error while loading ms_rsend: Don't like memo reciepts, or something.
[Aug 04 19:54:43 2011] Error while loading os_defcon: Invalid configuration settings

did i miss something, ive been working on this for a few hours now, and i really like the unrealircd, and anope looks great too(if i can get it to work right)

so what can i do to test or fix this problem
thanks in advance for any help or anything you may help with.

Logged

Adam

  • Team
  • *
  • Offline Offline
  • Posts: 463
Re: anope 1.9.x and unreal3.2.9-rc2 cant connect - No link block named
« Reply #1 on: August 05, 2011, 01:17:51 AM »

One of your confs has xxxx.com, and the other has xxxxx.com
Logged

Johnny

  • Anope User
  • Offline Offline
  • Posts: 3
Re: anope 1.9.x and unreal3.2.9-rc2 cant connect - No link block named
« Reply #2 on: August 05, 2011, 01:20:43 AM »

One of your confs has xxxx.com, and the other has xxxxx.com

thats just a typo, i manualy took out my names. all where irc.domain.com for irc.xxxx.com (or any XXXX)

thanks for looking at my post
Logged

Adam

  • Team
  • *
  • Offline Offline
  • Posts: 463
Re: anope 1.9.x and unreal3.2.9-rc2 cant connect - No link block named
« Reply #3 on: August 05, 2011, 01:23:05 AM »

Then make sure your link block isn't commented and is in the right file :/
Logged

Johnny

  • Anope User
  • Offline Offline
  • Posts: 3
Re: anope 1.9.x and unreal3.2.9-rc2 cant connect - No link block named
« Reply #4 on: August 05, 2011, 01:27:43 AM »

Then make sure your link block isn't commented and is in the right file :/

im a complete moron (and that did it) i commented the block out as i had another server up, and i didnt need it when i first started it this morning. as i didnt know what that block did.

im such a idiot for not realizing that.

thank you so much im most grateful im connected now
Logged
Pages: [1]   Go Up