Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: Quick question  (Read 7361 times)

0 Members and 1 Guest are viewing this topic.

waffleslayer

  • Anope User
  • Offline Offline
  • Posts: 5
Quick question
« on: November 23, 2008, 06:47:28 PM »

I've used the search feature quite a bit and its helped tremendously. But I just can't seem to find an answer for this.

I have a fresh install of unrealircd 3.2.7 and Anope 1.6.5.

When I set a mode +q,a,o,etc it does set the mode but there isn't a visual confirmation. The user had a @ next to their name and it just shows them as an op.

What do I need to set in order to show the normal ~ & as well?
Logged

deiks

  • Anope User
  • Offline Offline
  • Gender: Male
  • Posts: 139
  • Shizle my nizle
Re: Quick question
« Reply #1 on: November 23, 2008, 07:07:34 PM »

IRCd Releated Question.

unix:

When ./Configuring IRCd, there's one questions which ask you for ~ & modes. Must be answered by YES.

win:

Download version which supports ~ &
Logged

waffleslayer

  • Anope User
  • Offline Offline
  • Posts: 5
Re: Quick question
« Reply #2 on: November 23, 2008, 07:32:25 PM »

Hm. I'll try to do some googling and forum searching on the unreal forums but I'm pretty sure UnrealIrcd3.2.7 has that option.

Logged

Jobe

  • Contributor
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1023
    • Anope IRC Services
Re: Quick question
« Reply #3 on: November 23, 2008, 08:53:57 PM »

Hm. I'll try to do some googling and forum searching on the unreal forums but I'm pretty sure UnrealIrcd3.2.7 has that option.

It DOES have that option, but if during ./Config you said no to +aq prefixes then the "~" and "&" won't show, same if you downloaded either of the "-noaq" versions for windows.

Beyond that it could be your client.

To see if Unreal has been compiled with +aq prefixes type /quote version or /version and look for "PREFIX=(qaohv)~&@%+" or "PREFIX=(ohv)@%+"
Logged
Your IP: ()
My IRC Status:

Come along and visit http://www.anopequotes.org/

waffleslayer

  • Anope User
  • Offline Offline
  • Posts: 5
Re: Quick question
« Reply #4 on: November 23, 2008, 09:55:02 PM »

Ah, I see now.

 PREFIX=(ohv)@%+

Is there a way I can include the 'qa' after setup?

Edit: I've opened a support ticket with my ircd host to see if they can fix this for me.  Thanks for the help.
« Last Edit: November 23, 2008, 10:38:10 PM by waffleslayer »
Logged

SpaceDoG

  • Anope User
  • Offline Offline
  • Posts: 183
    • http://www.hypermutt.net
Re: Quick question
« Reply #5 on: November 23, 2008, 10:59:16 PM »

No you have to reconfigure and recompile UnrealIRCd.
Logged

waffleslayer

  • Anope User
  • Offline Offline
  • Posts: 5
Re: Quick question
« Reply #6 on: November 23, 2008, 11:04:26 PM »

Recompling the ircd would result in me losing the edits to .conf files?
Logged

zEkE

  • Anope User
  • Offline Offline
  • Posts: 34
Re: Quick question
« Reply #7 on: November 24, 2008, 03:46:32 AM »

No, your conf files will not be affected.

Assuming you use UnrealIRCd on Linux or another variation of Unix, use the following:
cd Unreal3.2 (may be Unreal3.2.7)

make clean

./Config

When it asks about prefixes ~ and &, say Yes, that you want them to be included and used.

When Config has finished, run make.

If, however, you are using UnrealIRCd on Windows, you will need to visit the UnrealIRCd and download the Win32 version that includes the prefixes and install.

As said, .conf files should remain untouched by both the compiler and the installer, though it is a good idea to keep up to date backup copies before making changes like this, unless you know exactly what you are doing.
Logged

waffleslayer

  • Anope User
  • Offline Offline
  • Posts: 5
Re: Quick question
« Reply #8 on: November 24, 2008, 07:00:56 PM »

Thanks so much everyone for the help. :)
Logged
Pages: [1]   Go Up