Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: Bugs with bs_fantasy_ext module  (Read 7859 times)

0 Members and 1 Guest are viewing this topic.

^{_reloaded54

  • Guest
Bugs with bs_fantasy_ext module
« on: November 21, 2008, 05:35:37 AM »

#


# illusion (illusion)

Posted: 10/11/08 05:26:54
Anope Version: 1.7.21
Module Version: 1.1.16
Comments:
I was glad to use this module.But i found a bug with this module which panic buffers. !set nobot on crashes the services.It would be great if you guys fix this error.

______________________________________________________________________
Matt F (matt98)

Posted: 20/11/08 07:54:16
Anope Version: 1.6.3
Module Version: 1.1.16
Comments:
This mod make the services crash. like illusion has stated above if the coder can fix this I think it would be great to have.

Thanks,
Matt F. matt98
_______________________________________________________________________
Hope you guys will fix this .

Regards ,
illusion aka ^{_reloaded54
Logged

deiks

  • Anope User
  • Offline Offline
  • Gender: Male
  • Posts: 139
  • Shizle my nizle
Re: Bugs with bs_fantasy_ext module
« Reply #1 on: November 21, 2008, 02:14:04 PM »

I guess you are using last stable from 1.8 branch.
Module is coded for 1.7.21 and below version, so u can't use it for your version.
Logged

^{_reloaded54

  • Guest
Re: Bugs with bs_fantasy_ext module
« Reply #2 on: November 25, 2008, 07:16:26 AM »

My services version is Anope1.7.21.
Logged

SNU

  • Anope User
  • Offline Offline
  • Posts: 158
    • http://www.firstclassirc.com
Re: Bugs with bs_fantasy_ext module
« Reply #3 on: November 25, 2008, 03:31:16 PM »

I can confirm this issue. "!set nobot on" crashes services and nobot is not "on". :D
Logged

^{_reloaded54

  • Guest
Re: Bugs with bs_fantasy_ext module
« Reply #4 on: November 30, 2008, 12:00:10 PM »

Would any coder reply to this topic ? :)
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
Re: Bugs with bs_fantasy_ext module
« Reply #5 on: November 30, 2008, 05:45:15 PM »

The module author may be more inclined to respond if useful information was provided such as a backtrace of the crash.
Logged

^{_reloaded54

  • Guest
Re: Bugs with bs_fantasy_ext module
« Reply #6 on: December 01, 2008, 06:42:03 AM »

oh well, when i type !set no bot on
i get notice similar like this " ****panic buffer "!set no bot on " caused by $nick***
after this services stop responding.
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
Re: Bugs with bs_fantasy_ext module
« Reply #7 on: December 01, 2008, 06:43:49 AM »

Follow the instructions laid out here.
Logged

Jan Milants

  • Team
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1372
Re: Bugs with bs_fantasy_ext module
« Reply #8 on: December 01, 2008, 02:58:45 PM »

I am aware of the issue and it will be fixed in the next release of bs_fantasy_ext which will be suitable for anope 1.8, till then i recommend undefining ENABLE_SET in config.h and rebuilding the module..
Logged
If you like me donate coins to 1FBmZVT4J8WAUMHKqpWhgNVj3XXnRN1cCk :)

^{_reloaded54

  • Guest
Re: Bugs with bs_fantasy_ext module
« Reply #9 on: December 02, 2008, 05:14:16 AM »

Viper,
I tried to undefine ENABLE_SET on config.h but it didn`t work.What i did was :
1:First i unloaded bs_fantasy_ext module from anope.
2:Then i deleted that modules from modules folder.
3:Then i got inside bs_fantasy_ext folder inside src/modules/ folder.
4:After that i edited config.h changed #define ENABLE_SET to  /*#define ENABLE_SET*/
5:I recompiled the module by make modules.
6:And finally make install and i loaded that modules bs_fantasy_ext.
But !set trigger is not disabled.So would you please guide me how do i disable !set trigger.If my process is wrong please guide me aswell.

« Last Edit: December 02, 2008, 05:18:45 AM by ^{_reloaded54 »
Logged

Jan Milants

  • Team
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1372
Re: Bugs with bs_fantasy_ext module
« Reply #10 on: December 02, 2008, 12:01:22 PM »

Quote
  Note that after changing config.h it may be required to delete bs_fantasy_ext/main.o and
  bs_fantasy_ext.so from the src/modules directory to force the module to recompile
  with "make modules".
Logged
If you like me donate coins to 1FBmZVT4J8WAUMHKqpWhgNVj3XXnRN1cCk :)

^{_reloaded54

  • Guest
Re: Bugs with bs_fantasy_ext module
« Reply #11 on: December 03, 2008, 05:07:18 AM »

Thanks Viper,

This time it worked.I`ll post again if i find any bugs.

Regards,
illusion
Logged
Pages: [1]   Go Up