Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: Module: cs_join & ircd_init no longer supported  (Read 14863 times)

0 Members and 1 Guest are viewing this topic.

n00bie

  • Anope User
  • Offline Offline
  • Gender: Male
  • Posts: 411
Module: cs_join & ircd_init no longer supported
« on: October 07, 2008, 01:54:37 AM »

As the topic stated, support for my 3rd party modules cs_join and ircd_init will be no longer supported. Which means that i will no longer update the modules or fixed a bug (if any or present otherwise) for Anope-1.7.22 and above. And please do not ask for problems regarding this two modules since all the people at #anope @ anope.org are pretty annoyed of it being asked many a times regarding 'i wnat chanserv! i want all bots to join a channel etc etc.'

You might successfully compile those 2 modules on your newest and latest anope shell without warning and stuffs (which in case you are at luck), but i will be no longer updating the code and compiling the source for windows dll. Your on your own! So please do not ask for support on the forum nor the anope network else you are at risk being kick/banned. Sorry & have a good day.
« Last Edit: October 07, 2008, 02:10:02 AM by n00bie »
Logged
I am always doing things that which I cannot do, in order that I may learn how to do it.

faceman

  • Anope User
  • Offline Offline
  • Posts: 2
Re: Module: cs_join & ircd_init no longer supported
« Reply #1 on: November 23, 2008, 02:42:59 PM »

I can confirm that ircd_init still runs fine on 1.8.0-rc1 if anyone wishes to know
Logged

spodletela

  • Anope User
  • Offline Offline
  • Posts: 4
Re: Module: cs_join & ircd_init no longer supported
« Reply #2 on: February 09, 2009, 10:11:36 AM »

Ok, i want to recompile it for 1.80 but i had it with need to compile language utility  :-\

But well... ollydbg is ok too... here is patched ircd_init for 1.80.

Maybe developers would be so nice and add  something like "skip version check" to services.conf?

http://www.ziddu.com/download/3460361/ircd_init_patched.zip.html
Logged

deiks

  • Anope User
  • Offline Offline
  • Gender: Male
  • Posts: 139
  • Shizle my nizle
Re: Module: cs_join & ircd_init no longer supported
« Reply #3 on: February 09, 2009, 01:02:53 PM »

Someone says that n00bie's ircd_init can be loaded and working properly at 1.8.0
Logged

zEkE

  • Anope User
  • Offline Offline
  • Posts: 34
Re: Module: cs_join & ircd_init no longer supported
« Reply #4 on: February 09, 2009, 02:57:08 PM »

Maybe developers would be so nice and add  something like "skip version check" to services.conf?

Perhaps, but if it were done I'd expect it to fall under the same usage as RAW, where it is provided as a feature and documented as far as enabling, disabling, and what it does whilst providing no support for using it or support for Anope installs having complications so long as it is enabled..
Logged

spodletela

  • Anope User
  • Offline Offline
  • Posts: 4
Re: Module: cs_join & ircd_init no longer supported
« Reply #5 on: February 10, 2009, 09:20:53 AM »

I have also patched the cs_join but it produces some strange behavior like chanserv complaining that it
cant join the channel as it isnt registered... but it is! I dont really get it...

Here is the cs_join.dll
http://www.ziddu.com/download/3472552/cs_join.zip.html

Someone says that n00bie's ircd_init can be loaded and working properly at 1.8.0

Sorry, wont go, modules have 4 exported functions getAnopeBuildVersion, getAnopeMajorVersion, getAnopeMinorVersion and getAnopePatchVersion,
each returning versions and wont get loaded when (i didnt check the code, presumption) the minor and major doesnt match. I have patched them
to return the same version as bahamut.dll as ircd_init didnt get loaded. I would rebuild it but i am so tired of building open source stuff with all unneeded
complications (well if there would be some vcprojs ok, but makefiles... i would really need a good reason to hassle with them, playing with them at
my job is more then enough for me...  ;)  )

To developers, i have two proposals:
- add option to remove/change the version and server advertising at join and "/version", it is highly annoying if some security holes are discovered
- add the configuration option to prevent version checking for -specific- modules (so the user would have to specify which should be skipped by version check)

« Last Edit: February 10, 2009, 10:46:42 AM by spodletela »
Logged

Trystan Scott Lee

  • Contributor
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 343
Re: Module: cs_join & ircd_init no longer supported
« Reply #6 on: February 10, 2009, 12:47:29 PM »

You went to far to much trouble

1. those functions are pulled in at build time of the module thus if its failing to load cause of those you just need to build against the same source

2. Your want to alter version is doable with a module this should NEVER be a core feature
3. Version checks ARE for you own good. Especially with Win32 builds. Crashes and other issues can occur if the mod is NOT the right version, it takes far more time to support this problem, then it does to just rebuild it against the right source code.
Logged
my God my tourniquet, return to me salvation

spodletela

  • Anope User
  • Offline Offline
  • Posts: 4
Re: Module: cs_join & ircd_init no longer supported
« Reply #7 on: February 10, 2009, 01:32:37 PM »

You went to far to much trouble

Not much trouble really :) Done in 15 minutes.

Anyway ok... you got the point, will dedicade an hour to it (although i doubt it will be enough. As far as i know opensource
projects, windows build is produced in few days... snort is a nice exception to the rule..)
« Last Edit: February 10, 2009, 01:52:51 PM by spodletela »
Logged

katsklaw

  • Guest
Re: Module: cs_join & ircd_init no longer supported
« Reply #8 on: February 10, 2009, 02:46:08 PM »

Not much trouble really :) Done in 15 minutes.

Anyway ok... you got the point, will dedicade an hour to it (although i doubt it will be enough. As far as i know opensource
projects, windows build is produced in few days... snort is a nice exception to the rule..)

Based on my experience, it only takes a few minutes to build Anope from scratch on any OS, Linux or windows alike. Which is far faster than troubleshooting.
Logged

spodletela

  • Anope User
  • Offline Offline
  • Posts: 4
Re: Module: cs_join & ircd_init no longer supported
« Reply #9 on: February 10, 2009, 05:32:25 PM »

Based on my experience, it only takes a few minutes to build Anope from scratch on any OS, Linux or windows alike. Which is far faster than troubleshooting.

yes, now i can say that from my expiriences too and next time i will swear over open
source world (wich basically thinks there is only linux and gcc) i will add two exceptions
to the rule; snort and anope. :)
Logged

Malcolm

  • Anope User
  • Offline Offline
  • Posts: 16
Re: Module: cs_join & ircd_init no longer supported
« Reply #10 on: February 12, 2009, 06:03:50 PM »

Who can help to explain to me as works cs_join?
At me on the channel 25 person, and it writes to me: -ChanServ- Can join only when there are 1 user(s) in #chan.

Anope 1.8.0.1899 (Windows)

Use .dll by spodletela

Quote
I have also patched the cs_join but it produces some strange behavior like chanserv complaining that it
cant join the channel as it isnt registered... but it is! I dont really get it...

Here is the cs_join.dll
http://www.ziddu.com/download/3472552/cs_join.zip.html
Logged

Izv143

  • Anope User
  • Offline Offline
  • Posts: 36
    • www.krajinalive.com
Re: Module: cs_join & ircd_init no longer supported
« Reply #11 on: September 29, 2009, 10:24:41 AM »

I have installed ircd_init on anope1.8.0 and have it on anope1.7.21 on both services Chanserv does not join new registered channel on registration. Any help ???
Logged

Jens Voss

  • Team
  • *
  • Offline Offline
  • Posts: 123
Re: Module: cs_join & ircd_init no longer supported
« Reply #12 on: September 29, 2009, 01:57:31 PM »

http://dev.anope.de/modules_1.8/bs_ajoinonregister.c

I made this module for 1.8.0.
I dont know if it works with 1.7.21. You can try it.

Install:
put this file in your anope-1.8/src/modules directory. Edit the file and change the line: #define BotName "ServicesBot". Replace the "ServicesBot" with the name of the Bot you want to join (only use BotServ-Bots! Don't use ChanServ or NickServ !). Then make, make install and "/operserv modload bs_ajoinonregister"


[edit]
I just found another module that solves your problem: http://modules.anope.org/viewmod.php?id=106 (the installation procedures are the same as above)
[/edit]





« Last Edit: September 29, 2009, 02:10:18 PM by Jens Voss »
Logged

Izv143

  • Anope User
  • Offline Offline
  • Posts: 36
    • www.krajinalive.com
Re: Module: cs_join & ircd_init no longer supported
« Reply #13 on: October 11, 2009, 09:50:14 AM »

http://dev.anope.de/modules_1.8/bs_ajoinonregister.c

I made this module for 1.8.0.
I dont know if it works with 1.7.21. You can try it.

Install:
put this file in your anope-1.8/src/modules directory. Edit the file and change the line: #define BotName "ServicesBot". Replace the "ServicesBot" with the name of the Bot you want to join (only use BotServ-Bots! Don't use ChanServ or NickServ !). Then make, make install and "/operserv modload bs_ajoinonregister"


[edit]
I just found another module that solves your problem: http://modules.anope.org/viewmod.php?id=106 (the installation procedures are the same as above)
[/edit]

See mate I need ChanServ to join new registered channels nothing else
Logged
Pages: [1]   Go Up