Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: [HELP] ircd_init  (Read 3683 times)

0 Members and 1 Guest are viewing this topic.

Andrey

  • Anope User
  • Offline Offline
  • Gender: Male
  • Posts: 65
    • RedeNorte
[HELP] ircd_init
« on: September 19, 2008, 02:15:43 AM »

i see 1 bug when chanserv enter in empty channel, he get +ao on channel, but chanserv dont work, he ignore all commands for chanserv, i see this in netslipt too, bot enter in channel, but no get +ao and dont work too.

IRCD: inspircd 1.1.20
Anope 1.7.21
Logged

Jobe

  • Contributor
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1023
    • Anope IRC Services
Re: [HELP] ircd_init
« Reply #1 on: September 19, 2008, 08:31:03 AM »

ChanServ simply shouldn't be in a channel to begin with, even having ChanServ in a channel is a network desync.
Logged
Your IP: ()
My IRC Status:

Come along and visit http://www.anopequotes.org/

katsklaw

  • Guest
Re: [HELP] ircd_init
« Reply #2 on: September 19, 2008, 01:07:04 PM »

stated differently, ChanServ will NOT reply to ANY command ever. because of what Jobe said, Chanserv is not designed to be in channels and without the aid of another module assigning command hooks to ChanServ, it'll never happen.

BOTSERV is what you need in channels if you want to use public commands. BotServ what invented just for this purpose.

PS: Please stop assuming that when Anope or a module doesn't do what you expect it must be a bug. I've seen several posts where you say it's a bug of one sort or another when it's simply a case of Anope or a module not working as you want that is the issue.
Logged

Andrey

  • Anope User
  • Offline Offline
  • Gender: Male
  • Posts: 65
    • RedeNorte
Re: [HELP] ircd_init
« Reply #3 on: September 19, 2008, 07:20:52 PM »

stated differently, ChanServ will NOT reply to ANY command ever. because of what Jobe said, Chanserv is not designed to be in channels and without the aid of another module assigning command hooks to ChanServ, it'll never happen.

BOTSERV is what you need in channels if you want to use public commands. BotServ what invented just for this purpose.

PS: Please stop assuming that when Anope or a module doesn't do what you expect it must be a bug. I've seen several posts where you say it's a bug of one sort or another when it's simply a case of Anope or a module not working as you want that is the issue.

i only warning users about module, because when module force chanserv enter in channel, need restart services for chanserv work again, have option for chanserv dont enter in channels, but i see in any netslipt what botserv get same problem, its only my sugestion.

my posts reflecting my modules tests, its help modules coder for make better and secure modules.
Logged
Pages: [1]   Go Up