Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: OpServ/Chanserv won't op people  (Read 2639 times)

0 Members and 1 Guest are viewing this topic.

nanoflower

  • Anope User
  • Offline Offline
  • Posts: 6
OpServ/Chanserv won't op people
« on: January 25, 2008, 03:59:23 PM »

Okay, here's the issue. I have the latest builds of Anope and Unreal working and linked. I can add people into the oplist for a channel and list them. However the people in the list don't get opped when they join even though they are registered and identified. Only I get opped when I join a channel.

I have tried adding the people into the Services Admin list and adding them into the Chanserv Op list for the channel. In neither case does Chanserv make them operators when they join the channel and they get an access denied message if they do a /cs op.

So my question is what is missing that would prevent people from being made operators? I've looked through the docs and I can't see why it's not working.

Not sure if this matters but the account I'm using is also the founder of the channels and the netadmin account. (Netadmin shouldn't be an issue since it didn't op me until I put myself into the Chanserv list.)
Logged

katsklaw

  • Guest
(No subject)
« Reply #1 on: January 25, 2008, 06:38:52 PM »

search the forum for NSModeOnID and ns autoop .. this question has been answered 34523452345634562343256234.8 times
Logged

nanoflower

  • Anope User
  • Offline Offline
  • Posts: 6
(No subject)
« Reply #2 on: January 26, 2008, 05:08:07 AM »

Thanks, but that doesn't help much. I have autoop turned on for the users I'm testing with and I have NSModeOnID defined in the services.conf file. I've gone through and restarted services just to make sure it had picked up the latest config file but that didn't change anything.

I've tried moving them between being Services Admin, Services Operator, and making them Channel operators for the channel I'm working with, and Services won't make them an operator. I can do it with /cs op command but that's not what I'm looking for.


I'm sure there's something simple that I'm missing but I can't figure out what it is. Anyone have another suggestion?

[Edited on 26-1-2008 by nanoflower]
Logged

Jan Milants

  • Team
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1372
(No subject)
« Reply #3 on: January 26, 2008, 11:29:28 AM »

1 - services admin/oper access has got nothing to do with getting ops on a channel, same thing goes for being /oper'd or not
2 - make sure they are recognized as identified /ns status nick must reply 3
3 - make sure that "Auto-op" is among the options in /ns info nick ALL
4 - make sure all third party modules are unloaded
Logged
If you like me donate coins to 1FBmZVT4J8WAUMHKqpWhgNVj3XXnRN1cCk :)
Pages: [1]   Go Up