Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: ns_noop +anope 1.6.5  (Read 4710 times)

0 Members and 1 Guest are viewing this topic.

netstat

  • Anope User
  • Offline Offline
  • Gender: Male
  • Posts: 37
ns_noop +anope 1.6.5
« on: September 06, 2008, 01:11:42 PM »

Hi all
i try to build ns_noop in anope 1.6.5, and it failed :-(

Code: [Select]
All done!  Now run "make" (or possibly "gmake") to compile your modules.
See the INSTALL, README and FAQ files if you have any problems.
make[1]: Entering directory `/home/defcon/anope-1.6.5/modules'
gcc -O2 -I/usr/include -Wall -g -c hs_moo.c
gcc -O2 -I/usr/include -Wall -g -c ircd_catserv.c
gcc -O2 -I/usr/include -Wall -g -c ns_noop.c
ns_noop.c:11:23: error: datafiles.h: No such file or directory
ns_noop.c: In function 'loadData':
ns_noop.c:278: error: 'dbFILE' undeclared (first use in this function)
ns_noop.c:278: error: (Each undeclared identifier is reported only once
ns_noop.c:278: error: for each function it appears in.)
ns_noop.c:278: error: 'f' undeclared (first use in this function)
ns_noop.c:283: warning: implicit declaration of function 'open_db'
ns_noop.c:285: warning: implicit declaration of function 'get_file_version'
ns_noop.c:287: warning: implicit declaration of function 'getc_db'
ns_noop.c:290: warning: implicit declaration of function 'read_string'
ns_noop.c:291: warning: implicit declaration of function 'read_int8'
ns_noop.c:295: warning: implicit declaration of function 'close_db'
ns_noop.c: In function 'saveData':
ns_noop.c:314: error: 'dbFILE' undeclared (first use in this function)
ns_noop.c:314: error: 'f' undeclared (first use in this function)
ns_noop.c:326: warning: implicit declaration of function 'write_int8'
ns_noop.c:326: warning: implicit declaration of function 'restore_db'
ns_noop.c:326: warning: implicit declaration of function 'anope_cmd_global'
ns_noop.c:327: warning: implicit declaration of function 'write_string'
make[1]: *** [ns_noop.o] Error 1
make[1]: Leaving directory `/home/defcon/anope-1.6.5/modules'
make: *** [modules] Error 2

Any ideas or suggestions?

Thx a lot

Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
Re: ns_noop +anope 1.6.5
« Reply #1 on: September 06, 2008, 03:08:55 PM »

Not the answer but a suggestion to upgrade to 1.7.21.

1.6.x really is old school now.
Logged

katsklaw

  • Guest
Re: ns_noop +anope 1.6.5
« Reply #2 on: September 06, 2008, 03:31:24 PM »

it seems you are missing datafiles.h, which comes with 1.6.5 in anope-1.6.5/

Please manually check to see if it's there as well as datafiles.c and if not, redownload 1.6.5 as it does indeed come with them.
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
Re: ns_noop +anope 1.6.5
« Reply #3 on: September 06, 2008, 04:30:52 PM »

Hi, it doesn't compile for me on gentoo with a fresh download of a 1.6.5 and the datafiles.c/h files do exist.
Logged

katsklaw

  • Guest
Re: ns_noop +anope 1.6.5
« Reply #4 on: September 06, 2008, 04:42:02 PM »

Hi, it doesn't compile for me on gentoo with a fresh download of a 1.6.5 and the datafiles.c/h files do exist.

That's interesting as it seems to find module.h which is in the exact same dir :/
Logged

netstat

  • Anope User
  • Offline Offline
  • Gender: Male
  • Posts: 37
Re: ns_noop +anope 1.6.5
« Reply #5 on: September 06, 2008, 08:18:03 PM »

Not the answer but a suggestion to upgrade to 1.7.21.

1.6.x really is old school now.

No, 1.6.5 is the only version that works with my thales
In newer version (anope 1.7.x), thales will be killed when somebody do a ghostkill via nickserv.
Logged

Jan Milants

  • Team
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1372
Re: ns_noop +anope 1.6.5
« Reply #6 on: September 06, 2008, 09:17:13 PM »

the 1.6 branch is very close to end-of-life and will be deprecated very soon. it will be replaced by the 1.8 branch (current 1.7) at which time 1.6 will no longer be supported. should there be a security problem arise in 1.6, it may be patched, but a new release for 1.6 is not scheduled.
so on the long run you will have to look at solving your problem because if everything goes well there may not even be a 1.6 anymore by the end of the year.
Logged
If you like me donate coins to 1FBmZVT4J8WAUMHKqpWhgNVj3XXnRN1cCk :)
Pages: [1]   Go Up