Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: NickServ +r problem  (Read 8141 times)

0 Members and 1 Guest are viewing this topic.

DarthYodi

  • Guest
NickServ +r problem
« on: July 29, 2007, 08:15:31 PM »

Hi,

I have installed anope 1.6.5 on UnrealIRCd 3.2 and it was working fine, then I installed 1.7.19 and it was working fine for a while then i was noticing that in channels that i had registered before I was only getting a +o not +q status, this led me to believe that something had changed. So i proceeded to drop the channels and then reregister them this led to the same thing. So I figured it was the newest unstable version of anope that was giving me problems and reinstalled the 1.6.5 version. Then i looked at the umodes that were set on me, and it was +iwx, even after identifing to Nickserv there was no +r being added and it won't let me add it either. The log file says everything loaded and it is connected with no errors, so I have no idea where to start.

Any ideas?

EDIT: Also when i ran it in debug mode it says services SVSMODE MyNick +rd but it does not show in the IRC window or in umodes.

Thanks in advance,
DarthYodi

[Edited on 7/29/2007 by DarthYodi]

[Edited on 7/29/2007 by DarthYodi]
Logged

ben

  • Guest
(No subject)
« Reply #1 on: July 31, 2007, 07:22:22 PM »

i believe +r can only be set by services
and to my knowledge, when "Svs2mode" was not on it didnt 'give' you +r it was "invisible" or at least on my server it was

did you try re-registering your nick?

[Edited on 7/31/2007 by ben]
Logged

katsklaw

  • Guest
(No subject)
« Reply #2 on: July 31, 2007, 11:41:14 PM »

Quote
Originally posted by ben
i believe +r can only be set by services
and to my knowledge, when "Svs2mode" was not on it didnt 'give' you +r it was "invisible" or at least on my server it was

did you try re-registering your nick?

[Edited on 7/31/2007 by ben]


umode +r has nothing to do with svs2mode, umode +r is requested by services to be set by the ircd when the user identifies to any regisitered nick. If Anope is not changing modes you need to check your ulines.
Logged

ben

  • Guest
(No subject)
« Reply #3 on: August 01, 2007, 07:54:38 PM »

katsklaw i never said +r didnt work without svs2mode i said it doesnt show services setting +r unless its on
Logged

katsklaw

  • Guest
(No subject)
« Reply #4 on: August 02, 2007, 12:03:54 AM »

DarthYodi, I'm still waiting for you to tell me if ChanServ or any other services bot can change modes anywhere.
Logged

DarthYodi

  • Guest
(No subject)
« Reply #5 on: August 02, 2007, 05:31:15 AM »

Anope will change modes such as ops, chan modes, and oper modes, but will not +r a nick for some reason. I have checked the ulines over and over and they are right, they worked on my first install of anope why shouldn't they work now? (I used the same conf file as my first setup)

edit: sorry for the delay.

[Edited on 8/1/2007 by DarthYodi]
Logged

katsklaw

  • Guest
(No subject)
« Reply #6 on: August 02, 2007, 10:14:56 PM »

Quote
Originally posted by DarthYodi
Anope will change modes such as ops, chan modes, and oper modes, but will not +r a nick for some reason. I have checked the ulines over and over and they are right, they worked on my first install of anope why shouldn't they work now? (I used the same conf file as my first setup)

edit: sorry for the delay.

[Edited on 8/1/2007 by DarthYodi]


Part of the problem could be that Anope1.6.5 do not support Unreal 3.2.5 100%, other then that, Anope should be setting +r when a user identifies.

My suggestion is to upgrade to Anope-1.7.19 and see if that fixes the problem.
Logged

DarthYodi

  • Guest
(No subject)
« Reply #7 on: August 03, 2007, 12:06:53 AM »

Quote
Originally posted by katsklaw

Part of the problem could be that Anope1.6.5 do not support Unreal 3.2.5 100%, other then that, Anope should be setting +r when a user identifies.

My suggestion is to upgrade to Anope-1.7.19 and see if that fixes the problem.


As I stated in the first post the problem all started after 1.7.19 was installed so I am hesitant, but I guess it is worth a try again. I'll report back on what happens.
Logged

katsklaw

  • Guest
(No subject)
« Reply #8 on: August 03, 2007, 09:38:12 PM »

1.7.19 works just fine with unreal32.x as well as it's 100% supported. Just so you know, you are the only one that has this problem out of the thousands of others using 1.7.19, I'll bet it's a config setting somewhere that has already been discussed that you are still overlooking.
Logged
Pages: [1]   Go Up