Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: bs_fantasy_ext 1.1.11 bug  (Read 4468 times)

0 Members and 1 Guest are viewing this topic.

paulmer2003

  • Guest
bs_fantasy_ext 1.1.11 bug
« on: June 17, 2007, 06:02:01 AM »

I'm running 1.7.19-svn rev 1250 with bs_fantasy_ext 1.1.11 and charybdis...services are linked via TS6. if I do .op nick1, it works fine. However, if I do .op *, disaster ensues.

[Jun 16 20:24:45.654688 2007] debug: Received: :572AAAAAC PRIVMSG #euphoria :I'm running it debug
[Jun 16 20:24:46.447421 2007] debug: Received: :327AAAAAE PRIVMSG #euphoria :lol
[Jun 16 20:24:48.449221 2007] debug: Received: :572AAAAAC PRIVMSG #euphoria :lets see what bug I get
[Jun 16 20:24:49.437186 2007] debug: Received: :572AAAAAC PRIVMSG #euphoria :.op *
[Jun 16 20:24:49.437495 2007] debug: Emitting event "bot_command" (4 args)
[Jun 16 20:24:49.437792 2007] debug: Sent: :100AAAAAP MODE #euphoria  
[Jun 16 20:24:49.437934 2007] debug: Changing modes for #euphoria to
[Jun 16 20:24:49.439998 2007] debug: Received: SQUIT 100 :by hub.paradise.mo.us: Insufficient parameters (2 < 3) for command 'MODE'
[Jun 16 20:24:49.440335 2007] debug: Emitting event "server_squit" (1 args)
[Jun 16 20:24:49.440418 2007] debug: delete_server() called for services.paradise.net

All hybrid/ratbox based ircds automatically squit remote servers that send them bad syntax for messages.

Other info..:

-OperServ- Module: charybdis [$Id: charybdis.c 953 2006-01-14 11:36:29Z certus $] [Protocol]
-OperServ- Module: bs_fantasy_ext [1.1.11] [3rd]

* Anope-1.7.19-svn (1250) services.paradise.net :Charybdis 1.0+ -  M (enc_old) -- build #1, compiled Jun 16 2007 18:40:34

* charybdis-2.2.0(20070530-3506). hub.paradise.mo.us :eGHIKMpSZ6 TS6ow 454

Everything is working fine besides this issue...other commands that use MODE work fine:
* Freebird sets modes [#euphoria -o paulmer]
-Freebird/#euphoria- DEOP command used for paulmer by paulmer
<paulmer> hrm
* Freebird sets modes [#euphoria +o paulmer]
-Freebird/#euphoria- OP command used for paulmer by paulmer

[Edited on 17-6-2007 by paulmer2003]
Logged

katsklaw

  • Guest
(No subject)
« Reply #1 on: June 17, 2007, 12:24:36 PM »

A few things here ..

1: wildcards are not acceptable in mode strings, you as a user shouldn't have used .op * because you should know it's an invalid string. This is the least important point as where the blame lies is in the servers. Anope and the ircd should be prepared for users doing unacceptable things.

2: the module should know that wildcards are not acceptable in mode strings and should have returned an error to you stating so.

3: Part of a rather contraversial conversation I've had over the last few years with several people on the topic of "trusted connections can't always be trusted" plays well in this scenario and the ircd should have sent an error back to Anope because the IRCd knows that wildcards are not acceptable in mode strings.

* When I say no wildcards in mode strings, that does not include modes like +b and other modes that DO accept them. However, mode +o is not such a mode.
Logged

Jan Milants

  • Team
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1372
(No subject)
« Reply #2 on: June 17, 2007, 12:43:07 PM »

hmmm i never really tested the module on charybdis and didn't know it was that sensitive...

I just did a quick look over the code and it does check whether the user exists with finduser(). either that gives a weird return value with * or there s mistake somewhere else... but anyways i ll look into this.

as for a temporary fix, you can comment OverrideCoreCmds out in the services.conf then the default anope code will handle that for now.

[Edited on 17-6-2007 by Viper]
Logged
If you like me donate coins to 1FBmZVT4J8WAUMHKqpWhgNVj3XXnRN1cCk :)

katsklaw

  • Guest
(No subject)
« Reply #3 on: June 17, 2007, 01:09:31 PM »

I'm wondering if there is a bug in finduser() that's allowing the usage of * or not properly handling that as a parameter. I'll look into this in anope core later today and see what I can find.
Logged

jilles

  • Anope User
  • Offline Offline
  • Posts: 7
(No subject)
« Reply #4 on: June 17, 2007, 03:11:37 PM »

The problem is that you don't check if you have accumulated any valid mode changes at all and happily continue sending an empty mode. The code seems designed to ignore nonexistent users and process the valid ones.
Logged

Jan Milants

  • Team
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1372
(No subject)
« Reply #5 on: June 17, 2007, 03:25:28 PM »

was afraid it would be something like that...

paulmer2003 , i ll try to post another .12 RC later, see if that fixes the problem

edit: Try the version here

[Edited on 17-6-2007 by Viper]
Logged
If you like me donate coins to 1FBmZVT4J8WAUMHKqpWhgNVj3XXnRN1cCk :)
Pages: [1]   Go Up