Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: Read error from server: Unknown error  (Read 5187 times)

0 Members and 1 Guest are viewing this topic.

msken

  • Guest
Read error from server: Unknown error
« on: January 22, 2007, 01:26:54 AM »

Trying to run services, I have been trying to do this for days with no luck. Been bashing my head against a wall for a while now. I seem to be down to this:

[Jan 21 18:03:18 2007] Loading IRCD Protocol Module: [unreal32]
[Jan 21 18:03:18 2007] status:
  • [Module, Okay - No Error]
  • [Jan 21 18:03:18 2007] Loading Encryption Module:
[enc_none]
[Jan 21 18:03:18 2007] status:
  • [Module, Okay - No Error]
  • [Jan 21 18:03:18 2007] Anope 1.7.18 (1214) (ircd protocol: UnrealIRCd 3.2+) starting up
    [Jan 21 18:03:19 2007] ms_rsend requested unload...
    [Jan 21 18:03:19 2007] debug: trying to load core module
[ms_rsend]
[Jan 21 18:03:19 2007] debug: status: [6][Module Error, Error during load time or module returned MOD_STOP]
[Jan 21 18:03:19 2007] MySQL: has been disabled.
[Jan 21 18:03:19 2007] Databases loaded
[Jan 21 18:03:19 2007] Info: Reflecting database records.
[Jan 21 18:03:19 2007] Connected to Server 1 (38.100.89.70:7000)
[Jan 21 18:03:19 2007] trying to load [cs_appendtopic]
[Jan 21 18:03:19 2007] [cs_appendtopic] Loaded successfully
[Jan 21 18:03:19 2007] status:
  • [Module, Okay - No Error]
  • [Jan 21 18:03:19 2007] trying to load
[cs_enforce]
[Jan 21 18:03:19 2007] status:
  • [Module, Okay - No Error]
  • [Jan 21 18:03:19 2007] trying to load
[ns_maxemail]
[Jan 21 18:03:19 2007] status:
  • [Module, Okay - No Error]
  • [Jan 21 18:03:19 2007] trying to load
[os_info]
[Jan 21 18:03:19 2007] os_info: Loading configuration directives...
[Jan 21 18:03:19 2007] os_info: OSInfoDBName is not defined in Services configuration file, using default os_info.db
[Jan 21 18:03:19 2007] os_info: Directive OSInfoDBName loaded (os_info.db)...
[Jan 21 18:03:19 2007] status:
  • [Module, Okay - No Error]
  • [Jan 21 18:03:19 2007] trying to load
[hs_request]
[Jan 21 18:03:19 2007] hs_request loaded
[Jan 21 18:03:19 2007] status:
  • [Module, Okay - No Error]
  • [Jan 21 18:03:19 2007] Read error from server: Unknown error: 0 (error num: 0)
    [Jan 21 18:03:19 2007]
[cs_appendtopic] Unloaded successfully
[Jan 21 18:03:19 2007] hs_request un-loaded

services.conf
IRCDModule "unreal32"
RemoteServer    38.100.89.70 7000 "passw0rd"
ServerName  "services.mwoserver.com"
ServicesRoot "msken"

unrealircd.conf

link   services.mwoserver.com
{
   username *;
   hostname 38.100.89.70;
   bind-ip    *;
   port 7000;
   hub *;
   password-connect "passw0rd";
   password-receive "passw0rd";
   class   servers;
};

listen         38.100.89.70:7000
{
   options
   {
      clientsonly;
   };
};


listen         38.100.89.70:8067;
listen         38.100.89.70:6667;

Anyone have any ideas?
Logged

Jan Milants

  • Team
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1372
(No subject)
« Reply #1 on: January 22, 2007, 10:34:43 AM »

you tell services to connect to port 7000 but your ircd doesn't allow servers on it... it s clientsonly
Logged
If you like me donate coins to 1FBmZVT4J8WAUMHKqpWhgNVj3XXnRN1cCk :)

Jobe

  • Contributor
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1023
    • Anope IRC Services
(No subject)
« Reply #2 on: January 22, 2007, 12:40:49 PM »

Oh and ms_rsend doesnt load if youve not uncommented the option to enable Memo receipts in your services.conf.
Logged
Your IP: ()
My IRC Status:

Come along and visit http://www.anopequotes.org/

msken

  • Guest
(No subject)
« Reply #3 on: January 22, 2007, 11:22:28 PM »

Thanks guys! Up and running.
Logged
Pages: [1]   Go Up