Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: Help installing ANOPE  (Read 13204 times)

0 Members and 1 Guest are viewing this topic.

msken

  • Guest
Help installing ANOPE
« on: January 17, 2007, 02:34:06 AM »

Hi,

I'm a complete newb to iRCD networks and such. I am setting up an IRC server for a Massive Multiplayer Online Game I am developing at www.motorworldonline.net  I have done a ton of reading and threw trail and error I have finally compiled and set up Unreal iRCD 3.2 on my server. I am following this tutorial here: http://news.softpedia.com/news/Building-Your-Own-IRC-Server-With-Services-40772.shtml

But I just can't seem to get my anope services configured and running with Unreal 3.2? Is there anyone trust worthy out there whom I could let use my shell/FTP access to help me get up and running?
Logged

BigBen

  • Anope User
  • Offline Offline
  • Posts: 79
(No subject)
« Reply #1 on: January 17, 2007, 03:39:27 AM »

IF you downloaded Anope services, and have found the example.conf  ( change it to services.conf ) and open in it, and change the stuff that it tells you to do, for example:


listen services.bigtigerirc.net:6669;

link 127.0.0.1
{
username *;
hostname 127.0.0.1;
bind-ip *;
port 6669;
password-connect "---"; be sure the passwords are the same!
password-receive "---";
class servers;
options {

-----------
Services:

RemoteServer 127.0.0.1 6669 "----"

# ServerName <name> [REQUIRED]
# Specifies the IRC server name which Services should use. May be
# overridden by the -name command-line option.

ServerName "127.0.0.1"


# ServerDesc <text> [REQUIRED]
# Specifies the text which should appear as the server's information in
# /whois and similar queries. May be overridden by the -desc
# command-line option.

ServerDesc "Services for IRC Networks"

# ServiceUser <usermask> [REQUIRED]
# Specifies the user@host mask which should be used by the Services
# pseudoclients. May be overridden by the -user and -host command-line
# options.

ServiceUser "Services@BigTigerIRC.net"
 

tell me if it works.

[Edited on 17-1-2007 by BigBen]

[Edited on 17-1-2007 by BigBen]

[Edited on 17-1-2007 by BigBen]
Logged

katsklaw

  • Guest
(No subject)
« Reply #2 on: January 18, 2007, 09:25:19 PM »

uhm, ServerNAME means just that .. A NAME .. not an IP address, all else fails .. read the example.

ServerName "services.somenetwork.tld"

If we used your given example BigBen, it would not link.
Logged

BigBen

  • Anope User
  • Offline Offline
  • Posts: 79
(No subject)
« Reply #3 on: January 18, 2007, 11:02:53 PM »

the support chat said, use it
Logged

katsklaw

  • Guest
(No subject)
« Reply #4 on: January 18, 2007, 11:24:00 PM »

ServerName is the NAME of your services .. you missunderstood what was said in the support channel.

The example.conf specificly says name:

Code: [Select]

# ServerName <name>  [REQUIRED]
#     Specifies the IRC server name which Services should use.  May be
#     overridden by the -name command-line option.

ServerName  "services.localhost.net"


No where do you see ServerName "1.2.3.4"
Logged

BigBen

  • Anope User
  • Offline Offline
  • Posts: 79
(No subject)
« Reply #5 on: January 18, 2007, 11:33:26 PM »

here's the logs:

[21:10] <BigBen> [21:09] -irc.bigtigerirc.net- *** Notice -- Max SendQ limit exceeded for 127.0.0.1: 10026 > 10000
[21:10] <BigBen> -
[21:10] <BigBen> [21:09] -irc.bigtigerirc.net- *** Global -- Closing link: Max SendQ exceeded - 127.0.0.1
[21:11] <Symphonics> U:lines.
[21:12] <BigBen> U stats.bigtigerirc.net
[21:12] <BigBen> U services.bigtigerirc.net
[21:12] <BigBen> End of /STATS report
[21:12] <Symphonics> What's Anope's ServerName directive set to?
[21:13] <Banditz> can anyone help?
[21:13] <BigBen> 127.0.0.1
[21:13] <Banditz> anope stays up for awhile, but then i get: [Jan 17 20:24:45 2007] Read error from server: Broken pipe (error num: 32)
[21:13] * Quits: Vash (Vash@C98C0A9.4588EEC6.33A21ADE.IP) (Ping timeout)
[21:13] <BigBen> now my bot is gone
[21:13] <Symphonics> You need to have Anope U:lined. If Anope is called 127.0.0.1, then that isn't u:lined is it?
[21:14] <Symphonics> Banditz: Is Anope on the same server?
[21:14] <BigBen> i have it on server name
[21:14] <BigBen> it still connects, just that it shutdown again
[21:14] <BigBen> when i made a bot and joined it
[21:15] <Symphonics> Like I said, fix your u:lines and the problem will go away.


[21:33] <Symphonics> link 127.0.0.1... <- Anope's called 127.0.0.1.
[21:33] <Symphonics> So you'll need ulines { 127.0.0.1; };
[21:33] <Symphonics> With any others you need added in, etc.
[21:34] <Banditz> Symphonics
Logged

Jobe

  • Contributor
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1023
    • Anope IRC Services
(No subject)
« Reply #6 on: January 19, 2007, 02:28:25 PM »

Ok is it just me or does anyone else actually fail to see where in that log you were told to NAME your services "127.0.0.1", told to use that in your ulines because thats what you named it maybe but you clearly wernt told to use that as the name in the first place.
Logged
Your IP: ()
My IRC Status:

Come along and visit http://www.anopequotes.org/

Hassankhalid

  • Guest
(No subject)
« Reply #7 on: January 19, 2007, 07:40:11 PM »

1: wget  http://jaist.dl.sourceforge.net/sourceforge/anope/anope-   1.7.18.tar.gz

2: gunzip -d anope-1.7.18.tar.gz
3: tar -xvf  anope-1.7.18.tar
4: cd anope-1.7.18
5:./Config
6: make or gmake
7: make install or gmakeinstall

now
cd  than enter

cd  services +enter

example.cong  rename this file to services.conf  after rename open and edit  add link block to your ircd server  rehash here you go still have any problem let us know thx.
Logged

katsklaw

  • Guest
(No subject)
« Reply #8 on: January 19, 2007, 08:14:44 PM »

Bigben, I never said that you COULD'T name your services a number. yes, it will work. However you seem to fail to understand the "human factor" involved in IRC. The less friendly your environment, the less users you will retain and the more "silly questions" you are likely to answer.

Services needs to be named, this is so your staff don't have to memorize numbers .. they say "services.bigben.net" and KNOW it's services .. they don't have to guess. instead of wtf is 127.0.0.1?!?!

Imagine a server map that looks like this:

Code: [Select]

192.168.200.100                                      (200)  1
|-192.168.201.50                                      (90)  250
`-127.0.0.1                                               (5)  251


As opposed to a normal looking map:

Code: [Select]

server1.someirc.net                                        (200)  1
|-server2.someirc.net                                      (90)  250
`-services.someirc.net                                     (5)  251


The second example is ALOT more self explainatory, easier to read and human friendly.

As a second observation I love you you made your listen block a roundrobin hostname .. just imagine how that will work out when suddenly servers can no longer connect due to the ambiguous instructions you've given.


Let's dummy this up a bit and use a WORKING example:

ircd.conf:
-------------------------

listen 127.0.0.1:6669;

link services.bigtigerirc.net
{
username *;
hostname 127.0.0.1;
bind-ip *;
port 6669;
password-connect "---"; be sure the passwords are the same!
password-receive "---";
class servers;
};

ulines { services.bigtigerirc.net };

set { services-server "services.bigtigerirc.net" };

include "aliases/anope.conf";

-----------
Services:

IRCDModule "unreal32"
Numeric 250

RemoteServer 127.0.0.1 6669 "----"

# ServerName <name> [REQUIRED]
# Specifies the IRC server name which Services should use. May be
# overridden by the -name command-line option.

ServerName "services.bigtigerirc.net"

[Edited on 26-1-2007 by katsklaw]
Logged
Pages: [1]   Go Up