Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: Services is running, but IRC commands don't recognise their presence.  (Read 7374 times)

0 Members and 1 Guest are viewing this topic.

eurosong

  • Guest

Hi all, I have a problem.

I am running bahamut-1.8.3 server, and have installed anope-1.6.5.

I have edited the config files as per the guide at
http://www.anope.org/~heinz/ilm.php?p=1

I started the services, and they successfully connected to my IRCd: when I type /links in mIRC, then the Services shows up as a link. All good so far.

The problem, however, is that when I actually try to access any of the services commands (chanserv etc), I am simply faced with a message from my IRCD:

"Services is currently down. Please wait a few moments, and then try again."

... just as if the services are not present at all!

My Bahamut config file includes the following lines:
==============
/* class for services */
class {
    name        services;
    pingfreq    60;         # Idle check every minute
    maxsendq    5000000;    # 5MB backlog buffer
};

connect {
 name services.eurosong.net;
 host 127.0.0.1;
 apasswd *****;
 cpasswd *****;
 bind 127.0.0.1;
 class services;
};

super {
 "services.eurosong.net";
};
==============

(Anope is running on the same machine, hence the local IP).

Can anyone shed some light on the problem? It's especially strange, because as I say, the services have been linked correctly. It's as if the IRCD does not recognise the fact that the linked server is actually Services.

Thanks.
Logged

BigBen

  • Anope User
  • Offline Offline
  • Posts: 79
(No subject)
« Reply #1 on: December 18, 2006, 01:14:15 AM »

did u go in the UnrealIRCd config? it needs to say.

link            services.servername.com
{
   username   *;
   hostname    127.0.0.1;
   bind-ip    *;
   port       6667;
   hub             *;
   password-connect "LiNk";
   password-receive "LiNk";
   class           servers;
      options {
         /* Note: You should not use autoconnect when linking services */
            zip;

};



dont forget to /rehash
Logged

eurosong

  • Guest
(No subject)
« Reply #2 on: December 18, 2006, 01:35:15 AM »

I am running Bahamut, not Unreal...
Logged

BigBen

  • Anope User
  • Offline Offline
  • Posts: 79
(No subject)
« Reply #3 on: December 18, 2006, 02:13:37 AM »

never haerd of that one. may be someone has that kinda server, and they can help.
Logged

owine

  • Anope User
  • Offline Offline
  • Posts: 130
(No subject)
« Reply #4 on: December 18, 2006, 02:18:42 AM »

make sure you correctly specified your services server name when configuring bahamut. per the docs:
Code: [Select]
This is the services domain name. It doesn't actually have to point to services (ie. services.wood-soft.co.uk doesn't really exist).
If you have network services and would like to make use of
the built in secure services aliasing features, type in the
name of your network services server here. If you are a
DALnet admin, you would type in "services.dal.net" below.
[services.dal.net] - services.wood-soft.co.uk


that name must match the name in your link block and the ServerName config in services.conf.
Logged

Jobe

  • Contributor
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1023
    • Anope IRC Services
(No subject)
« Reply #5 on: December 18, 2006, 05:57:45 PM »

Quote
Originally posted by BigBen
never haerd of that one. may be someone has that kinda server, and they can help.


Just for reference BigBen had he been running UnrealIRCd with the same problem it would be because heshe hadnt set set::services-server correctly.
Logged
Your IP: ()
My IRC Status:

Come along and visit http://www.anopequotes.org/

eurosong

  • Guest
(No subject)
« Reply #6 on: December 18, 2006, 08:24:33 PM »

Thanks for trying to help, but I have checked everything and still can not see anything wrong.

In my Anope services.conf, I have the following specified:

ServerName  "services.eurosong.net"

This, as you can see, is identical to the Services name as specified in my ircd.conf.
Logged

katsklaw

  • Guest
(No subject)
« Reply #7 on: December 18, 2006, 08:36:06 PM »

This has nothing to do with linking, as stated ... services are successfully connected.

Bahamut-1.8.x:
in your bahamut conf file in the options block make sure services_name matches services.eurosong.net.

Bahamut-1.4:
specify services.eurosong.net when running ./config as the name of your services.
Logged

eurosong

  • Guest
(No subject)
« Reply #8 on: December 19, 2006, 01:03:39 AM »

Ahhh...
Thank you Scott!

This services_name option was not mentioned in the "template.conf": the example provided with Bahamut from which I was working... therefore I had no clue as to its existence. Now you have pointed me in the right direction, I have an options block with the variable... and the Services are working correctly :)

Thanks a lot!
Logged

katsklaw

  • Guest
(No subject)
« Reply #9 on: December 19, 2006, 04:21:22 AM »

for more settings read the reference.conf, it explains alot more than what's in the template.conf
Logged
Pages: [1]   Go Up