Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: bs_fantasy_ext  (Read 3131 times)

0 Members and 1 Guest are viewing this topic.

serpe

  • Guest
bs_fantasy_ext
« on: November 09, 2006, 02:09:12 PM »

Hi.
I try to install this module but when i install it give me an error:
access.c:49: error: `CHAN_ACCESS_XOP_HOP' undeclared (first use in this function)
access.c:49: error: (Each undeclared identifier is reported only once
access.c:49: error: for each function it appears in.)
make[2]: *** [main.o] Error 1
Logged

Jan Milants

  • Team
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1372
(No subject)
« Reply #1 on: November 09, 2006, 05:20:07 PM »

check requirements before trying it ...

bs_fantasy_ext v1.1.11 is only supported on Anope 1.7.16 and above... in some cases modules will work with older Anope's, but in this case it won't.

[Edited on 9-11-2006 by Viper]
Logged
If you like me donate coins to 1FBmZVT4J8WAUMHKqpWhgNVj3XXnRN1cCk :)

serpe

  • Guest
(No subject)
« Reply #2 on: November 09, 2006, 06:36:05 PM »

Ah ok thanks. And there is a same module for anope1.7.15 ?
Logged

Jan Milants

  • Team
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1372
(No subject)
« Reply #3 on: November 09, 2006, 07:28:29 PM »

v1.1.10 worked on 1.7.15, however i do not support old versions because they may contain unfixed bugs, and well i just can't test my work on every singly development version of anope so i chose to only support the latest dev version released.

Administrators should always update their software when an update is available anyways, certainly if that software is still a development release rather then module writers having to keep everything backwards compatible with development releases... if it were stable releases, there d be a point in keeping the modules backwards compatible within a branch, but i don't see any point in keeping it compatible with older development releases...

edit: a copy of 1.1.10 can be found here, however know that it s unsupported and provided "as is"...

[Edited on 9-11-2006 by Viper]
Logged
If you like me donate coins to 1FBmZVT4J8WAUMHKqpWhgNVj3XXnRN1cCk :)
Pages: [1]   Go Up