Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: logchan - can't use set command with operserv  (Read 7532 times)

0 Members and 1 Guest are viewing this topic.

OssieB

  • Guest
logchan - can't use set command with operserv
« on: February 25, 2006, 09:58:14 PM »

hi,
i got a question: how can i turn on the logchan with operserv?
i added the logchan in the services.conf but i cant use the /msg operserv set (command) at all.
gives this error:  *OperServ* Unknown command set. "/msg OperServ HELP" for help.
anyone who could help me get it fixed?
Logged

lavinpj1

  • Guest
(No subject)
« Reply #1 on: February 25, 2006, 10:45:19 PM »

Sounds to me like the operserv modules are messed up. Make sure the OS_Modules is all on one line and you have the necessary modules in there.
Logged

Tom65789

  • Anope User
  • Offline Offline
  • Posts: 343
    • www.t65789.co.uk
(No subject)
« Reply #2 on: February 26, 2006, 12:31:41 AM »

are you using: /msg OperServ set logchan on

and make sure you have got the Config set to a channel which i assume you have:

Code: [Select]

# LogChannel <channel> [OPTIONAL]
#
#     When defined, services will output log messages to this channel.
#     IMPORTANT: This can be a security risk so make certain this channel
#     is sufficiently protected from normal access.

LogChannel "#logchan"

Trystan Scott Lee

  • Contributor
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 343
(No subject)
« Reply #3 on: February 26, 2006, 01:03:27 AM »

os_set must be loaded then /os set logchan on will work
Logged
my God my tourniquet, return to me salvation

OssieB

  • Guest
(No subject)
« Reply #4 on: February 26, 2006, 08:17:22 AM »

thx for the help but i still cant get it to work
i double checked the services.conf and os_set is in the operserv modules line.
and the logchannel is also set.
but i cant seem to get the "/os set" command to work.
are there any flags i need to set extra on O-line to get it working, i tried services-admin and allmost all other modes?

*i just tried to manually load the os_set module with /os modload os_set but that wont work either, all other modules load fine with /os modload , even os_raw but there's something thats preventing me from loading os_set.
os_set is present in modules folder though

[Edited on 26-2-2006 by OssieB]
Logged

ShelLuser

  • Guest
(No subject)
« Reply #5 on: February 26, 2006, 01:37:17 PM »

Quote
Originally posted by OssieB
but i cant seem to get the "/os set" command to work.

Are you now talking about the literal command "/os set" or are we talking about a shortcut for "/msg operserv set ...". Because the first has nothing to do with Anope but the aliases your ircd may or may not support.  Just a sidenote.

Second thing I'm wondering about, but I am not sure here, have you also tried using the "LogBot" option ?  This is but a guess but I wonder if all ircds support services dumping text in the channel without an "entity" doing so.

And I'm also wondering if you already tried debugging the obvious options (like checking if the logchan isn't denied by your services or ircd for example).
Logged

OssieB

  • Guest
(No subject)
« Reply #6 on: February 26, 2006, 03:02:28 PM »

we were talking about /msg operserv set :)
but i just started from scratch again, new config file etc..
works fine now, so dunno what was wrong before
thx for all the help guys
Logged
Pages: [1]   Go Up