Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: "/msg nickserv" is not supported! *NIX+Unreal3.2+Anope1.7.15  (Read 4680 times)

0 Members and 1 Guest are viewing this topic.

ErZo

  • Guest
"/msg nickserv" is not supported! *NIX+Unreal3.2+Anope1.7.15
« on: October 01, 2006, 01:39:21 PM »

Hello. I've done some researching into my little problem, but without luck. I am now going to ask you for help regarding this matter.

The problem:
Services launches fine, get's connected, syncs. When using "/msg nickserv <command>" We get an message from ANOPE (note, not unrealircd.) saying that says:
("/msg nickserv" is no longer supported.  Use "/msg nickserv@services.phractured.net" or "/nickserv" instead. )

The thing is, I thought it was some kind of configuration error, I made. Like, not including /aliases/anope.conf in the unrealircd.conf file, or not setting my services-server services.phractured.net; or something.
which it apparently, isn't wrong.

I've included /aliases/anope.conf, I've set { services-server services.phractured.net; }; and for all I know, I've say my Anope Services up correctly..

Does anyone have information about this? I've done extensive searching here, in the Anope forums, the UnrealIRCd forums, and random googleing.
Logged

Jobe

  • Contributor
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1023
    • Anope IRC Services
(No subject)
« Reply #1 on: October 01, 2006, 01:51:10 PM »

If you've set up your aliases correctly then the /nickserv and /ns aliases should work instead of /msg NickServ otherwise youll have to use "/msg NickServ@services.phractured.net" instead. The alternative is you comment out UseStrictPrivMsg in your services.conf file and restart Anope.
Logged
Your IP: ()
My IRC Status:

Come along and visit http://www.anopequotes.org/

Dave Robson

  • Team
  • *
  • Offline Offline
  • Posts: 357
(No subject)
« Reply #2 on: October 01, 2006, 02:17:38 PM »

Anope now has an optional configureation setting called "UseStrictPrivMsg" when enabled (as you've clearly set it to) anope will not accept /msg nickserv bleh style messages.  

If you cant get your ircds aliases to work, then disable the anope option.
Logged

ErZo

  • Guest
(No subject)
« Reply #3 on: October 01, 2006, 04:05:40 PM »

Ah, so that's what is nutty! I'll see if I got UseStrictPrivMsg enabled. The thing is, it must be. Since the aliases works fine, /ns /nickserv. It's just that my client doesn't recognize that. so, I have to /msg nickserv in order to issue commands.

Thanks for the fast responses, peeps :)
I'm very grateful.
Logged

ErZo

  • Guest
(No subject)
« Reply #4 on: October 01, 2006, 08:48:45 PM »

That was it, it was UseStrictPrivMsg. Thanks alot guys :-)
Logged

katsklaw

  • Guest
(No subject)
« Reply #5 on: October 01, 2006, 09:12:57 PM »

most all clients support the /quote or /raw command to send commands past the client to the server. For example: /quote ns identify blah would send the comannd NS straight to the server instead of the client bailing because it's an unknown command.

If you client supports scripts of any kind it would be advisable to create a script to pass these commands to the server instead of sacrificing the security that's created by UseStrictPrivMsg.
Logged
Pages: [1]   Go Up