Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: vhost_fantasy problems  (Read 7244 times)

0 Members and 1 Guest are viewing this topic.

setti

  • Guest
vhost_fantasy problems
« on: February 20, 2006, 02:24:13 PM »

I would thank you Trystan for this nice module.

But ive problems to get it work for me.

1st of all i added the following to my services.conf

Code: [Select]
RequestChan #vhost

After that i loaded the module with this command:

/os modload vhost_fantasy

If got a message, that the module was successfully loaded.
But no bot or whatever joined the chan!

I can request a vhost by typing /msg HostServ ......
But the !vhost command isnt recognised...
What did i wrong?

Im Using UnrealIRCD (newest version) and anope-devel.

[Bearbeitet am 20-2-2006 von setti]
Logged

Trystan Scott Lee

  • Contributor
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 343
(No subject)
« Reply #1 on: February 20, 2006, 03:14:21 PM »

You MUST assign the bot to the channel, it can not random assign the bot.
Logged
my God my tourniquet, return to me salvation

setti

  • Guest
(No subject)
« Reply #2 on: February 20, 2006, 03:17:31 PM »

what do you mean with assign???

How do i assign a bot?

And maybe you can tell me how do i change the nick of this bot!

thx for your help!
Logged

Symphonics

  • Guest
(No subject)
« Reply #3 on: February 20, 2006, 03:47:59 PM »

/bs help bot & /bs help assign
I assume it works though any botserv robot?
Logged

Trystan Scott Lee

  • Contributor
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 343
(No subject)
« Reply #4 on: February 20, 2006, 03:51:53 PM »

works with any bot, as long as they are assigned to the RequestChan
Logged
my God my tourniquet, return to me salvation

setti

  • Guest
(No subject)
« Reply #5 on: February 20, 2006, 06:14:43 PM »

Syntax: ASSIGN Channel Botnick


whats the the name of your bot?

[19:13:10] —› *botserv* assign #vhosts HostServ

Bot HostServ is unknown....
Logged

Symphonics

  • Guest
(No subject)
« Reply #6 on: February 20, 2006, 07:43:51 PM »

BotServ can only assign it's own bots. (I.E. Ones you make with it.)
You can't assign the standard service bots with BotServ.

You'll have to make another robot with BotServ and assign it. (E.G. vHostServ.)
Logged

setti

  • Guest
(No subject)
« Reply #7 on: February 20, 2006, 07:57:42 PM »

ok i already created one. but the bot didnt recognise my !vhost trigger....

How do i tell the bot to recognise the trigger?

In my opinion i have to link the bot with vhost_fantasy... But how???
Logged

Symphonics

  • Guest
(No subject)
« Reply #8 on: February 20, 2006, 08:08:44 PM »

I assume fantasy commands aren't on or something?
/bs set #whatever fantasy on
Logged

setti

  • Guest
(No subject)
« Reply #9 on: February 20, 2006, 08:24:36 PM »

fantasy mode is set "on"

Bot no reaction if i type !vhost :(

I just love this tiny module :((((


o my fault!

!vhost is working!

But not repsonding when only typing "!vhost"

When i typed "!vhost help" ive got an error!

I Thought i could get some help announcing from the bot! :(

[Bearbeitet am 20-2-2006 von setti]
Logged

Trystan Scott Lee

  • Contributor
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 343
(No subject)
« Reply #10 on: February 22, 2006, 04:31:11 AM »

Okay if you grab it from the site again

http://www.nomadinc.net/mymods/files/vhost_fantasy.c

1. Added config file variable VhostsRequestHelp, which you can set what the message will be on !vhost and !vhost help

2. On load it checks if the channel has a bot assigned if not it throws a warning
3. On load it checks if the channel does not have fantasy commands enabled
4. There are more debugs
Logged
my God my tourniquet, return to me salvation

setti

  • Guest
(No subject)
« Reply #11 on: February 23, 2006, 08:30:17 AM »

thx a lot!
A last question:

How can i make multiline VhostsRequestHelp?
Logged

juanker

  • Guest
(No subject)
« Reply #12 on: February 23, 2006, 08:22:15 PM »

Btw. the module works like a charm, good work :)
Logged

n00bie

  • Anope User
  • Offline Offline
  • Gender: Male
  • Posts: 411
(No subject)
« Reply #13 on: March 05, 2006, 08:08:27 AM »

there can be a really mis-confusion when using anope-1.7.13 and assign one of the fatasy command from services.conf. I assign '@' as a botserv fantasy command for my services and when loading the vhost_fantasy module .. i notice that it dont work. I checked the compiling errors, but no errors! at last i found out that the main problem was the fantasy command. I do !vhost bleh.hehe.lol .. it don't work.. and when i do @vHost yes.it.works.now .. it works .. hehe ;)
Logged
I am always doing things that which I cannot do, in order that I may learn how to do it.
Pages: [1]   Go Up