Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: hello  (Read 4940 times)

0 Members and 1 Guest are viewing this topic.

lost_soul

  • Guest
hello
« on: July 15, 2006, 05:40:37 PM »

just a quick hello from a new member, I've heard extremely good things about anope and am anxiously waiting to get mine up and running.  I've finally got it down to only receiving one error message.  I'll done alot of googling about this topic, but nothing really is speaking of the issue I have.  

System Stats:  Pentium III (450mhz) 384meg sdram running FreeBSD6.1, UnrealIRCD, Eggdrop, and of course Anope.

Apparently when I pkg_add -r anope, for some reason or another a services.log file was never created.  I tried also doing man anope to RTFM to no avail (No manual entry for anope) same with the help file btw.
A friend suggested "touch services.log" which did in fact create an empty services.log file, however the error still is appearing.  The error is as follows not that I can see it being much help.

Warning: unable to open log file services.log: No such file or directory

apparently the guy that compiled this for FreeBSD made the binary named anope..  Doing ./anope -nofork gives me the following output

$ ./anope -nofork
Warning: unable to open log file services.log: No such file or directory
[Jul 15 12:33:02 2006] Anope 1.6.3 (427) (compiled for UnrealIRCd 3.1.1+) starting up
[Jul 15 12:33:03 2006] MySQL has been disabled.
[Jul 15 12:33:03 2006] Attempting to load V3 HS Database
[Jul 15 12:33:03 2006] Databases loaded
[Jul 15 12:33:03 2006] Connected to Server 1 (localhost:6667)
[Jul 15 12:33:03 2006] Read error from server: Unknown error: 0

I'm back to my googling..  and just so the base is covered.  I have changed the permissions of the services.log file I tried to create by giving chmod 744 services.log.  I noticed some files in the folder were using 600 and 644.  I used 744 after reading something about that particular file needing all permissions.

Thanks, it's a pleasure to meet everyone.  And btw sorry for the long post. :)
Logged

katsklaw

  • Guest
(No subject)
« Reply #1 on: July 15, 2006, 05:56:13 PM »

try using 127.0.0.1 instead of localhost
Logged

lost_soul

  • Guest
thanks
« Reply #2 on: July 15, 2006, 07:13:42 PM »

katsklaw, thanks for the speedy response.  Shortly after making the post I removed the pre-compiled package I had used.  This time doing the full make on it and used the same services.conf file I was using previously.  Upon completion this time their was a services.log file, woohoooo (thats a good start).  But my happiness was short lived, I then tried to run anope again and ended up with the same errors I previously listed with the exception of the services.log error.  I came back to post another message explaining the progress I had made and noticed your reply to me.  I adjusted my services.conf file as instructed.

the output of  ./anope -nofork -debug is as follows now
[Jul 15 14:10:41.417526 2006] Anope 1.6.3 (427) (compiled for UnrealIRCd 3.1.1+) starting up (options: debug)
[Jul 15 14:10:41.420617 2006] debug: Loading language 10 from file `languages/cat'
[Jul 15 14:10:41.501407 2006] debug: Loading language 9 from file `languages/de'
[Jul 15 14:10:41.580729 2006] debug: Loading language 0 from file `languages/en_us'
[Jul 15 14:10:41.659684 2006] debug: Loading language 4 from file `languages/es'
[Jul 15 14:10:41.738525 2006] debug: Loading language 6 from file `languages/fr'
[Jul 15 14:10:41.817242 2006] debug: Loading language 11 from file `languages/gr'
[Jul 15 14:10:41.896167 2006] debug: Loading language 5 from file `languages/pt'
[Jul 15 14:10:41.973626 2006] debug: Loading language 7 from file `languages/tr'
[Jul 15 14:10:42.052903 2006] debug: Loading language 8 from file `languages/it'
[Jul 15 14:10:42.146387 2006] debug: Loading language 12 from file `languages/nl'
[Jul 15 14:10:42.242094 2006] debug: Loading language 13 from file `languages/ru'
[Jul 15 14:10:42.326389 2006] debug: Loaded languages
[Jul 15 14:10:42.333095 2006] MySQL has been disabled.
[Jul 15 14:10:42.338326 2006] debug: Loaded NickServ database (1/7)
[Jul 15 14:10:42.343518 2006] Attempting to load V3 HS Database
[Jul 15 14:10:42.348592 2006] debug: Loaded HostServ database (2/7)
[Jul 15 14:10:42.353677 2006] debug: Loaded BotServ database (3/7)
[Jul 15 14:10:42.358861 2006] debug: Loaded ChanServ database (4/7)
[Jul 15 14:10:42.364174 2006] debug: Loaded OperServ database (5/7)
[Jul 15 14:10:42.369396 2006] debug: Loaded news database (6/7)
[Jul 15 14:10:42.374589 2006] debug: Loaded exception database (7/7)
[Jul 15 14:10:42.379582 2006] Databases loaded
[Jul 15 14:10:42.384554 2006] debug: Saving FFF databases
[Jul 15 14:10:42.432042 2006] Connected to Server 1 (127.0.0.1:6667)
[Jul 15 14:10:42.437351 2006] debug: Sent: PROTOCTL NICKv2 VHP
[Jul 15 14:10:42.442430 2006] debug: Sent: PASS :mypass
[Jul 15 14:10:42.449931 2006] debug: Sent: SERVER filesrv.domain.org 1 :Services for IRC Networks
[Jul 15 14:10:42.455360 2006] debug: Sent: NICK NickServ 1 1152987042 services 127.0.0.1 filesrv.domain.org 0 +oS * :Nickname Ser
[Jul 15 14:10:42.463072 2006] debug: Sent: SQLINE NickServ :Reserved for services
[Jul 15 14:10:42.470586 2006] debug: Sent: NICK ChanServ 1 1152987042 services 127.0.0.1 filesrv.domain.org 0 +oS * :Channel Serv
[Jul 15 14:10:42.475932 2006] debug: Sent: SQLINE ChanServ :Reserved for services
[Jul 15 14:10:42.485036 2006] debug: Sent: NICK HostServ 1 1152987042 services 127.0.0.1 filesrv.domain.org 0 +oS * :vHost Server
[Jul 15 14:10:42.490735 2006] debug: Sent: SQLINE HostServ :Reserved for services
[Jul 15 14:10:42.495843 2006] debug: Sent: NICK MemoServ 1 1152987042 services 127.0.0.1 filesrv.domain.org 0 +oS * :Memo Server
[Jul 15 14:10:42.501605 2006] debug: Sent: SQLINE MemoServ :Reserved for services
[Jul 15 14:10:42.506735 2006] debug: Sent: NICK BotServ 1 1152987042 services 127.0.0.1 filesrv.domain.org 0 +oS * :Bot Server
[Jul 15 14:10:42.511872 2006] debug: Sent: SQLINE BotServ :Reserved for services
[Jul 15 14:10:42.517325 2006] debug: Sent: NICK HelpServ 1 1152987042 services 127.0.0.1 filesrv.domain.org 0 +oS * :Help Server
[Jul 15 14:10:42.522280 2006] debug: Sent: SQLINE HelpServ :Reserved for services
[Jul 15 14:10:42.527351 2006] debug: Sent: NICK OperServ 1 1152987042 services 127.0.0.1 filesrv.domain.org 0 +ioS * :Operator Se
[Jul 15 14:10:42.537140 2006] debug: Sent: SQLINE OperServ :Reserved for services
[Jul 15 14:10:42.542432 2006] debug: Sent: NICK Global 1 1152987042 services 127.0.0.1 filesrv.domain.org 0 +ioS * :Global Notice
[Jul 15 14:10:42.547602 2006] debug: Sent: SQLINE Global :Reserved for services
[Jul 15 14:10:42.552649 2006] debug: Received: :localhost.net NOTICE AUTH :*** Looking up your hostname...
[Jul 15 14:10:42.558173 2006] unknown message from server (:localhost.net NOTICE AUTH :*** Looking up your hostname...)
[Jul 15 14:10:42.563690 2006] debug: Received: :localhost.net NOTICE AUTH :*** Found your hostname (cached)
[Jul 15 14:10:42.569219 2006] unknown message from server (:localhost.net NOTICE AUTH :*** Found your hostname (cached))
[Jul 15 14:10:43.433396 2006] debug: Received: ERROR :Link denied (No matching link configuration) [@127.0.0.1.59610]
[Jul 15 14:10:43.437914 2006] unknown message from server (ERROR :Link denied (No matching link configuration) [@127.0.0.1.59610]
[Jul 15 14:10:43.443381 2006] debug: Received: ERROR :Closing Link: [127.0.0.1] (Link denied (No matching link configuration))
[Jul 15 14:10:43.448371 2006] unknown message from server (ERROR :Closing Link: [127.0.0.1] (Link denied (No matching link config
)))
[Jul 15 14:10:43.455735 2006] Read error from server: Unknown error: 0
[Jul 15 14:10:43.456327 2006] debug: Sent: :filesrv.domain.org SQUIT filesrv.domain.org :Read error from server: Unknown error: 0

Still playin with my config file but wanted to pop in and send my thanks for the help given and show the progress made :)
Logged

Jobe

  • Contributor
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1023
    • Anope IRC Services
(No subject)
« Reply #3 on: July 15, 2006, 08:16:09 PM »

Ok the error "[Jul 15 14:10:43.437914 2006] unknown message from server (ERROR :Link denied (No matching link configuration) [@127.0.0.1.59610]" is saying that the IRCd has not got a link block with the same name that you have put for ServicesName in your services.conf file.
Logged
Your IP: ()
My IRC Status:

Come along and visit http://www.anopequotes.org/

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
(No subject)
« Reply #4 on: July 16, 2006, 09:26:34 AM »

Also, you don't mention (or at least I can't find it) whether you are using Unreal3.2.x - If you are, you should really use a newer anope on the development branch (1.7.14) ... It's stable enough trust me there, as we don't really support the idea of Unreal3.2.x with 1.6.x.

Looks like you've done yourself most of the work though, good stuff :)
Logged
Pages: [1]   Go Up