Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: Error while loading m_xmlrpc  (Read 1662 times)

0 Members and 1 Guest are viewing this topic.

cyres

  • Anope User
  • Offline Offline
  • Posts: 1
Error while loading m_xmlrpc
« on: July 11, 2014, 01:54:39 PM »

Hi,

i want to load xmlrpc but it doenst work.

Error while loading m_xmlrpc: Unable to find http reference, is m_httpd loaded?

Anope 2.0.1

/os modlist
Quote
-OperServ- Current module list:
-OperServ- Module: unreal [2.0.1] [Protocol, Vendor]
-OperServ- Module: db_sql_live [2.0.1] [Database, Vendor]
-OperServ- Module: enc_md5 [2.0.1] [Encryption, Vendor]
-OperServ- Module: m_mysql [2.0.1] [Extra, Vendor]
-OperServ- Module: m_sql_authentication [2.0.1] [Extra, Vendor]
-OperServ- Module: m_httpd [2.0.1] [Extra, Vendor]
-OperServ- 6 modules loaded.

modules.conf
Quote
module
{
        name = "m_httpd"

        httpd
        {
                /* Name of this service. */
                name = "httpd/main"

                /* IP to listen on. */
                ip = "127.0.0.1"

                /* Port to listen on. */
                port = 7070

                /* Time before connections to this server are timed out. */
                timeout = 30

                /* Listen using SSL. Requires an SSL module. */
                #ssl = yes

                /* If you are using a reverse proxy that sends one of the
                 * extforward_headers set below, set this to its IP.
                 * This allows services to obtain the real IP of users by
                 * reading the forwarded-for HTTP header.
                 */
                #extforward_ip = "192.168.0.255"

                /* The header to look for. These probably work as is. */
                extforward_header = "X-Forwarded-For Forwarded-For"
        }
}

Any idea? THX
module
{
        name = "m_xmlrpc"

        /* Web service to use. Requires m_httpd. */
        server = "httpd/main"
}
module { name = "m_xmlrpc_main" }

Please delete! I make a hard restart and now ist working.
« Last Edit: July 11, 2014, 01:56:57 PM by cyres »
Logged
Pages: [1]   Go Up