Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: I have the nick registered but does not change the minute not identify  (Read 4689 times)

0 Members and 1 Guest are viewing this topic.

carlos toloza

  • Anope User
  • Offline Offline
  • Posts: 2

hello pls help me.

I have the nick registered but does not change the minute not identify


example:

join serverirc.XXXX.com

/nick merlin

[20:01] NickServ: This nickname is registered and protected. If this is your
[20:01] Nick: nick, type / msg NickServ IDENTIFY password. If not,
[20:01] NiCK: please choose a different nick.

now change 1 minute nickname

as an asset to the minute you change all users having their nick registered or to be registered?

pls help me
Logged

Jeffrey Turner

  • Anope User
  • Offline Offline
  • Gender: Male
  • Posts: 17
    • TurnerGames

You may not have it set to "kill" those that aren't auth.

Check "/msg nickserv help set kill"

Nickserv options for newly registered nicks, if you want this feature to be default you should enabled one of the following:

Code: [Select]
* -   killprotect: Kill nick if not identified within 60 seconds
* -   kill_quick: Kill nick if not identified within 20 seconds, this one overrides the above

This wont change the behavior for already registered nicks. So you will need to have those that want the feature, to issue one (or more) of the commands to enable/turn on the feature.
Logged
Jeffrey "Zero" Turner

Yoerger

  • Contributor
  • *
  • Offline Offline
  • Posts: 12
    • Fletzia Secure Services

(Assuming you are using Anope 2)

If you want all nicks to automatically be killed if the user using them does not identify, you need to edit nickserv.conf line 114:
Code: [Select]
defaults = "ns_secure ns_private hide_email hide_mask memo_signon memo_receive autoop"Add to the end of it:
Code: [Select]
defaults = "ns_secure ns_private hide_email hide_mask memo_signon memo_receive autoop killprotect"(You can also add kill_quick)

See the help for that on line 94:
Code: [Select]
* -   killprotect: Kill nick if not identified within 60 seconds
* -    kill_quick: Kill nick if not identified within 20 seconds, this one overrides the above
*                    option and the above must be specified with this one

If you just want to enable this feature for your own nick, then just use: (Be identified as this nick)
Code: [Select]
/msg NickServ SET KILL ONor
Code: [Select]
/msg NickServ SET KILL QUICK
If you want to change the times of killprotect or kill_quick, that is found later in nickserv.conf on lines 162 and 163:
Code: [Select]
killquick = 20s
kill = 60s
« Last Edit: June 25, 2014, 01:34:22 AM by Yoerger »
Logged
Yoerger
Support Contributor / Wiki Administrator
Anope IRC Services

carlos toloza

  • Anope User
  • Offline Offline
  • Posts: 2

and use anope-1.8.8
Logged

Yoerger

  • Contributor
  • *
  • Offline Offline
  • Posts: 12
    • Fletzia Secure Services

You should update to Anope 2. It's got a lot more features and advancements.
Here is information on how to do that: http://wiki.anope.org/index.php/2.0/Installation

In anope 1.8:
Use /msg NickServ SET just the same as described above.
For more info /msg NickServ HELP SET KILL

To make this default, uncomment lines 767 and optionally 768 in services.conf.
Code: [Select]
#NSDefKill
#NSDefKillQuick
Logged
Yoerger
Support Contributor / Wiki Administrator
Anope IRC Services

John

  • Anope User
  • Offline Offline
  • Gender: Male
  • Posts: 19
    • IRCSpeed - The Network with a Difference

hello pls help me.

I have the nick registered but does not change the minute not identify

Usually, if the nickname you're using doesn't force change your nick, it means that NickServ has a current hostmask match for your access list.

Code: [Select]
/nickserv help access
The hosts in your access list will NOT make NickServ force your nick change. This is a good thing :)
Every nickname that does not match the access list will be forced.
Logged

EduardO

  • Anope User
  • Offline Offline
  • Posts: 1

when I save the changes and restart the services, does not work


defaults = "ns_secure ns_private hide_email hide_mask memo_signon memo_receive autoop killprotect"

Help me !!
Logged
Pages: [1]   Go Up