Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Poll

Just curious, Which version do you use?

1.8
- 5 (31.3%)
1.9
- 11 (68.8%)
1.7
- 0 (0%)

Total Members Voted: 16


Pages: [1]   Go Down

Author Topic: Which branch do you use?  (Read 4304 times)

0 Members and 1 Guest are viewing this topic.

katsklaw

  • Supporter
  • Anope User
  • Offline Offline
  • Posts: 537
Which branch do you use?
« on: July 10, 2013, 04:49:58 PM »

As the poll asks, which version do you use?
Logged

Gianluca

  • Anope User
  • Offline Offline
  • Posts: 27
Re: Which branch do you use?
« Reply #1 on: July 23, 2013, 10:07:21 AM »

1.9
Logged

Jens Voss

  • Team
  • *
  • Offline Offline
  • Posts: 121
Re: Which branch do you use?
« Reply #2 on: August 02, 2013, 07:39:59 AM »

I voted for 1.9 and added the "1.7" option. There are still networks around that use 1.7.
Logged

Gianluca

  • Anope User
  • Offline Offline
  • Posts: 27
Re: Which branch do you use?
« Reply #3 on: August 04, 2013, 09:56:06 AM »

but the future anope 2.0 is the fusion from 1.8 and 1.9 version?
Logged

katsklaw

  • Supporter
  • Anope User
  • Offline Offline
  • Posts: 537
Re: Which branch do you use?
« Reply #4 on: August 04, 2013, 01:56:17 PM »

but the future anope 2.0 is the fusion from 1.8 and 1.9 version?

No, 1.7 became 1.8, 1.9 becomes 2.0, 2.1 becomes 2.2, 2.3 becomes 2.4 ... etc.

odd numbers are development versions, even numbers are stable releases.
Logged

Gianluca

  • Anope User
  • Offline Offline
  • Posts: 27
Re: Which branch do you use?
« Reply #5 on: August 06, 2013, 10:31:44 AM »

why don't fusion the two version? 1.8 version is too simple + 1.9 is the perfect but bug version..1+1= perfect version :)? isn't a good idea?
Logged

katsklaw

  • Supporter
  • Anope User
  • Offline Offline
  • Posts: 537
Re: Which branch do you use?
« Reply #6 on: August 06, 2013, 03:29:32 PM »

why don't fusion the two version? 1.8 version is too simple + 1.9 is the perfect but bug version..1+1= perfect version :)? isn't a good idea?

The 2 are not compatible. 1.8 is the old stable version, 1.9 is the new re-write. 1.9 may seem to do a lot of the same things, but the coding is completely different than 1.8. The "bugs" are because it's still in development, hence the version number is odd (1.9) .. once all the bugs are fixed and 1.9 is declared stable, it will  be renamed 2.0.

Every version of Anope for more than a decade has evolved this way. The last stable version was 1.6 etc.
Logged

Gianluca

  • Anope User
  • Offline Offline
  • Posts: 27
Re: Which branch do you use?
« Reply #7 on: August 07, 2013, 03:38:50 PM »

mmm also the 2.0 is the stable version and the 2.1 devepolment version? :)
Logged

Adam

  • Team
  • *
  • Offline Offline
  • Posts: 461
Re: Which branch do you use?
« Reply #8 on: August 07, 2013, 03:41:35 PM »

why don't fusion the two version? 1.8 version is too simple + 1.9 is the perfect but bug version..1+1= perfect version :)? isn't a good idea?

Do you actually know of any bugs against 1.9? You should report them if so.
The release is pretty solid, there are only a handful of not-too-large problems that I doubt you would encounter.
Logged

Gianluca

  • Anope User
  • Offline Offline
  • Posts: 27
Re: Which branch do you use?
« Reply #9 on: August 08, 2013, 12:34:30 PM »

mmm here some bug or missing....but i don't know if called bug..missing sendpass end getpass command? on services.conf here a defult opzion


defaults = "secure private hideemail kill hideusermask memo_signon memo_receive autoop"

but when nick is registered on /ns info all ...not here a kill protection and not change nick after 60 secondi...

after ( bit i'm OFF TOPIC

This code is with Gogetassj5 (registered) nickname

[13:06:15] Hai impostato i seguente modi:
[13:06:15] +ix
[13:06:15] Nickserv *** This nickname is registered and protected. If it is your
[13:06:15] Nickserv *** nick, type /msg NickServ IDENTIFY password. Otherwise,
[13:06:15] Nickserv *** please choose a different nick.
[13:06:15] Nickserv *** If you do not change within 1 minute, I will change your nick.

[13:06:17] Nickserv *** Password accepted - you are now recognized.
[13:06:17] Operserv*** Changing your usermodes to +S
[13:06:18] Hai impostato i seguente modi:
[13:06:18] +rS

if change nick after logout

[13:21:46] Hai impostato i seguente modi:
[13:21:46] -r
[13:21:48] Il tuo nuovo nick è¨ ora G\
[13:27:07] Il tuo nuovo nick è¨ ora Gogetassj5
[13:27:08] Nickserv *** This nickname is registered and protected. If it is your
[13:27:08] Nickserv *** nick, type /msg NickServ IDENTIFY password. Otherwise,
[13:27:08] Nickserv *** please choose a different nick.  (<- not notified after 60 secs my nick is change )

sorry for my off topic






Logged

katsklaw

  • Supporter
  • Anope User
  • Offline Offline
  • Posts: 537
Re: Which branch do you use?
« Reply #10 on: October 23, 2013, 12:54:41 PM »

1: get pass/send pass doesn't work if you use any encryption other than enc_none.
2: nickserv will not notify or change a persons nick if they connect from a host listed in their /ns access list even if /ns kill is set.
Logged

KnownSyntax

  • Anope User
  • Offline Offline
  • Gender: Male
  • Posts: 9
    • FreshAquaria
Re: Which branch do you use?
« Reply #11 on: November 05, 2013, 07:34:09 PM »

I personally use 1.9 since I love all of the new features that are added in each release. Yes there are bugs in the 1.9 branch, but still it's worth it in my eyes and all of my user's love it.
Logged
FreshAquaria - Freshwater Discussion and Knowledgebase
Pages: [1]   Go Up