Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: Services won't start. [Help needed]  (Read 2392 times)

0 Members and 1 Guest are viewing this topic.

Zerratar

  • Guest
Services won't start. [Help needed]
« on: May 19, 2006, 04:21:14 PM »

Well i posted something similiar a while ago but the result of the response never helped me through. i mean i didnt got it to work. :P Now ive tried again but it still wont work.. Ive set the config files as detailed as possible and what i think ive done nothing wrong.. anyway heres my error report:

Btw. im using Unreal IRCD 3.2

Code: [Select]

[May 19 17:16:58 2006] Loading IRCD Protocol Module: [unreal32]
[May 19 17:16:58 2006] status: [0][Module, Okay - No Error]
[May 19 17:16:58 2006] Launching Anope into the background
[May 19 17:16:58 2006] Anope 1.7.14 (1023) (ircd protocol: UnrealIRCd 3.2+) starting up
[May 19 17:17:01 2006] ms_rsend requested unload...
[May 19 17:17:01 2006] debug: trying to load core module [ms_rsend]
[May 19 17:17:01 2006] debug: status: [6][Module Error, Error during load time or module returned MOD_STOP]
[May 19 17:17:03 2006] Databases loaded
[May 19 17:17:03 2006] Info: Reflecting database records.
[May 19 17:17:03 2006] Connected to Server 1 (127.0.0.1:6667)
[May 19 17:17:03 2006] trying to load [cs_appendtopic]
[May 19 17:17:03 2006] [cs_appendtopic] Loaded succesfully
[May 19 17:17:03 2006] status: [0][Module, Okay - No Error]
[May 19 17:17:03 2006] trying to load [cs_enforce]
[May 19 17:17:03 2006] status: [0][Module, Okay - No Error]
[May 19 17:17:03 2006] trying to load [ns_maxemail]
[May 19 17:17:03 2006] status: [0][Module, Okay - No Error]
[May 19 17:17:03 2006] trying to load [ns_noop]
[May 19 17:17:04 2006] ns_noop: Loading configuration directives
[May 19 17:17:04 2006] ns_noop: NSAutoOPDBName is not defined in Services configuration file, using default autoop.db
[May 19 17:17:04 2006] ns_noop: Directive NSAutoOPDBName loaded (autoop.db)...
[May 19 17:17:04 2006] ns_noop: WARNING: Can not open database file! (it might not exist, this is not fatal)
[May 19 17:17:04 2006] status: [0][Module, Okay - No Error]
[May 19 17:17:04 2006] trying to load [os_info]
[May 19 17:17:04 2006] os_info: Loading configuration directives...
[May 19 17:17:04 2006] os_info: OSInfoDBName is not defined in Services configuration file, using default os_info.db
[May 19 17:17:04 2006] os_info: Directive OSInfoDBName loaded (os_info.db)...
[May 19 17:17:04 2006] os_info: WARNING: can not open the database file! (it might not exist, this is not fatal)
[May 19 17:17:04 2006] status: [0][Module, Okay - No Error]
[May 19 17:17:04 2006] trying to load [hs_request]
[May 19 17:17:04 2006] [hs_request] Unable to open database ('hs_request.db') for reading
[May 19 17:17:04 2006] hs_request loaded
[May 19 17:17:04 2006] status: [0][Module, Okay - No Error]
[May 19 17:17:04 2006] Read error from server: No such file or directory (error num: 2)
[May 19 17:17:04 2006] [cs_appendtopic] Unloaded succefully
[May 19 17:17:04 2006] PANIC! waiting=-4 (Segmentation fault)
[May 19 17:17:04 2006] Backtrace: not available on Windows
[May 19 17:17:04 2006] Running
[May 19 17:17:04 2006] Services terminating on signal 11



Heres my code i use for the listening

Code: [Select]

listen         *:6667
{
options
{
//ssl;
clientsonly;
standard;
};
};

listen         *:8067;
{
options
{
//ssl;
clientsonly;
standard;
};
};

listen         *:6697;
{
options
{
ssl;
clientsonly;
standard;
};
};


Linking....

Code: [Select]

link            code-genius.no-ip.org
{
username *;
hostname code-genius.no-ip.org;
bind-ip 127.0.0.1;
port 6667;
hub             *;
password-connect "LiNkiNg";
password-receive "LiNkiNg";
class           servers;
options {
autoconnect;
zip;
};
};


now for my services.conf:

Code: [Select]

RemoteServer   127.0.0.1 6667 "LiNkiNg"
RemoteServer2  localhost 6667 "LiNkiNg"
RemoteServer3  213.64.139.3 6667 "LiNkiNg"



Any help is appraiciated.

[Edited on 19-5-2006 by Zerratar]
Logged

Dave Robson

  • Team
  • *
  • Offline Offline
  • Posts: 357
(No subject)
« Reply #1 on: May 19, 2006, 04:58:36 PM »

You've told services to link on port 6667, yet port 6667 is setup as "clients only"
Logged
Pages: [1]   Go Up