Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: *** LocOps -- Link denied for services.server.name(unknown@127.0.0.1) (No link  (Read 18552 times)

0 Members and 1 Guest are viewing this topic.

gaatjeniksaan

  • Anope User
  • Offline Offline
  • Posts: 11

I'm running ANOPE on UnrealIRCd 3.2.9 and everything works fine with localhost, but now it gives this error:

 *** LocOps -- Link denied for services.server.name(unknown@127.0.0.1) (No link block named 'services.server.name') [@127.0.0.1.3827]

This probably is that theres no link block named 'services.server.name'. Thats right, there isn't. Its called 'services.127.0.0.1'. BUT I have never configured it to link services.server.name. How do I change this?
Logged

Jobe

  • Contributor
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1023
    • Anope IRC Services

You could try finding "services.server.name" in services.conf and changing it to "services.127.0.0.1", or you could do the oposite in your IRCd config.
Logged
Your IP: ()
My IRC Status:

Come along and visit http://www.anopequotes.org/

gaatjeniksaan

  • Anope User
  • Offline Offline
  • Posts: 11

anope doesnt even start the services now, while I configured it correctly :S
Logged

VisioN

  • Contributor
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 82
    • myIRC Project Hosting IRC Network

apparently its not configured correctly. You need to show us:
- link block from unrealircd.conf
- listen block from unrealircd.conf
- RemoteServer from services.conf
- The services server name.
Logged
______________________________
VisioN
Find me: irc.myirc.net | irc.anope.org
Contact me: vision@myirc.net

gaatjeniksaan

  • Anope User
  • Offline Offline
  • Posts: 11

Listen:
listen 127.0.0.1:7070;

Link:

link services.127.0.0.1
{
      username *;
      hostname 127.0.0.1;
      bind-ip *;
      hub *;
      port 7070;
      password-connect "xxx";
      password-receive "xxx";
      class servers;
};


RemoteServer:

RemoteServer    127.0.0.1 6667 "xxx"


Server name:

ServerName  "services.127.0.0.1"


I really have the feeling I indeed did not configure something correctly. Tell me if any info is missing (you can rely on me the passwords match)
Logged

Jan Milants

  • Team
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1372

I really have the feeling I indeed did not configure something correctly.
i wonder what would give you that feeling..

listen 127.0.0.1:7070;
...
RemoteServer    127.0.0.1 6667 "xxx"

see anything wrong..?

and for the record:
Quote
anope doesnt even start the services now, while I configured it correctly :S
the first i contradicted by the second.. if it s not configured correctly anope will fail to start..
« Last Edit: November 10, 2011, 11:53:28 AM by Jan Milants »
Logged
If you like me donate coins to 1FBmZVT4J8WAUMHKqpWhgNVj3XXnRN1cCk :)

gaatjeniksaan

  • Anope User
  • Offline Offline
  • Posts: 11

OK I changed the server name to ''127.0.0.1'' and it still doesnt start :S What am I doing wrong now?
Logged

VisioN

  • Contributor
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 82
    • myIRC Project Hosting IRC Network

no, you should have changed the port to 7070

Code: [Select]
RemoteServer    127.0.0.1 7070 "xxx"
leave the server name to what it was.
Logged
______________________________
VisioN
Find me: irc.myirc.net | irc.anope.org
Contact me: vision@myirc.net

gaatjeniksaan

  • Anope User
  • Offline Offline
  • Posts: 11

ok now I have


RemoteServer    127.0.0.1 7070 "xxx"

and


listen 127.0.0.1:7070;

and

link services.127.0.0.1
{
      username *;
      hostname 127.0.0.1;
      bind-ip *;
      hub *;
      port 7070;
      password-connect "xxx";
      password-receive "xxx";
      class servers;
};


Please tell me what I need to fix now, I do not have any clue :S
« Last Edit: November 10, 2011, 12:09:53 PM by gaatjeniksaan »
Logged

VisioN

  • Contributor
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 82
    • myIRC Project Hosting IRC Network

what's your services server name ?
Logged
______________________________
VisioN
Find me: irc.myirc.net | irc.anope.org
Contact me: vision@myirc.net

gaatjeniksaan

  • Anope User
  • Offline Offline
  • Posts: 11


ServerName  "services.127.0.0.1"


The RemoteServer part is wrong, I guess.

EDIT: of course it isn't... the listen part is what I mean
Logged

VisioN

  • Contributor
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 82
    • myIRC Project Hosting IRC Network

It seems correct, can you show us some logs from /services/logs ? We need to see the part where anope tries to connect to the ircd. Also, do you get any errors from the ircd when you try to link anope ?
Logged
______________________________
VisioN
Find me: irc.myirc.net | irc.anope.org
Contact me: vision@myirc.net

gaatjeniksaan

  • Anope User
  • Offline Offline
  • Posts: 11

the anope.bat shows nothing, then it shows ''Press any key to continue...''.

Log:

[Nov 10 13:30:29 2011] Every UserKey must be different. It's for YOUR safety! Remember that!
[Nov 10 13:30:29 2011] Loading IRCD Protocol Module: [unreal32]
[Nov 10 13:30:30 2011] status:
  • [Module, Okay - No Error]
[Nov 10 13:30:30 2011] Loading Encryption Module: [enc_md5]
[Nov 10 13:30:30 2011] status:
  • [Module, Okay - No Error]
[Nov 10 13:30:30 2011] Launching Anope into the background
[Nov 10 13:30:30 2011] Anope 1.8.6 (3072) (ircd protocol: UnrealIRCd 3.2+) starting up
[Nov 10 13:30:33 2011] MSMemoReceipt not enabled in services.conf
[Nov 10 13:30:33 2011] ms_rsend requested unload...
[Nov 10 13:30:33 2011] debug: trying to load core module [ms_rsend]
[Nov 10 13:30:33 2011] debug: status: [6][Module Error, Error during load time or module returned MOD_STOP]
[Nov 10 13:30:37 2011] Databases loaded
[Nov 10 13:30:37 2011] Info: Reflecting database records.
[Nov 10 13:30:37 2011] Connected to Server 1 (127.0.0.1:7070)
[Nov 10 13:30:37 2011] trying to load [cs_appendtopic]
[Nov 10 13:30:37 2011] [cs_appendtopic] Loaded successfully
[Nov 10 13:30:37 2011] status:
  • [Module, Okay - No Error]
[Nov 10 13:30:37 2011] trying to load [cs_enforce]
[Nov 10 13:30:38 2011] status:
  • [Module, Okay - No Error]
[Nov 10 13:30:38 2011] trying to load [ns_maxemail]
[Nov 10 13:30:38 2011] status:
  • [Module, Okay - No Error]
[Nov 10 13:30:38 2011] trying to load [os_info]
[Nov 10 13:30:38 2011] os_info: Loading configuration directives...
[Nov 10 13:30:38 2011] os_info: OSInfoDBName is not defined in Services configuration file, using default os_info.db
[Nov 10 13:30:38 2011] os_info: Directive OSInfoDBName loaded (os_info.db)...
[Nov 10 13:30:38 2011] status:
  • [Module, Okay - No Error]
[Nov 10 13:30:38 2011] trying to load [hs_request]
[Nov 10 13:30:38 2011] hs_request loaded
[Nov 10 13:30:38 2011] status:
  • [Module, Okay - No Error]
[Nov 10 13:30:38 2011] Read error from server: No such file or directory (error num: 2)
[Nov 10 13:30:38 2011] [cs_appendtopic] Unloaded successfully
[Nov 10 13:30:38 2011] hs_request un-loaded


edit: more up to date version
« Last Edit: November 10, 2011, 12:32:00 PM by gaatjeniksaan »
Logged

VisioN

  • Contributor
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 82
    • myIRC Project Hosting IRC Network

there is not much useful information in there.. try to run anope on debug so we see a little more info.
If you're a windows user run   anope.exe -support
If you're a *nix user run  ./services -support

paste the output.
Logged
______________________________
VisioN
Find me: irc.myirc.net | irc.anope.org
Contact me: vision@myirc.net

gaatjeniksaan

  • Anope User
  • Offline Offline
  • Posts: 11

As I thought, it starts doing this:


[Nov 10 14:03:20 2011] debug: Emitting event "delcommand" (2 args)
[Nov 10 14:03:20 2011] debug: Emitting event "delcommand" (2 args)
[Nov 10 14:03:20 2011] debug: Emitting event "delcommand" (2 args)

as a result of:

[Nov 10 14:03:20 2011] Read error from server: No such file or directory (error num: 2)
[Nov 10 14:03:20 2011] debug: Sent: SQUIT services.127.0.0.1 :Read error from server: No such file or directory (error num: 2)


The delcommand part is really long, and is followed by:

[Nov 10 14:03:20 2011] debug: Cleaning out Module run time directory (\modules/runtime) - this may take a moment please wait
[Nov 10 14:03:20 2011] debug: Module run time directory has been cleaned out
Press any key to continue . . .
Logged

Jobe

  • Contributor
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1023
    • Anope IRC Services

Perhaps now you can provide us with the full log so we can work out what is wrong rather then you assuming you know what to look for and failing to provide us with the lines we need.
Logged
Your IP: ()
My IRC Status:

Come along and visit http://www.anopequotes.org/

gaatjeniksaan

  • Anope User
  • Offline Offline
  • Posts: 11
Logged

Jobe

  • Contributor
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1023
    • Anope IRC Services

Can you show us /stats P from your IRCd please?
Logged
Your IP: ()
My IRC Status:

Come along and visit http://www.anopequotes.org/

gaatjeniksaan

  • Anope User
  • Offline Offline
  • Posts: 11

Of course I can:

* *** Listener on 127.0.0.1:7070, clients 1. is PERM
* *** Listener on *:6667, clients 1. is PERM
* *** Listener on *:8067, clients 0. is PERM
* *** Listener on *:6697, clients 0. is PERM clientsonly
* P :End of /STATS report
Logged

Jobe

  • Contributor
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1023
    • Anope IRC Services

Can you show us /stats G and /stats K please?

Also can you show us your whole unrealircd.conf please?
Logged
Your IP: ()
My IRC Status:

Come along and visit http://www.anopequotes.org/

gaatjeniksaan

  • Anope User
  • Offline Offline
  • Posts: 11


* K *tirc@*.saturn.bbn.com Idiot
* Z 195.86.232.81 Delinked server
* E *stskeeps@212.*
* K :End of /STATS report


/stats G gave no results.

http://pastebin.com/00bmy7ZR is my unrealircd.conf
Logged
Pages: [1]   Go Up