Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: FATAL: Can't connect to server: Connection refused  (Read 8881 times)

0 Members and 1 Guest are viewing this topic.

Nemesis Forever

  • Anope User
  • Offline Offline
  • Posts: 8
FATAL: Can't connect to server: Connection refused
« on: April 14, 2011, 01:32:51 PM »

I am using Unrealircd 3.2 and Anope 1.8.5. I installed it today on a webhost which doesn't provide static ip to point to my website.

The same IP is being used to host lots of websites.

I have configured the as per this topic.

What changes needs to be done?

I'm getting the error " FATAL: Can't connect to server: Connection refused" when trying to start Anope with ./services -debug -nofork

Please help.
Logged

Jobe

  • Contributor
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1023
    • Anope IRC Services
Re: FATAL: Can't connect to server: Connection refused
« Reply #1 on: April 14, 2011, 01:35:13 PM »

Connection refused means your IRCd is NOT listeneing on the IP and port RemoteServer in services.conf tells Anope to connect to.

Note the port param of a link block will NOT make UnrealIRCd listen on that port. You will still NEED to add a listen block for the port (and IP if not *).
Logged
Your IP: ()
My IRC Status:

Come along and visit http://www.anopequotes.org/

Nemesis Forever

  • Anope User
  • Offline Offline
  • Posts: 8
Re: FATAL: Can't connect to server: Connection refused
« Reply #2 on: April 14, 2011, 01:50:56 PM »

Connection refused means your IRCd is NOT listeneing on the IP and port RemoteServer in services.conf tells Anope to connect to.

Note the port param of a link block will NOT make UnrealIRCd listen on that port. You will still NEED to add a listen block for the port (and IP if not *).

How do I add a listen block for the port?

This is how I have configured services.conf till now:
Code: [Select]
RemoteServer 127.0.0.1 7070 "password"
This is how I have configured unrealircd.conf till now:

Code: [Select]
listen 127.0.0.1:7070
{
options
{
serversonly;
};
};

Code: [Select]
link services.mysite.com
{
username *;
hostname 127.0.0.1;
bind-ip *;
port 7070;
hub *;
password-connect "password";
password-receive "password";
class servers;
options {
};
};

Code: [Select]

ulines {
services.mysite.com;
stats.mysite.com;
};

Code: [Select]
set {
network-name "Mysite";
default-server "irc.mysite.com";
services-server "services.mysite.com";
stats-server "stats.mysite.com";
help-channel "#Mysite-Help";
hiddenhost-prefix "Mysite";
}
Logged

Jobe

  • Contributor
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1023
    • Anope IRC Services
Re: FATAL: Can't connect to server: Connection refused
« Reply #3 on: April 15, 2011, 11:34:24 AM »

With that listen block it should work.

Did you add that listen block before or after starting Unreal? If after, did you remember to /rehash?
Logged
Your IP: ()
My IRC Status:

Come along and visit http://www.anopequotes.org/

Nemesis Forever

  • Anope User
  • Offline Offline
  • Posts: 8
Re: FATAL: Can't connect to server: Connection refused
« Reply #4 on: April 15, 2011, 11:45:18 AM »

It's working now.... Thanks....
Logged
Pages: [1]   Go Up