Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: FATAL: Can't connect to server: No such file or directory  (Read 9615 times)

0 Members and 1 Guest are viewing this topic.

Zerratar

  • Guest
FATAL: Can't connect to server: No such file or directory
« on: April 03, 2006, 11:33:03 AM »

Hi, when i checked around on the forums i found another post about this but the owner seems to fixed his problem but the sulotion wasnt posted, and since i have the problem myself i really REALLY!! Wan't to know how to fix it :(

Ive tried the most things

This is in my services.conf
Code: [Select]

RemoteServer    213.64.139.3 6667 "<this is secret plz>"

LocalAddress   127.0.0.1 6667

ServerName  "code-genius.no-ip.org"


and my linking in my unrealircd.conf

Code: [Select]

link            code-genius.no-ip.org
{
username *;
hostname 213.64.139.3;
bind-ip *;
port 6667;
hub             *;
password-connect "<this is secret plz>"";
password-receive "<this is secret plz>"";
class           servers;
options {
autoconnect;
zip;
};
};


ulines {
code-genius.no-ip.org;
};


And my full log.

Code: [Select]

[Apr 03 12:27:54 2006] Loading IRCD Protocol Module: [unreal32]
[Apr 03 12:27:54 2006] status: [0][Module, Okay - No Error]
[Apr 03 12:27:54 2006] Launching Anope into the background
[Apr 03 12:27:54 2006] Anope 1.7.14 (1023) (ircd protocol: UnrealIRCd 3.2+) starting up
[Apr 03 12:27:55 2006] ms_rsend requested unload...
[Apr 03 12:27:55 2006] debug: trying to load core module [ms_rsend]
[Apr 03 12:27:55 2006] debug: status: [6][Module Error, Error during load time or module returned MOD_STOP]
[Apr 03 12:27:56 2006] Databases loaded
[Apr 03 12:27:56 2006] Info: Reflecting database records.
[Apr 03 12:27:56 2006] FATAL: Can't connect to server: No such file or directory



Does anyone have any ideas what could cause this to NOT be working? I really want to have this fixed :( :)
Logged

Dave Robson

  • Team
  • *
  • Offline Offline
  • Posts: 357
(No subject)
« Reply #1 on: April 03, 2006, 01:10:00 PM »

Dont specify a local address.
Logged

Zerratar

  • Guest
(No subject)
« Reply #2 on: April 03, 2006, 01:35:30 PM »

Cheers!... Almost.. It still wont start, this is what i get now :(

Code: [Select]

[Apr 03 14:33:45 2006] Loading IRCD Protocol Module: [unreal32]
[Apr 03 14:33:45 2006] status: [0][Module, Okay - No Error]
[Apr 03 14:33:45 2006] Launching Anope into the background
[Apr 03 14:33:45 2006] Anope 1.7.14 (1023) (ircd protocol: UnrealIRCd 3.2+) starting up
[Apr 03 14:33:47 2006] ms_rsend requested unload...
[Apr 03 14:33:47 2006] debug: trying to load core module [ms_rsend]
[Apr 03 14:33:47 2006] debug: status: [6][Module Error, Error during load time or module returned MOD_STOP]
[Apr 03 14:33:49 2006] Databases loaded
[Apr 03 14:33:49 2006] Info: Reflecting database records.
[Apr 03 14:33:49 2006] Connected to Server 1 (213.64.139.3:6667)
[Apr 03 14:33:49 2006] trying to load [cs_appendtopic]
[Apr 03 14:33:49 2006] [cs_appendtopic] Loaded succesfully
[Apr 03 14:33:49 2006] status: [0][Module, Okay - No Error]
[Apr 03 14:33:49 2006] trying to load [cs_enforce]
[Apr 03 14:33:49 2006] status: [0][Module, Okay - No Error]
[Apr 03 14:33:49 2006] trying to load [ns_maxemail]
[Apr 03 14:33:49 2006] status: [0][Module, Okay - No Error]
[Apr 03 14:33:49 2006] trying to load [ns_noop]
[Apr 03 14:33:49 2006] ns_noop: Loading configuration directives
[Apr 03 14:33:49 2006] ns_noop: NSAutoOPDBName is not defined in Services configuration file, using default autoop.db
[Apr 03 14:33:49 2006] ns_noop: Directive NSAutoOPDBName loaded (autoop.db)...
[Apr 03 14:33:49 2006] ns_noop: WARNING: Can not open database file! (it might not exist, this is not fatal)
[Apr 03 14:33:49 2006] status: [0][Module, Okay - No Error]
[Apr 03 14:33:49 2006] trying to load [os_info]
[Apr 03 14:33:49 2006] os_info: Loading configuration directives...
[Apr 03 14:33:49 2006] os_info: OSInfoDBName is not defined in Services configuration file, using default os_info.db
[Apr 03 14:33:49 2006] os_info: Directive OSInfoDBName loaded (os_info.db)...
[Apr 03 14:33:49 2006] os_info: WARNING: can not open the database file! (it might not exist, this is not fatal)
[Apr 03 14:33:49 2006] status: [0][Module, Okay - No Error]
[Apr 03 14:33:49 2006] trying to load [hs_request]
[Apr 03 14:33:49 2006] [hs_request] Unable to open database ('hs_request.db') for reading
[Apr 03 14:33:49 2006] hs_request loaded
[Apr 03 14:33:49 2006] status: [0][Module, Okay - No Error]
[Apr 03 14:33:49 2006] Read error from server: No such file or directory (error num: 2)
[Apr 03 14:33:49 2006] [cs_appendtopic] Unloaded succefully
[Apr 03 14:33:49 2006] PANIC! waiting=-4 (Segmentation fault)
[Apr 03 14:33:49 2006] Backtrace: not available on Windows
[Apr 03 14:33:49 2006] Running
[Apr 03 14:33:49 2006] Services terminating on signal 11

[Edited on 3-4-2006 by Zerratar]
Logged

Dave Robson

  • Team
  • *
  • Offline Offline
  • Posts: 357
(No subject)
« Reply #3 on: April 03, 2006, 03:14:19 PM »

Im guessing that it cant connec to 213.64.139.3:6667 - if this is your home windows pc, sitting behind a router, it wont be able to connect to its external interface...
Logged

Zerratar

  • Guest
(No subject)
« Reply #4 on: April 03, 2006, 03:26:03 PM »

Quote
Originally posted by Rob
Im guessing that it cant connec to 213.64.139.3:6667 - if this is your home windows pc, sitting behind a router, it wont be able to connect to its external interface...


I have opened the port 6667 on my router, i can have people connect to my server. but this is my only problem i cant get services to work. And well that was the log i got.. sry if you find this post confusing.
Logged

Dave Robson

  • Team
  • *
  • Offline Offline
  • Posts: 357
(No subject)
« Reply #5 on: April 03, 2006, 04:32:06 PM »

Yes, you've opened the port on your router, so people external can connect, however, your _internal_ computer can not connect to port 6667 of the external ip.
Logged

Zerratar

  • Guest
(No subject)
« Reply #6 on: April 09, 2006, 09:51:44 PM »

i see, so theres no way i can fix it?
Logged

Dave Robson

  • Team
  • *
  • Offline Offline
  • Posts: 357
(No subject)
« Reply #7 on: April 10, 2006, 07:31:55 AM »

yes, you can link using the local address, or the loopback address.
Logged

BigBen

  • Anope User
  • Offline Offline
  • Posts: 79
(No subject)
« Reply #8 on: January 06, 2007, 11:38:27 PM »

i have something like this to, i have everything right, but i still get:

FATAL: Can't connect to server: No such file or directory

here's what's in it:

link            Services.BigTiger.net
{
   username   *;
   hostname    localhost;
   bind-ip    *localhost;
   port       7029;
   hub             *hub.BigTiger.net;
   password-connect "----";
   password-receive "----";
   class           servers;
      options {
         /* Note: You should not use autoconnect when linking services */

};
};

Services:

RemoteServer    localhost 7029 "----"


and still get the same message.
Logged

katsklaw

  • Guest
(No subject)
« Reply #9 on: January 07, 2007, 03:25:50 AM »

use the IP and not the host name. localhost doesn't always resolve properly.

Try this:

RemoteServer 127.0.0.1 6667 "<this is secret plz>"

ServerName "code-genius.no-ip.org"
 


unrealircd.conf

listen 127.0.0.1:6667;

link code-genius.no-ip.org
{
      username *;
      hostname 127.0.0.1;
      bind-ip *;
      port 6667;
      hub *;
      password-connect "<this is secret plz>"";
      password-receive "<this is secret plz>"";
     class servers;
};


ulines {
     code-genius.no-ip.org;
};
Logged

antoniocr

  • Guest
(No subject)
« Reply #10 on: November 10, 2007, 08:46:50 AM »

:( No se cual es el problema
help

[Nov 10 09:44:46 2007] Every UserKey must be different. It's for YOUR safety! Remember that!
[Nov 10 09:44:46 2007] Loading IRCD Protocol Module: [unreal32]
[Nov 10 09:44:46 2007] status:
  • [Module, Okay - No Error]
[Nov 10 09:44:46 2007] Loading Encryption Module: [enc_none]
[Nov 10 09:44:46 2007] status:
  • [Module, Okay - No Error]
[Nov 10 09:44:46 2007] Launching Anope into the background
[Nov 10 09:44:46 2007] Anope 1.7.19 (1247) (ircd protocol: UnrealIRCd 3.2+) starting up
[Nov 10 09:44:49 2007] ms_rsend requested unload...
[Nov 10 09:44:49 2007] debug: trying to load core module [ms_rsend]
[Nov 10 09:44:49 2007] debug: status: [6][Module Error, Error during load time or module returned MOD_STOP]
[Nov 10 09:44:51 2007] Databases loaded
[Nov 10 09:44:51 2007] Info: Reflecting database records.
[Nov 10 09:44:52 2007] FATAL: Can't connect to server: No such file or directory
Logged

Jobe

  • Contributor
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1023
    • Anope IRC Services
(No subject)
« Reply #11 on: November 10, 2007, 12:07:33 PM »

Can you show us your listen blocks too please?
Logged
Your IP: ()
My IRC Status:

Come along and visit http://www.anopequotes.org/
Pages: [1]   Go Up