Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: Problem with DefcCon's chan mode  (Read 3628 times)

0 Members and 1 Guest are viewing this topic.

Adonis

  • Anope User
  • Offline Offline
  • Posts: 11
Problem with DefcCon's chan mode
« on: October 05, 2007, 02:58:59 PM »

Since a few weeks we have upgraded from an older Anope to 1.7.19 and for the first time since we upgraded, we had use Defcon. All wehnt well, Defcon set the chanmodes to +R, and when the defcon was set back to 5, it set the +R back to -R. However, as soon as Operserv set it back to -R, Chanserv challenged that and set it back to +R for ALL channels.

We have tried everything.. even temporarily changing the config to -R and setting Defcon again. Somehow Chanserv happily lets OS set the +R but challenges it when it tries to set it back to -R. In the end we had to restart the server to fix this.

Any idea why this is? And how to get around that? Because we can't restart the whole server every time a defcon happened.
Logged

Jobe

  • Contributor
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1023
    • Anope IRC Services
(No subject)
« Reply #1 on: October 05, 2007, 03:15:14 PM »

It's a known bug.
Logged
Your IP: ()
My IRC Status:

Come along and visit http://www.anopequotes.org/

SNU

  • Anope User
  • Offline Offline
  • Posts: 158
    • http://www.firstclassirc.com
(No subject)
« Reply #2 on: October 05, 2007, 03:18:49 PM »

will it be fixed in .20 or 1.8 final? or is it much harder to fix?
Logged

katsklaw

  • Guest
(No subject)
« Reply #3 on: October 06, 2007, 02:58:39 AM »

I split the topic. Please see: http://forum.anope.org/viewthread.php?tid=1800
Logged

katsklaw

  • Guest
(No subject)
« Reply #4 on: October 06, 2007, 02:59:01 AM »

SNU, 1.7.20.
Logged
Pages: [1]   Go Up