Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: /services/src folder does not exist  (Read 4882 times)

0 Members and 1 Guest are viewing this topic.

Nofilicity

  • Guest
/services/src folder does not exist
« on: July 06, 2007, 05:15:41 PM »

I'm trying to compile a module, when I realized...my /src folder does not exist. What should I do, and where do I put the unreal_addon.c file then?
Logged

n00bie

  • Anope User
  • Offline Offline
  • Gender: Male
  • Posts: 411
(No subject)
« Reply #1 on: July 06, 2007, 05:22:21 PM »

You need to put your modules inside Anope-1.7.x/src/modules folder.
read this link: http://anope.info/index.php/Modules:Usage:Compiling

[Edited on 6-7-2007 by n00bie]
Logged
I am always doing things that which I cannot do, in order that I may learn how to do it.

Nofilicity

  • Guest
(No subject)
« Reply #2 on: July 06, 2007, 05:45:22 PM »

Ah, thanks. I compile the module, unreal_addon.so now, and moved it to my services/modules folder. However, when I type /os modload unreal_addon , it doesn't work. Any ideas?
Logged

n00bie

  • Anope User
  • Offline Offline
  • Gender: Male
  • Posts: 411
(No subject)
« Reply #3 on: July 06, 2007, 05:54:03 PM »

when you compiled the module and do 'make install' the compiled modules automatically goes to the services folder, so doing /os modload modulename will give no problem unless there is a problem with the module itself. Check your services logs folder for errors on why you can't load the modules
Logged
I am always doing things that which I cannot do, in order that I may learn how to do it.

Nofilicity

  • Guest
(No subject)
« Reply #4 on: July 06, 2007, 06:30:05 PM »

Quote

[Jul 06 17:27:08 2007] Trying to load module [unreal_addon]
[Jul 06 17:27:08 2007] Trying to load module [unreal_addon]
[Jul 06 17:27:08 2007] [unreal_addon] MYSQL is not configured. Please edit your services.conf .
[Jul 06 17:27:08 2007] [unreal_addon] Module not loaded.
[Jul 06 17:27:08 2007] unreal_addon requested unload...
[Jul 06 17:27:08 2007] Module loading status: 6 (Module Error, Error during load time or module returned MOD_STOP)
Logged

n00bie

  • Anope User
  • Offline Offline
  • Gender: Male
  • Posts: 411
(No subject)
« Reply #5 on: July 06, 2007, 06:47:14 PM »

I'm guessing you don't have MYSQL enabled during configuration on your services.
Logged
I am always doing things that which I cannot do, in order that I may learn how to do it.

Nofilicity

  • Guest
(No subject)
« Reply #6 on: July 06, 2007, 07:00:13 PM »

Is there anyway to enable it without having to reset my NickServ and Channel Registrations and such?
Logged

n00bie

  • Anope User
  • Offline Offline
  • Gender: Male
  • Posts: 411
(No subject)
« Reply #7 on: July 07, 2007, 08:33:43 AM »

just to make sure, do ./Config again and see that checking of MySQL libs is enabled (tho its default). Next open up your services.conf and check whether if you have encryption enabled or not (depending on your databases). go down and configure the mysql configuration. Lastly, make sure that you have all your *.db's backup before you make any changes... *just in case*
Logged
I am always doing things that which I cannot do, in order that I may learn how to do it.
Pages: [1]   Go Up