Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: -.- Unreal32 & Anope problems.  (Read 1961 times)

0 Members and 2 Guests are viewing this topic.

annihilation

  • Guest
-.- Unreal32 & Anope problems.
« on: March 29, 2007, 05:45:26 AM »

[Mar 29 00:41:06 2007] Loading IRCD Protocol Module: [unreal32]
[Mar 29 00:41:07 2007] status:
  • [Module, Okay - No Error]
[Mar 29 00:41:07 2007] Loading Encryption Module: [enc_none]
[Mar 29 00:41:07 2007] status:
  • [Module, Okay - No Error]
[Mar 29 00:41:07 2007] Launching Anope into the background
[Mar 29 00:41:07 2007] Anope 1.7.18 (1214) (ircd protocol: UnrealIRCd 3.2+) starting up
[Mar 29 00:41:08 2007] ms_rsend requested unload...
[Mar 29 00:41:08 2007] debug: trying to load core module [ms_rsend]
[Mar 29 00:41:08 2007] debug: status: [6][Module Error, Error during load time or module returned MOD_STOP]
[Mar 29 00:41:09 2007] Databases loaded
[Mar 29 00:41:09 2007] Info: Reflecting database records.
[Mar 29 00:41:10 2007] FATAL: Can't connect to server: No such file or directory


Code: [Select]
UnReal ircd -
link            ircv2.game-server.cc
{
username *;
hostname 75.88.165.22;
bind-ip *;
port 7000;
hub             *;
password-connect "password";
password-receive "password";
class           servers;
options {
/* Note: You should not use autoconnect when linking services */
};

Code: [Select]
listen         *:7000
{
options
{
ssl;
clientsonly;
};
};

listen        *:8067;
listen         *:6667;

Code: [Select]
ulines {
ircv2.game-server.cc;


Services (Anope)
Code: [Select]
RemoteServer    75.88.165.22 7000 "password"
Code: [Select]
ServerName  "ircv2.game-server.cc"
Logged

katsklaw

  • Guest
(No subject)
« Reply #1 on: March 29, 2007, 07:06:42 AM »

Your problem is you are trying to connect Services to an ssl and clients only port, Services can not use ssl nor connect to a clients only port.

You should also use IPs in your listen blocks:

listen 75.88.165.22:8067;

not

listen *:8067;

Also you should have searched the forum before making a new thread, this question has been answered 50 billion times already. Please insure you do so next time. :)
Logged
Pages: [1]   Go Up