Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: -NickServ- unnkown command help  (Read 5160 times)

0 Members and 1 Guest are viewing this topic.

Vunderik

  • Guest
-NickServ- unnkown command help
« on: January 13, 2007, 06:01:17 AM »

I see services connected to my UnrealIRCD in status, but all my attemps to send them any command fail with such error. I don't know what to do. The same problems with register and identify commands and with all services.
WinXP, anope-1.7.9, Unreald 3.2.6
Logged

n00bie

  • Anope User
  • Offline Offline
  • Gender: Male
  • Posts: 411
(No subject)
« Reply #1 on: January 13, 2007, 06:10:00 AM »

Firstly, services didn't need the autoconnect options on your services link block. And by looking at your config, i don't see anything wrong with it, except that on line no.1 on your unrealircd.conf you have

Fixedsys;Arial;Fixedsys;Arial;Fixedsys;Fixedsys;Arial;Fixedsys;Arial;Fixedsys;Arial;include "help.conf";
which can happen because of an improper editor or edit. that will give you an error on your unrealircd.cong when you do /rehash

line no. 4
include "aliases\anope.conf"

you have a missing semicolon at the end.


[Edited on 13-1-2007 by n00bie]
Logged
I am always doing things that which I cannot do, in order that I may learn how to do it.

Jan Milants

  • Team
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1372
(No subject)
« Reply #2 on: January 13, 2007, 12:14:21 PM »

Quote
Originally posted by Vunderik
anope-1.7.9

you should really consider upgrading...
Logged
If you like me donate coins to 1FBmZVT4J8WAUMHKqpWhgNVj3XXnRN1cCk :)

Jobe

  • Contributor
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1023
    • Anope IRC Services
(No subject)
« Reply #3 on: January 13, 2007, 12:23:33 PM »

Quote
Originally posted by Viper
you should really consider upgrading...


Id personally say "consider" is an understatement and that "should" should have been emphasized. :P
Logged
Your IP: ()
My IRC Status:

Come along and visit http://www.anopequotes.org/

Hassankhalid

  • Guest
(No subject)
« Reply #4 on: January 13, 2007, 02:02:04 PM »

well  anope link block in conf dont need  autoconnect 2nd you should  update anope version in unreal config check this part below

include "aliases/anope.conf";<<<<<<  that one hope your problem fix u need add this line in config.
Logged

heinz

  • Guest
(No subject)
« Reply #5 on: January 13, 2007, 04:43:00 PM »

Hassankhalid, you've just repeated whats been said already. Please check to make sure you're adding something useful to the topic, otherwise some may see it as spam or post-count-inflating.
Logged

katsklaw

  • Guest
(No subject)
« Reply #6 on: January 13, 2007, 05:13:40 PM »

Guys, If services is returning "-NickServ- unnkown command help" ,then services is already successfully connected so it's not a link issue.

Vunderik, upgrade to 1.7.18 and see if that fixes your problem.
Logged

Vunderik

  • Guest
(No subject)
« Reply #7 on: January 14, 2007, 09:14:29 AM »

I've updated and corrected mistake with semicolon, but Nickserv returns exactly the same mistake. Maybe something is wrong with services.conf? But when i start them they return no mistakes.
Logged

n00bie

  • Anope User
  • Offline Offline
  • Gender: Male
  • Posts: 411
(No subject)
« Reply #8 on: January 14, 2007, 10:35:46 AM »

i suggest you do a backup of your databases and upgrade your services to 1.7.18
Logged
I am always doing things that which I cannot do, in order that I may learn how to do it.

Vunderik

  • Guest
(No subject)
« Reply #9 on: January 14, 2007, 11:25:39 AM »

;( the same problem with 1.7.18... I have no idea why
Logged

n00bie

  • Anope User
  • Offline Offline
  • Gender: Male
  • Posts: 411
(No subject)
« Reply #10 on: January 14, 2007, 11:41:16 AM »

do you have 'UseStrictPrivMsg' enabled on your services.conf
Logged
I am always doing things that which I cannot do, in order that I may learn how to do it.
Pages: [1]   Go Up