Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: (Under VMware 1.0.1 for Windows): Anope 1.7.17 + MySQL problem connection  (Read 2076 times)

0 Members and 1 Guest are viewing this topic.

MOLI

  • Guest

Hi everybody!

I explain my case shortly. I own two Windows 2003 servers running VMware 1.0.1 for Windows.

I have the same virtual machine which has FreeBSD 6.1 with Unreal 3.2 and Anope 1.7.17 services running.

Ok, when I start the same virtual machine (copying previously the physical files on the drive) and I boot it, everything goes OK. This means that the FreeBSD virtual box boots with no errors, as like as the Unrealircd, the Anope services and the MySQL engine too.

The problem becomes when I copy the same physical files corresponding to the virtual machine on another Windows 2003 server and I boot it: Everything goes aparently fine. FreeBSD 6.1 boots, Unreal boots with NO ERROR, MySQL engine too, but Anope does not!!!

So, I've revised my config file and without touching it in a VMware server works and on another it doesn't (and the files are in each case the same, because I move them from one Windows server into another, so the corruption hypothesis is discarded).

I have downloaded several times the original tarball and compiled it separately in each VMware server and in one of the servers works and on the another it doesn't (even if the compilation of Anope on this another server was successful). So, you halt the virtual machine and you copy into the another VMware host and Anope works perfectly without having to make any modification into the FreeBSD operating system, or Unreal and Anope configuration files.

It is unbelievable, I know. For that reason, I attach you my "-debug -nofork" output log (This Anope installation has been performed 60 mins ago before writing this post, and it doesn't works even if the SQL structure is properly created at the MySQL database). I can assure you that if I stop this virtual machine and I boot it from another Windows server with WMware for Windows installed, it will probably boot the Anope IRC Services without having to modify any .conf file... :(

For concluding, I have converted the Virtual Machine into a physical machine (this means that all is at this moment running into a free, physical and standalone FreeBSD server) and the result is the same: Anope services only runs in one VMware host. In despite of, all other daemons and FreeBSD services run perfectly, except Anope.

Can anyone help me?

Thank you so much in advance.

Best regards and Merry Christmas!!

MOLI

[Edited on 26/12/2006 by MOLI]
Logged

Jan Milants

  • Team
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1372
(No subject)
« Reply #1 on: December 26, 2006, 11:31:47 AM »

i think this should say enough heh...

Code: [Select]
FATAL: Can't connect to server: Unknown error: 0

it starts up fine, but fails to connect to unrealircd..

you say you copy the VM to another server and tried running it standalone... usually that means that it will get another IP... so, did you change the RemoteServer in services.conf to match the new IP of your IRCd?
Logged
If you like me donate coins to 1FBmZVT4J8WAUMHKqpWhgNVj3XXnRN1cCk :)

MOLI

  • Guest
(No subject)
« Reply #2 on: December 26, 2006, 11:39:13 AM »

Hi Viper,

Thanks for your quicker answer! :)

I've modified my post in order it could be more legible and everybody can read the 100% of my case.

Your're right. The two VMware servers have differents IP address. One is on 213.x.x.x network (public network) and another is on 10.x.x.x (private network).

But, the link block in Unreal configuration file and the link line in services.conf, are both pointing to the localhost server. Look:

For unrealircd.conf:

 link            services.irc.ircplanet.com
{
        username         *;
        hostname         127.0.0.1;
        bind-ip          *;
        port             7001;
        hub              *;
        password-connect "mypass";
        password-receive "mypass";
        class            servers;
                 options {
                         /* Note: You should not use autoconnect when linking services */
//                         autoconnect;
//                         ssl;
//                         zip;
                 };
};


and ...


root@devel:/usr/local/etc/Unreal/anope# cat services.conf | grep 7001
RemoteServer    localhost 7001 "mypass"
root@devel:/usr/local/etc/Unreal/anope#

There is something wrong?

Thank you so much again. :)
Logged

Jan Milants

  • Team
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1372
(No subject)
« Reply #3 on: December 26, 2006, 03:29:00 PM »

try using 127.0.0.1 instead of localhost, also check whether unrealircd actually sees the connection attempt, if not then either the ircd s not listening on it or something s blocking it or so...
try /stats P to make sure the ircd was able to start listening on the port..
Logged
If you like me donate coins to 1FBmZVT4J8WAUMHKqpWhgNVj3XXnRN1cCk :)

MOLI

  • Guest
(No subject)
« Reply #4 on: December 26, 2006, 04:27:35 PM »

Viper,

IT WORKED!! ;-) The problem was on the connection line at services.conf . It seems it doesn't like "localhost" but "127.0.0.1" ;)

Thank you so much again and Merry Christmas from Madrid!

MOLI
Logged
Pages: [1]   Go Up