Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  


Pages: 1 2 [3] 4 5 ... 10
 on: March 23, 2019, 01:07:24 PM 
Started by Craig Fairhurst - Last post by Craig Fairhurst
It would appear I had not gone about installing the SSL library. A complete start-from-scratch approach helped a lot here.

Thanks all.

 on: March 22, 2019, 07:40:27 AM 
Started by Kenneth Clement - Last post by CrazyCat
Did you enable them with the ./extras command before compiling anope ?

 on: March 22, 2019, 07:37:25 AM 
Started by Craig Fairhurst - Last post by CrazyCat
First: re-comment the server config example (lines 131 to 138 of your config file), it's an example for your ircd, not a configuration part of anope.

If it doesn't work after that, run it with the --debug parameter (cf

 on: March 21, 2019, 07:53:18 PM 
Started by Craig Fairhurst - Last post by Craig Fairhurst

I've not had any further luck with this; could it be an openssl issue? Not sure, going to try on a different server now.

Kind regards

 on: March 21, 2019, 12:07:29 AM 
Started by Kenneth Clement - Last post by Kenneth Clement
Can't load installed modules: webcpanel, db_sql_live, m_xmlrpc_main, ...

[00:24] -> *OperServ* modload db_sql_live
[00:24] -OperServ- Unable to load module db_sql_live.

[00:24] -> *OperServ* modload webcpanel
[00:24] -OperServ- Unable to load module webcpanel.

[00:26] -> *OperServ* modload m_xmlrpc_main
[00:26] -OperServ- Unable to load module m_xmlrpc_main.

These modules are in my /lib/modules/ ( as example) and in my config file. Tried to load the modules in services.conf and also with the modules.conf file.

Does sombody has an idea what could be the problem? Already tried ./Config - make - make install again... the modules did install fine.

 on: March 17, 2019, 10:48:49 PM 
Started by Craig Fairhurst - Last post by Craig Fairhurst

This is my services.conf

And here is my links.conf:
Code: [Select]
<link name=""

<uline server="" silent="yes">

If somebody could point out where I am going wrong that would be great.

Many thanks

 on: March 09, 2019, 01:17:21 PM 
Started by gerry - Last post by gerry
I'd be very interested to see a "ProfileServ" module for the new Anope series.

Features would be allowing a "registered nick with Nickserv" to set up a profile on the "ProfileServ" .. Nick (already set with nickserv), age (settable), location (settable) and a brief user description (settable)

with a command based interface for users to be able to edit their profile or for other users to say... "!view <username>" and "ProfileServ" pm's the user in question the info.

We sorta had a crude version running but the guy that was coding it went awol and we dont have the code anymore for it.

There is a module on NeoStats (defunct i know...) but it maybe could be modded ?

 on: February 26, 2019, 09:46:29 PM 
Started by Rene - Last post by Rene
Please HELP

 on: February 24, 2019, 09:06:28 PM 
Started by Kathir - Last post by Kathir
I wanted to say like atheme service have a module for fflags system, Ircop can add anyone in any flag by using !fflags command in any channel, how could we make possible in anope?

 on: February 23, 2019, 12:24:16 PM 
Started by Rene - Last post by Rene
hello anybody :) i have setup anope 2.0.6 and activate the webcpanel for it. now my problem is the connection from the url for default is http://url:8080 but i will connect with https://url:8080 i activate the m_ssl_openssl module in the modules.example.conf .. whats wrong?

how can i connect via https://url:8080 to the webcpanel ?
For a better understanding ...
I installed Plesk on my server and encrypted my domain using SSL Encrypt for SSL / TSL. Now I would like the data entered in the webcpanel are also encrypted this happens so if you use HTTPS ..
I hope you understand me I'm from Germany
I have encrypted the domain with Lets Encrypt so that all data entered in forms are encrypted.
But if I call  [HTTPS://domain:8080] an error comes
When I call the panel via HTTP it works but the data is not encrypted. if I go with firefox in the formularfeld he warns me that the connection is not encrypted entered data can get into wrong hands. I thought if I activate the SSL module in the modules.example.conf that I can then connect via HTTPS this is unfortunately not the case.

Please Help!
Here are 2 Pictures sorry i'm from germany

Pages: 1 2 [3] 4 5 ... 10