Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: 1 ... 8 9 [10]
 91 
 on: April 12, 2020, 02:43:55 PM 
Started by Nanar - Last post by Joel
Hello,
On my server the language is Portuguese as I show below.

rede-irc@mail:~$ env | grep LANG
LANG=pt_PT.UTF-8
rede-irc@mail:~$

and the language is always in English, I don't understand why

 92 
 on: April 09, 2020, 01:48:29 PM 
Started by Nanar - Last post by CrazyCat
If using debian (or ubuntu or any debian-based OS): dpkg-reconfigure locales

 93 
 on: April 09, 2020, 01:29:23 PM 
Started by Nanar - Last post by Nanar

 Thank you. Could you tale me What are locales ?

 94 
 on: April 09, 2020, 12:08:02 PM 
Started by Nanar - Last post by CrazyCat
As someone said on IRC, first install locales on your VPS and then recompile your services.

 95 
 on: April 09, 2020, 11:31:31 AM 
Started by Nanar - Last post by Nanar
 It's there :
/home/anope/anope-2.0.7-source/language/anope.fr_FR.po

There's :
/home/anope/services

But in services there is not :
/locale/fr_FR/


In services there's only :
bin
conf
data
lib
logs


 96 
 on: April 09, 2020, 10:44:33 AM 
Started by Nanar - Last post by CrazyCat
3. There's on VPS server:
/home/anope/anope-2.0.7-source/language/anope.fr_FR.po

Have you /home/anope/services/locale/fr_FR/ (or whatever your install directory is) ?

 97 
 on: April 09, 2020, 09:46:08 AM 
Started by Nanar - Last post by Nanar
 Thank you for your nice answer, yes I did !

    languages = "ca_ES.UTF-8 de_DE.UTF-8 el_GR.UTF-8 es_ES.UTF-8 fr_FR.UTF-8 hu_HU.UTF-8 it_IT.UTF-8 nl_NL.UTF-8 pl_PL.UTF-8 pt_PT.UTF-8 ru_RU.UTF-8 tr_TR.UTF-8"

    defaultlanguage = "fr_FR.UTF-8"

The answer of nickserv :
Changes the language Services uses when sending messages to you (for example, when responding to a command you send) language should be chosen from the following list of supported languages: n_US (English)

And the problem is always there !

 98 
 on: April 07, 2020, 08:12:59 AM 
Started by Nanar - Last post by CrazyCat
Did you edit the block:
Code: [Select]
/*
         * A list of languages to load on startup that will be available in /nickserv set language.
         * Useful if you translate Anope to your language. (Explained further in docs/LANGUAGE).
         * Note that english should not be listed here because it is the base language.
         *
         * Removing .UTF-8 will instead use the default encoding for the language, eg. iso-8859-1 for western European languages.
         */
        languages = "fr_FR.UTF-8 fr_FR"

 99 
 on: April 07, 2020, 08:09:55 AM 
Started by Nanar - Last post by CrazyCat
I already met this error and it was a trouble with ulines.
Double check the things Lord255 pointed.

Verify:
  • unreal - link block for services
  • unreal - ulines block
  • anope - define block
  • anope - server info block
Usually, you may have a typo somewhere which makes the names mismatch.

 100 
 on: April 07, 2020, 08:04:11 AM 
Started by Nanar - Last post by Zemra
Check your u:lines

https://www.unrealircd.org/docs/Configuration#ULines_block

Pages: 1 ... 8 9 [10]