Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: 1 [2] 3 4 ... 10
 11 
 on: June 02, 2020, 01:41:06 PM 
Started by mcsaturn - Last post by CrazyCat
The meaning of the quote part of documentation is: "if you use unreal4 or higher, you must choose unreal4 as protocol".
This means that protocol "unreal" is for unreal versions up to 3.x

 12 
 on: May 31, 2020, 11:19:54 AM 
Started by mcsaturn - Last post by Lord255
no.
who said that?:D
i told you to set the module in anope to unreal4.

look: https://github.com/anope/anope/blob/c327d1aeefb372cff4dce26e482a8f087f871b71/data/example.conf#L247-L285
and:
Quote
UnrealIRCd 5 is compatible with the following services:
anope (version 2.0.7 or higher) - with the "unreal4" protocol module


 13 
 on: May 31, 2020, 10:05:02 AM 
Started by mcsaturn - Last post by mcsaturn
Hi.

So i need to install unreal 4, check for the module and put it on unreal 5 ?

That's it ?

Thx for your help ;)

 14 
 on: May 30, 2020, 10:18:25 PM 
Started by mcsaturn - Last post by Lord255
no worries for english, you are in a french topic.. i just cant speak it, so eng fits me more. ( or i could just google translate.. but.. :) )

about the protocol:
for unreal5 you need to use unreal4 in anope.

Quote
UnrealIRCd 5 is compatible with the following services:
anope (version 2.0.7 or higher) - with the "unreal4" protocol module

:)

 15 
 on: May 30, 2020, 10:10:18 PM 
Started by mcsaturn - Last post by mcsaturn
Hum ok i will test that tomorrow. After sleeping its better lol.

I will come here to say you if there are problem again.

Just now, server say me that : ERROR: Closing Link: services.ChatLesAmiZ.fr[127.0.0.1] (Server using old unsupported protocol from UnrealIRCd 3.2.x or earlier. See https://www.unrealircd.org/docs/FAQ#old-server-protocol)


But i use the last Unreal and the last anope service... I check tomorrow for the error.

Thanks for your help ! (and sorry for my bad english ;) )


 16 
 on: May 30, 2020, 09:42:54 PM 
Started by mcsaturn - Last post by Lord255
hoi.
so.. if you want to link your services to ircd via port 7000, you need to have a listen block for it.

according to your /stats P, you dont have only port 6900 ready for server connection, but with ssl.
(ssl == tls)

so..  two things which you can do:
1, remove tls from the port 6900 and try to link on localhost (127.0.0.1)
2, add a listen block with port 7000 (of course dont use tls option, just serversonly)


 17 
 on: May 30, 2020, 09:32:04 PM 
Started by mcsaturn - Last post by mcsaturn
This is what Stats P return to me

*** Listener on *:6900 (IPv6): has 0 client(s), options: serversonly tls
*** Listener on *:6900 (IPv4): has 0 client(s), options: serversonly tls
*** Listener on *:6697 (IPv6): has 0 client(s), options: tls
*** Listener on *:6697 (IPv4): has 1 client(s), options: tls
*** Listener on *:6667 (IPv6): has 0 client(s), options: plaintext
*** Listener on *:6667 (IPv4): has 3 client(s), options: plaintext

My services will be connect on port 7000

I had test on 6667 but it say me :

"Check that you are not connecting Anope to an SSL enabled port without configuring SSL in Anope (or vice versa)"  :o :o :o

 18 
 on: May 26, 2020, 11:57:42 PM 
Started by mcsaturn - Last post by Lord255
check if the port is open.
you can use either
$ netstat -anp | grep 7000
or check what /stats P says to you on irc.

probably you bind to a diff ip than what you are trying to connect to.

---- google translate too french .. -----
vérifiez si le port est ouvert.
vous pouvez utiliser soit
$ netstat -anp | grep 7000
ou vérifiez ce que /stats P vous dit sur irc.

vous vous connectez probablement à une adresse IP différente de celle à laquelle vous essayez de vous connecter.

 19 
 on: May 26, 2020, 11:37:02 PM 
Started by mcsaturn - Last post by mcsaturn
Bon j'avance un peu finalement... voici mon nouveau problème :

[May 26 18:31:54 2020] Attempting to connect to uplink #1 **.***.***.** (**.***.***.**), port 7000
[May 26 18:31:54 2020] Unable to connect to uplink #1 (**.***.***.**:7000): Connection refused
[May 26 18:31:54 2020] Unable to connect to any uplink

 20 
 on: May 24, 2020, 03:55:48 PM 
Started by Bruno Pontecorvo - Last post by Lord255
I've solved deleting the other user as Lord255 said......
After write /msg operserv login password I can access......

awesome. :)
and i dont recommend not using pw.. or at least use certfp.. but never without pw or anything..

and gj.

Pages: 1 [2] 3 4 ... 10