Anope IRC Services

Anope Support => 1.8.x/1.7.x Support => Topic started by: Philip on August 20, 2006, 04:20:03 AM

Title: Making the services (NickServ, ChanServ...) join a channel
Post by: Philip on August 20, 2006, 04:20:03 AM
How do I make the services (NickServ, ChanServ, BotServ..) and the Rest join a particular channel? I know of the os_clientjoin.dll module, but its not compatible with the newest version of Anope (1.7.15) It says Invalid handle. If there is another way I can do this I would like to know :) Thanks
Title:
Post by: hc2995 on August 20, 2006, 07:24:12 AM
i think you can use /invite SERVICE #CHANNEL but im not sure (correct me if im wrong :D)


yea forget it i tried they will get the invite but wont come to the channel :| (it worked on one of the networks i was on lol you could invite chanserv to hold the channel for you like a bot but its a services)

[Edited on 20-8-2006 by hc2995]

[Edited on 20-8-2006 by hc2995]
Title:
Post by: Jobe on August 20, 2006, 10:50:40 AM
Quote
Originally posted by Philip
How do I make the services (NickServ, ChanServ, BotServ..) and the Rest join a particular channel? I know of the os_clientjoin.dll module, but its not compatible with the newest version of Anope (1.7.15) It says Invalid handle. If there is another way I can do this I would like to know :) Thanks


I think all that needs doing is for that module to be recompiled to the latest version.
Title:
Post by: Tom65789 on August 20, 2006, 12:06:48 PM
http://www.area51designz.com/c/anope/os_clientjoin.dll

i had it uploaded anyway for some reason, and its updated from the one on the modules site to work best with the 1.7 series too :)

see the .c file for the configuration values to put into your services.conf as well.

http://www.area51designz.com/c/anope/os_clientjoin.c
Title:
Post by: Jobe on August 20, 2006, 12:25:52 PM
To be honest the Anope clients (ChanServ, NickServ, BotServ, etc...) are not designed to be in a channel anyway. That's why there are BotServ bots.
Title:
Post by: Philip on August 20, 2006, 02:20:02 PM
Quote
Originally posted by Tom65789
http://www.area51designz.com/c/anope/os_clientjoin.dll

i had it uploaded anyway for some reason, and its updated from the one on the modules site to work best with the 1.7 series too :)

see the .c file for the configuration values to put into your services.conf as well.

http://www.area51designz.com/c/anope/os_clientjoin.c


Million Thanks to you!
Title:
Post by: Tom65789 on August 20, 2006, 02:38:50 PM
never tested it or anything so just let me know if you have any issues with it
Title:
Post by: Philip on August 20, 2006, 07:13:04 PM
yeah, i'm having a little problem with it, here is the message

[14:11] -OperServ- Unable to load module os_clientjoin.dll

I don't know the problem with it , I registered my nick, and Im the services Root admin.
Title:
Post by: Jobe on August 20, 2006, 07:22:18 PM
try "/os modload os_clientjoin" without the .dll extension
Title:
Post by: Philip on August 20, 2006, 07:25:01 PM
[14:25] -OperServ- Unable to load module os_clientjoin
Title:
Post by: katsklaw on August 20, 2006, 07:36:14 PM
check your log file .. that's where errors are logged.
Title:
Post by: Philip on August 20, 2006, 07:54:16 PM
The specified module could not be found.

Thats the error its giving
Title:
Post by: n00bie on August 20, 2006, 08:00:03 PM
Put os_clientjoin.dll inside data/modules folder.
Title:
Post by: Philip on August 20, 2006, 09:30:42 PM
it is there, but still giving the same error
Title:
Post by: Tom65789 on August 21, 2006, 02:06:45 AM
and now it has been fixed. caught me up with it on IRC. was complain about the different versions. because of the manifest and such like but all is fixed
Title:
Post by: dudMan2028 on August 28, 2006, 02:30:21 AM
What happens if services crash while theyre joined to a channel, or some stupid op kicks them?

anything bad?

thanks..
Title:
Post by: Tom65789 on August 28, 2006, 08:49:26 AM
if the services crash while joining to a channel they will just quit. and if a op kicks them they just get kicked. nothing happens
Title:
Post by: Jan Milants on August 28, 2006, 10:15:22 AM
if you are afraid of bad things happening, you shouldn't join those clients to a channel at all... only cause of desyncs...
for example if some1 kicks one of the services clients, anope would receive a kick event for a user it doesn't even know is on the channel... but no, nothing bad that is visible should happen...

[Edited on 28-8-2006 by Viper]
Title:
Post by: PreciousAlly on September 04, 2006, 08:32:05 PM
Yeah... I'm getting the same error as Philip. Can someone help me please? Thanks!

Kind Regards,
Allison
Title:
Post by: n00bie on September 04, 2006, 09:21:42 PM
PreciousAlly, have you tried the updated module by Tom65789 ?
take a look at this link: http://forum.anope.org/viewthread.php?tid=774
Title:
Post by: Tom65789 on September 04, 2006, 10:37:01 PM
the link is in this thread to. they just need to read but here it is again for reference:

http://www.area51designz.com/c/anope/os_clientjoin.c

Windows dll:

http://www.area51designz.com/c/anope/os_clientjoin.dll
Title:
Post by: PreciousAlly on September 05, 2006, 05:12:21 AM
I'm confused... I downloaded the windows DLL file, I placed it in the DATA/MODULES folder, and typed: '/os modload os_clientjoin.dll', and even tried typing it without the .DLL extension, but I still recieve this error:

-OperServ- Unable to load module os_clientjoin

I'm not very experienced with Anope/IRCd, I actually had to read a dummy guide on the net for setting up an IRC server using Unreal IRCd, and Anope services. In which I'm not exactly sure what to do with the other file that was linked above (os_clientjoin.c) Any help would be great. Thanks. :)

Regards,
Allison
Title:
Post by: Tom65789 on September 05, 2006, 08:14:28 AM
need to know what error u are getting. follow these:

/msg OperServ set debug on
/msg OperServ modload os_clientjoin
/msg OperServ set debug off

then paste the results from the log file here
Title:
Post by: Gman on September 05, 2006, 11:16:10 AM
I'm receive a C++ runtime error when I loaded this module and services craches...
Title:
Post by: Tom65789 on September 05, 2006, 11:45:16 AM
like i said before. get logs of errors otherwise i cant do anything

/msg OperServ set debug on
/msg OperServ modload os_clientjoin
*wait til you get the error*
/msg OperServ set debug off
Title:
Post by: PreciousAlly on September 05, 2006, 05:09:54 PM
Well, at first when I type: "/os modload os_clientjoin", I get a pop-up that says: "This application has failed to start because MSVCR80.dll was not found. Re-installing the application may fix this problem."

In the logs, I get this:

"[Sep 05 12:03:26 2006] OperServ: PreciousAlly: set debug on
[Sep 05 12:03:26 2006] Debug mode activated
[Sep 05 12:03:26 2006] debug: Sent: :OperServ NOTICE PreciousAlly :Services are now in debug mode.
[Sep 05 12:03:28 2006] debug: Received: :PreciousAlly PRIVMSG OperServ@services.thesims2source.com :modload os_clientjoin
[Sep 05 12:03:28 2006] OperServ: PreciousAlly: modload os_clientjoin
[Sep 05 12:03:28 2006] Trying to load module [os_clientjoin]
[Sep 05 12:03:28 2006] Runtime module location: .\modules\runtime\os_clientjoin.dll.a10860
[Sep 05 12:03:31 2006] The specified module could not be found.


[Sep 05 12:03:31 2006] debug: Sent: :OperServ NOTICE PreciousAlly :Unable to load module os_clientjoin
[Sep 05 12:03:31 2006] Module loading status: 6
[Sep 05 12:03:35 2006] debug: Received: :PreciousAlly PRIVMSG OperServ@services.thesims2source.com :set debug off
[Sep 05 12:03:35 2006] OperServ: PreciousAlly: set debug off
[Sep 05 12:03:35 2006] Debug mode deactivated"
Title:
Post by: PreciousAlly on September 05, 2006, 05:13:52 PM
Gman, maybe try downloading THIS (http://www.microsoft.com/downloads/details.aspx?FamilyID=32bc1bee-a3f9-4c13-9c99-220b62a191ee&DisplayLang=en)
Title:
Post by: Tom65789 on September 05, 2006, 07:22:01 PM
[Sep 05 12:03:31 2006] The specified module could not be found.

it obviously cant find it for some reason. are you sure its in /data/modules/ ??
Title:
Post by: PreciousAlly on September 05, 2006, 07:57:53 PM
[edit by Rob]
Sorry, i've deleted this post, there are so many issues with using raw its best not to post strings on here, as a general rule, we dont even try to support networks using the Raw command as as soon as you use it, you have (almost certainly) caused a de-sync in the state of the network i.e. services think one thing, and the ircd thinks another, which more often than not, leads to "odd" bugs in both the ircd and services.

Rob
[/edit]

[Edited on 5-9-2006 by Rob]
Title:
Post by: Jan Milants on September 05, 2006, 08:22:02 PM
what you just posted is not supported....

could a mod delete these references to *** ?

[Edited on 5-9-2006 by Viper]
Title:
Post by: Tom65789 on September 05, 2006, 08:33:57 PM
i'll just quote :)

"RAW is a developer tool ONLY. Only a fool would ever have it enabled on a network with real users. RAW has the ability to crash your network, desync your services and comprimise any network security you have. You may be banned for typing raw strings in this room, and we refuse to support people who have raw enabled."

so some of you may have lost support \o/ as Rob edited that post too

[Edited on 5-9-2006 by Tom65789]
Title:
Post by: PreciousAlly on September 05, 2006, 08:56:42 PM
Ooops, my apologies... I'm not aware of the commands harm, I was just given the command from a friend who I asked if it was possible to make the network services join the channel. It won't happen again. :)

Regards,
Allison
Title:
Post by: Tom65789 on September 05, 2006, 09:08:52 PM
and that is what the module is for. better to use this module rather than RAW
Title:
Post by: Gman on September 06, 2006, 10:06:15 AM
Thanks, Tom and PreciousAlly

I downloaded a new version of Anope (1.7.15) and all successfully working :)
Title:
Post by: Ajay on September 10, 2006, 09:35:19 AM
deleted.


[Edited on 10-9-2006 by Rob]


Ajay: Sorry, I have used raw before and it never caused any problems. I still don't know what kind of damage it could do but I guess you guess would know better than me. ;) I just thought since posters in this thread are going through all the trouble of doing this that they might have wanted a simple alternative.

[Edited on 10-9-2006 by Ajay]
Title:
Post by: Tom65789 on September 10, 2006, 11:37:59 AM
k let me make this clear.

RAW is very dodgy and should NEVER be USED. this MODULE is to work instead of using RAW. so STOP posting RAW strings because as said above. those that have posted RAW strings obviously have used it, therefore if you have any problems it is most likely you will NOT get support because it may be something you caused yourself so the devs will be looking for a problem that doesnt exist.
Title:
Post by: owine on September 10, 2006, 06:04:57 PM
here is what i get tom
Code: [Select]
[Sep 10 17:02:45.415897 2006] debug: Received: :owine PRIVMSG operserv@services.hak5.org :modload os_clientjoin
[Sep 10 17:02:45.416406 2006] OperServ: owine: modload os_clientjoin
[Sep 10 17:02:45.416531 2006] Trying to load module [os_clientjoin]
[Sep 10 17:02:45.418272 2006] Runtime module location: /home/hak5/services/modules/runtime/os_clientjoin.so.85ZHwm
[Sep 10 17:02:45.421634 2006] Module os_clientjoin compiled against current or newer anope revision 1128, this is 1128
[Sep 10 17:02:45.422080 2006] Displaying command list for CLIENTJOIN
[Sep 10 17:02:45.422126 2006] 1:  0x0x8549600
[Sep 10 17:02:45.422160 2006] end
[Sep 10 17:02:45.422291 2006] debug: existing msg: (0x0x851bd00), new msg (0x0x8545d40)
[Sep 10 17:02:45.422328 2006] Displaying message list for reload
[Sep 10 17:02:45.422359 2006] 1: 0x0x8545d40
[Sep 10 17:02:45.422390 2006] 2: 0x0x851bd00
[Sep 10 17:02:45.422421 2006] 3: 0x0x8511440
[Sep 10 17:02:45.422451 2006] 4: 0x0x8502600
[Sep 10 17:02:45.422482 2006] 5: 0x0x8502520
[Sep 10 17:02:45.422513 2006] 6: 0x0x84f2ce0
[Sep 10 17:02:45.422543 2006] 7: 0x0x84f20e0
[Sep 10 17:02:45.422574 2006] end
[Sep 10 17:02:45.425155 2006] os_clientjoin: Config: OSClientJoinModes: [+sOi]
[Sep 10 17:02:45.425631 2006] os_clientjoin: Config: OSClientJoinBots: [1] - BotServ bots will now join on the command.
[Sep 10 17:02:45.425823 2006] PANIC! buffer = :owine PRIVMSG operserv@services.hak5.org :modload os_clientjoin
[Sep 10 17:02:45.426145 2006] debug: Sent: :services.hak5.org GLOBOPS :PANIC! buffer = :owine PRIVMSG operserv@services.hak5.org :modload os_clientjoin

any help would be appreciated... thanks
Title:
Post by: Tom65789 on September 10, 2006, 06:55:33 PM
k. did a very quick change to it. havent tested it because i am in a rush but download it from here again:

http://www.area51designz.com/c/anope/os_clientjoin.c
http://www.area51designz.com/c/anope/os_clientjoin.dll


havent tested it so make sure you test it before using it on a public network