Anope IRC Services

Anope Support => 1.8.x/1.7.x Support => Topic started by: yourtime on August 18, 2008, 03:02:08 AM

Title: another odd problem :/
Post by: yourtime on August 18, 2008, 03:02:08 AM
Okay, this time I have another odd problem:
-I wget an Anope module, put it in services/src/modules
-I go back to services/
-I type "make modules"
-Reply: "make: Nothing to be done for `modules'."

any idea? (the src file is chmod'ed to 0777)
Title: Re: another odd problem :/
Post by: deiks on August 18, 2008, 09:00:16 AM
put it in /home/anope<version>/src/modules

not services..
Title: Re: another odd problem :/
Post by: Jan Milants on August 18, 2008, 10:26:24 AM
actually if he put it in "services/src/modules" it should be ok.. the runtime dir doesn't have a /src/, so he must have renamed it..
which module did you wget if i might ask.. check it for custom installation instructions.
Title: Re: another odd problem :/
Post by: yourtime on August 18, 2008, 04:37:19 PM
yeah my anope is installed to services/
the module is ircd_vhostserv.c
Title: Re: another odd problem :/
Post by: Charles Kingsley on August 18, 2008, 05:58:03 PM
If anope is "make installed" into ~/services then the module source needs to be wget'd into the src directory of anope.

Typically, a user extracts the anope tarball to ~/anope-1.7.21/ where you'd put the module.c into ~/anope-1.7.21/src/modules and nip back to ~/anope-1.7.21 and make modules and make install which would compile, and install the module into ~/services