Anope IRC Services

Anope Support => 1.8.x/1.7.x Support => Topic started by: yourtime on August 17, 2008, 01:08:39 PM

Title: Issue with services
Post by: yourtime on August 17, 2008, 01:08:39 PM
Hi-

I have recently configured Unreal 3.2.7 with Anope for services. In unrealircd.conf I have myself down as a "services-admin;" (along with other things) and I have my nick as ServicesRoot services.conf.

When I /oper [user] [pass], I have access to everything I would have expected, aside from administration abilities within the services.  For example, when trying to add a new bot to BotServ, I get access denied.

Thanks for your help!
Title: Re: Issue with services
Post by: katsklaw on August 17, 2008, 01:16:20 PM
You need to be opered, identified and using a nick on the Services Admin list or higher.

you MUST be all 3!

do /os staff and see if your nick has either ADMN or ROOT as well as an asterisk (*) next to it. If it doesn't, you are not all 3.

Should look like:

[08.19.38] -OperServ-  * ROOT  katsklaw
Title: Re: Issue with services
Post by: yourtime on August 17, 2008, 01:33:28 PM
it has "* ROOT" next to my nick :/
Title: Re: Issue with services
Post by: katsklaw on August 17, 2008, 01:45:05 PM
when I said you must be opered, that means as a global operator. If you are not opered or are a local oper, then you'll lack access. please double check your ircd's documetation to insure you have all your O:Line stuff correct.

There is no other reason to be denied access to anything other than SuperAdmin privs as an properly qualified SRA.
Title: Re: Issue with services
Post by: yourtime on August 17, 2008, 01:51:59 PM
I'm oper'ed as global, netadmin, services-admin, etc., hence my problem and why I'm stuck, thanks btw
Title: Re: Issue with services
Post by: katsklaw on August 17, 2008, 02:29:36 PM
well those are the only reasons you won't have BS access. Have you tried any oper serv commands? like /os restart?
Title: Re: Issue with services
Post by: yourtime on August 17, 2008, 02:40:51 PM
I get the same "Access Denied." message
Title: Re: Issue with services
Post by: Jan Milants on August 17, 2008, 02:48:29 PM
paste the output of /os staff and /whois <yournick> (you can/should your ip of course)...
Title: Re: Issue with services
Post by: yourtime on August 17, 2008, 03:09:19 PM
ha! nevermind guys, another friend of mine helped me fix it, I made a stupid mistake.

Thanks alot anyway! :)
Title: Re: Issue with services
Post by: deiks on August 17, 2008, 04:51:25 PM
You can paste your mistake.. Maybe some users make same mistakes.
It can help them..