Anope IRC Services

Anope Support => 1.8.x/1.7.x Support (Read Only) => Topic started by: BullDog on January 26, 2008, 04:05:38 AM

Title: Compile problem: WinXP and Anope 1.7.21
Post by: BullDog on January 26, 2008, 04:05:38 AM
Ok, so, first off, before anybody asks why I'm attempting to compile on a Win32 platform, it's in case I wanted to add any modules on later.

Now, on to my problem. I have a little issue with compiling Anope 1.7.21, on WinXP SP2. It appears it manages to get everything compiled, until it gets to linking:


   Creating library anope.lib and object anope.exp
misc.obj : error LNK2019: unresolved external symbol __imp__GetSystemMetrics@4 referenced in function _GetWindowsVersion
anope.exe : fatal error LNK1120: 1 unresolved externals
NMAKE : fatal error U1077: '"C:\Program Files\Microsoft Visual Studio 9.0\VC\BIN\cl.EXE"' : return code '0x2'
NMAKE : fatal error U1077: 'cd' : return code '0x2'

I'm normally tech-minded but this one has me stumped. It's possible I missed something simple I was supposed to do or change before I started compiling (I ran the config.bat as instructed), I'm probably just too tired at this moment to figure it out.

Anybody have any ideas what caused that? And if any additional info is needed, please let me know.

Oh, right, also, build environment is:
> Microsoft Visual C++ 2008 Express Edition
> New Platform SDK (WinServer2003 R2)
> Win XP Home
Post by: Jan Milants on January 26, 2008, 11:23:20 AM
and i thought it was because i was compiling on Vista... i have exactly the same problem...
well had actually because i modified the src to get around it, but i ll report it as a bug now i know it s not just me :)
Post by: Jan Milants on January 26, 2008, 02:40:24 PM
issue has been solved in SVN
Post by: BullDog on January 26, 2008, 07:52:07 PM
Ah, good to know I wasn't the only one.

And thanks for the help, I'll get the SVN then.