Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: [BUG] CS Enforce  (Read 3763 times)

0 Members and 1 Guest are viewing this topic.

Bandit

  • Guest
[BUG] CS Enforce
« on: June 21, 2006, 04:37:59 AM »

Hello, I think I have discovered an Anope bug.  Whenever I try to enforce a mode(s) on a channel, I get the following message:


Quote

(23:29:19) -elite.phatlogic.com- *** Global -- from services.phatlogic.com: PANIC! buffer = :Bandit PRIVMSG chanserv@services.phatlogic.com :enforce #phatlogic +m


what caused that was when I typed /cs enforce #chan +m.

After that, the services stop responding and they eventually crash.  Very dangerous....this can be used to temporarily bringing down services for a network.
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
(No subject)
« Reply #1 on: June 21, 2006, 10:22:07 AM »

Works fine for me, can you give us some more information as to what version of anope, what modules, and also provide a backtrace from anope running in debug mode.

Join the irc chan if you need a hand.
Logged

Bandit

  • Guest
(No subject)
« Reply #2 on: June 21, 2006, 05:11:24 PM »

Chaz, good to see ya again :)  Sorry I'm such an idiot, I really don't know how to run anope in debug mode, and plus i have to go in like two minutes...I'll edit this post when I return.  But I am running anope 1.7.14 and also Unreal3.2.5  I currently don't have any 3rd party modules installed.
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
(No subject)
« Reply #3 on: June 21, 2006, 05:25:12 PM »

Hey buddy,

When you get back, instead of running ./services run

gdb
run ./services -debug -nofork
*Go ahead and crash anope.*
bt full

Copy and paste the output into a post here. Or come on IRC and someone will help you .. I'm heading out soon too.
Logged
Pages: [1]   Go Up