Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: 1 [2]   Go Down

Author Topic: Backing up fails. Anope gives errors.  (Read 17667 times)

0 Members and 1 Guest are viewing this topic.

katsklaw

  • Guest
(No subject)
« Reply #25 on: June 26, 2008, 01:09:51 AM »

this forum has a built in PM system. I wouldn't waste too much time getting the info to me .. this offer DOES expire.

[Edited on 26-6-2008 by katsklaw]
Logged

katsklaw

  • Guest
(No subject)
« Reply #26 on: June 26, 2008, 10:52:42 AM »

to okami,

You need to make sure that the data\backups directory exists. For some reason it was excluded from the installer and on Windows it doesn't auto create. *nix doesn't have this issue,
Logged

TommyGun

  • Anope User
  • Offline Offline
  • Posts: 11
(No subject)
« Reply #27 on: June 26, 2008, 06:12:42 PM »

U got PM
Logged

katsklaw

  • Guest
(No subject)
« Reply #28 on: June 26, 2008, 11:52:00 PM »

TommyGun,

1> That install is in the root group, which means you didn't install as a non-root user as you was clearly instructed.
2> I wouldn't be able to re-compile because you deleted the source directory, which is rather important since you didn't set Anope's default permissions. So I don't have all the resources needed to insure all steps are followed.
3> As per #2 I can't change the default permissions back to what they were and they are not set to now because again the source directory is missing. This is important because the permissions set during configuration is the permissions used by Anope forever until told otherwise, thus chmod will not be enough to fix the issue.
4> Also because of #2 you have prevented me from completing all steps required to insure that your backups work properly. Therefore I can no longer help you.
5> The creation timestamps on all the files are the same day that you last successfully backup, this suggests something has changed. Like say moved from one box to another and the new compile is not the same as the old, namely permissions. Which you was also clearly instructed that permissions is a primary reason for the backups to fail.

In short you failed to follow all instructions and wasted my time. The login information that you PM'ed to me has been deleted as I no longer need it.

Good luck fixing your services.

ciao.

PS: It's not a good idea to run your IRCd as root either. Additionally as a side note, Anope1.6.4 does not fully support Unreal 3.2 .. I suggest you upgrade to 1.7.21 if you wish to continue using that ircd. Also, do NOT delete the source directory as you will likely need it again in the future.
Logged

Keiro

  • Anope User
  • Offline Offline
  • Posts: 35
Re: Backing up fails. Anope gives errors.
« Reply #29 on: July 19, 2008, 03:49:26 PM »

facepalmed

Directory issues.

Figures.

:@ Well, at least it should be fixable the next time I reinstall Anope+UnrealIRCD

At this time though, I'm running Ubuntu with Anope.

It is working quite well now. :D 1.7.21 and 3.2.7 for those of you wondering what versions I'm running. >_>;
Logged
Pages: 1 [2]   Go Up