Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  


Pages: [1]   Go Down

Author Topic: Anope aliases don't function, running in circles attempting to figure it out.  (Read 2882 times)

0 Members and 1 Guest are viewing this topic.


  • Anope User
  • Offline Offline
  • Posts: 2

We have a properly setup UnrealIRCD (latest stable build) and the development build of Anope successfully installed.
Unreal nor Anope have plugins or w/e
Unreal and Anope are properly linked.
The problem:
We can't get /ns or any other aliases to properly function.
When a user uses "/msg nickserv identify", the server properly responds with the syntax correction/help.
When running the services as -nofork -debug, I can see the message is properly accepted.
[Jul 21 05:50:56.837254 2008] debug: Received: :bobsmith PRIVMSG nickserv :identify
[Jul 21 05:50:56.837501 2008] debug: Sent: :NickServ NOTICE bobsmith :Syntax: IDENTIFY password
[Jul 21 05:50:56.837554 2008] debug: Sent: :NickServ NOTICE bobsmith :/msg NickServ HELP IDENTIFY for more information.
HOWEVER when the user attempts to use /ns identify, or any command with the nickserv (or any other services), the message is properly received by the services
[Jul 21 05:52:40.481256 2008] debug: Received: :bobsmith PRIVMSG nickserv@>---Censored IRCD ip---< :identify
Yet the service does no response, or even acknowledgment of the message.

We are using the standard anope aliases that are included with the UnrealIRCD, and the includes for the aliases are properly set in the ircd config.
In the "Services Identifcation and Pseudoclient names" section, we adjusted the services user, aliases names, and turned on/off the #usestrictprivmsg, and played with the "ns def msg" option
« Last Edit: July 21, 2008, 07:07:21 AM by spaceship9 »


  • Guest

Aliases have nothing to do with Anope except being the target. This is 100% an ircd issue. Since they do not work, then they are NOT set-up correctly.

You need to follow the directions for Unreal found at Example #2 is including the aliases file, then insure set::services-name matches the name you gave to services.

the fact that you have: debug: Received: :bobsmith PRIVMSG nickserv@>---Censored IRCD ip---< :identify, tells me you have not configured Unreal correctly because that shouldn't be your IRCd's IP, it should be the name you gave to services as seen in services.conf, ServerName.
Pages: [1]   Go Up